aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alsa
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-03-12 06:09:54 +0000
committerJohn Lee <john_lee@openmoko.org>2008-03-12 06:09:54 +0000
commit77b4afc360d84af02638eeb39ff2c2e31eed2fc0 (patch)
treed7d1b72a56db7fccb1ea80f302fd9c8f7fa28cd6 /packages/alsa
parent11a927c21ec3e58d33a71bb3a4ed7788a3faf54c (diff)
downloadopenembedded-77b4afc360d84af02638eeb39ff2c2e31eed2fc0.tar.gz
alsa-state: sync upstream from XorA
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-state.bb2
-rw-r--r--packages/alsa/alsa-state/fic-gta02/gsmhandset.state142
2 files changed, 85 insertions, 59 deletions
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
index 3d12b5d3cd..16fee583d4 100644
--- a/packages/alsa/alsa-state.bb
+++ b/packages/alsa/alsa-state.bb
@@ -8,7 +8,7 @@ DESCRIPTION = "Default ALSA configuration"
LICENSE = "GPL"
RRECOMMENDS_alsa-state = "alsa-states"
PV = "0.1.0"
-PR = "r12"
+PR = "r13"
SRC_URI = " \
file://asoundrc \
diff --git a/packages/alsa/alsa-state/fic-gta02/gsmhandset.state b/packages/alsa/alsa-state/fic-gta02/gsmhandset.state
index cc0d32a7c7..722ce88425 100644
--- a/packages/alsa/alsa-state/fic-gta02/gsmhandset.state
+++ b/packages/alsa/alsa-state/fic-gta02/gsmhandset.state
@@ -26,8 +26,8 @@ state.neo1973gta02 {
comment.range '0 - 127'
iface MIXER
name 'Headphone Playback Volume'
- value.0 121
- value.1 121
+ value.0 0
+ value.1 0
}
control.4 {
comment.access 'read write'
@@ -46,7 +46,7 @@ state.neo1973gta02 {
comment.range '0 - 127'
iface MIXER
name 'Mono Playback Volume'
- value 115
+ value 121
}
control.6 {
comment.access 'read write'
@@ -85,7 +85,7 @@ state.neo1973gta02 {
iface MIXER
name 'Headphone Playback ZC Switch'
value.0 false
- value.1 true
+ value.1 false
}
control.10 {
comment.access 'read write'
@@ -94,7 +94,7 @@ state.neo1973gta02 {
iface MIXER
name 'Speaker Playback ZC Switch'
value.0 false
- value.1 true
+ value.1 false
}
control.11 {
comment.access 'read write'
@@ -103,7 +103,7 @@ state.neo1973gta02 {
comment.range '0 - 7'
iface MIXER
name 'Mono Bypass Playback Volume'
- value 3
+ value 2
}
control.12 {
comment.access 'read write'
@@ -112,7 +112,7 @@ state.neo1973gta02 {
comment.range '0 - 7'
iface MIXER
name 'Mono Sidetone Playback Volume'
- value 1
+ value 2
}
control.13 {
comment.access 'read write'
@@ -121,7 +121,7 @@ state.neo1973gta02 {
comment.range '0 - 7'
iface MIXER
name 'Mono Voice Playback Volume'
- value 1
+ value 2
}
control.14 {
comment.access 'read write'
@@ -171,7 +171,7 @@ state.neo1973gta02 {
comment.range '0 - 15'
iface MIXER
name 'Treble Volume'
- value 7
+ value 0
}
control.19 {
comment.access 'read write'
@@ -209,8 +209,8 @@ state.neo1973gta02 {
comment.range '0 - 63'
iface MIXER
name 'Capture Volume'
- value.0 24
- value.1 24
+ value.0 23
+ value.1 23
}
control.23 {
comment.access 'read write'
@@ -276,7 +276,7 @@ state.neo1973gta02 {
comment.range '0 - 7'
iface MIXER
name 'ALC Capture Max Volume'
- value 1
+ value 7
}
control.30 {
comment.access 'read write'
@@ -288,7 +288,7 @@ state.neo1973gta02 {
comment.item.3 Stereo
iface MIXER
name 'ALC Capture Function'
- value Stereo
+ value Left
}
control.31 {
comment.access 'read write'
@@ -305,7 +305,7 @@ state.neo1973gta02 {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Hold Time'
- value 7
+ value 15
}
control.33 {
comment.access 'read write'
@@ -495,6 +495,16 @@ state.neo1973gta02 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
+ comment.item.0 'Non Inverted'
+ comment.item.1 Inverted
+ iface MIXER
+ name 'ROUT2 Phase'
+ value Inverted
+ }
+ control.53 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
comment.item.0 'Mic 1'
comment.item.1 'Mic 2'
comment.item.2 'Mic 3'
@@ -502,7 +512,7 @@ state.neo1973gta02 {
name 'Mic Selection Mux'
value 'Mic 1'
}
- control.53 {
+ control.54 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -514,7 +524,7 @@ state.neo1973gta02 {
name 'Rx Mixer'
value 'RXP - RXN'
}
- control.54 {
+ control.55 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -526,7 +536,7 @@ state.neo1973gta02 {
name 'Line Mixer'
value 'Line 1 + 2'
}
- control.55 {
+ control.56 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -536,7 +546,7 @@ state.neo1973gta02 {
name 'Line Mono Mux'
value 'Line Mix'
}
- control.56 {
+ control.57 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -546,7 +556,7 @@ state.neo1973gta02 {
name 'Line Right Mux'
value 'Rx Mix'
}
- control.57 {
+ control.58 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -556,7 +566,7 @@ state.neo1973gta02 {
name 'Line Left Mux'
value 'Rx Mix'
}
- control.58 {
+ control.59 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -564,7 +574,7 @@ state.neo1973gta02 {
name 'ALC Mixer Line Capture Switch'
value false
}
- control.59 {
+ control.60 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -572,7 +582,7 @@ state.neo1973gta02 {
name 'ALC Mixer Mic2 Capture Switch'
value true
}
- control.60 {
+ control.61 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -580,7 +590,7 @@ state.neo1973gta02 {
name 'ALC Mixer Mic1 Capture Switch'
value false
}
- control.61 {
+ control.62 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -588,7 +598,7 @@ state.neo1973gta02 {
name 'ALC Mixer Rx Capture Switch'
value false
}
- control.62 {
+ control.63 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -600,7 +610,7 @@ state.neo1973gta02 {
name 'Mic Sidetone Mux'
value 'Left PGA'
}
- control.63 {
+ control.64 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -611,7 +621,7 @@ state.neo1973gta02 {
name 'Capture Right Mux'
value PGA
}
- control.64 {
+ control.65 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -622,7 +632,7 @@ state.neo1973gta02 {
name 'Capture Left Mux'
value PGA
}
- control.65 {
+ control.66 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -634,7 +644,7 @@ state.neo1973gta02 {
name 'Capture Right Mixer'
value Stereo
}
- control.66 {
+ control.67 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -646,7 +656,7 @@ state.neo1973gta02 {
name 'Capture Left Mixer'
value Stereo
}
- control.67 {
+ control.68 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -654,7 +664,7 @@ state.neo1973gta02 {
name 'Playback Mixer Voice Capture Sw'
value false
}
- control.68 {
+ control.69 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -662,7 +672,7 @@ state.neo1973gta02 {
name 'Playback Mixer Left Capture Swi'
value false
}
- control.69 {
+ control.70 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -670,7 +680,7 @@ state.neo1973gta02 {
name 'Playback Mixer Right Capture Sw'
value false
}
- control.70 {
+ control.71 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -681,7 +691,7 @@ state.neo1973gta02 {
name 'Out4 Mux'
value VREF
}
- control.71 {
+ control.72 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -692,7 +702,7 @@ state.neo1973gta02 {
name 'Out3 Mux'
value VREF
}
- control.72 {
+ control.73 {
comment.access 'read write'
comment.type ENUMERATED
comment.count 1
@@ -704,7 +714,7 @@ state.neo1973gta02 {
name 'Mono 2 Mux'
value 'Inverted Mono 1'
}
- control.73 {
+ control.74 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -712,7 +722,7 @@ state.neo1973gta02 {
name 'Mono Mixer Left Playback Switch'
value false
}
- control.74 {
+ control.75 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -720,7 +730,7 @@ state.neo1973gta02 {
name 'Mono Mixer Right Playback Switc'
value false
}
- control.75 {
+ control.76 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -728,7 +738,7 @@ state.neo1973gta02 {
name 'Mono Mixer Voice Playback Switc'
value false
}
- control.76 {
+ control.77 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -736,7 +746,7 @@ state.neo1973gta02 {
name 'Mono Mixer Sidetone Playback Sw'
value true
}
- control.77 {
+ control.78 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -744,7 +754,7 @@ state.neo1973gta02 {
name 'Mono Mixer Bypass Playback Swit'
value false
}
- control.78 {
+ control.79 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -752,31 +762,31 @@ state.neo1973gta02 {
name 'Right Mixer Voice Playback Swit'
value false
}
- control.79 {
+ control.80 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
name 'Right Mixer Sidetone Playback S'
- value true
+ value false
}
- control.80 {
+ control.81 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
name 'Right Mixer Right Playback Swit'
- value false
+ value true
}
- control.81 {
+ control.82 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
name 'Right Mixer Bypass Playback Swi'
- value false
+ value true
}
- control.82 {
+ control.83 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -784,7 +794,7 @@ state.neo1973gta02 {
name 'Left Mixer Voice Playback Switc'
value false
}
- control.83 {
+ control.84 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -792,15 +802,15 @@ state.neo1973gta02 {
name 'Left Mixer Sidetone Playback Sw'
value false
}
- control.84 {
+ control.85 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
name 'Left Mixer Left Playback Switch'
- value false
+ value true
}
- control.85 {
+ control.86 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -808,15 +818,15 @@ state.neo1973gta02 {
name 'Left Mixer Bypass Playback Swit'
value true
}
- control.86 {
+ control.87 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
iface MIXER
name 'DAPM Stereo Out Switch'
- value true
+ value false
}
- control.87 {
+ control.88 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -824,7 +834,7 @@ state.neo1973gta02 {
name 'DAPM GSM Line Out Switch'
value true
}
- control.88 {
+ control.89 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -832,7 +842,7 @@ state.neo1973gta02 {
name 'DAPM GSM Line In Switch'
value false
}
- control.89 {
+ control.90 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -840,7 +850,7 @@ state.neo1973gta02 {
name 'DAPM Headset Mic Switch'
value false
}
- control.90 {
+ control.91 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -848,7 +858,7 @@ state.neo1973gta02 {
name 'DAPM Handset Mic Switch'
value true
}
- control.91 {
+ control.92 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 1
@@ -856,4 +866,20 @@ state.neo1973gta02 {
name 'DAPM Handset Spk Switch'
value true
}
+ control.93 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Amp State Switch'
+ value false
+ }
+ control.94 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Amp Spk Switch'
+ value false
+ }
}