aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alsa
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-20 12:53:10 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-20 12:53:10 +0000
commita9b6a0a881c44ec67bb87cf5116b0304f7786ecd (patch)
tree2bcdb5705e94cc6833a8dbe936ba430ebd53c4e2 /packages/alsa
parent6bf5dd04cdb06e971d33ce36768b95e03c5de9b1 (diff)
downloadopenembedded-a9b6a0a881c44ec67bb87cf5116b0304f7786ecd.tar.gz
alsa-driver: package midi/misc modules separately instead of deleting them (not all are actually built right now). re-enable sequencer. make configure checks work.
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-driver_0.9.6-hh4c.bb30
1 files changed, 21 insertions, 9 deletions
diff --git a/packages/alsa/alsa-driver_0.9.6-hh4c.bb b/packages/alsa/alsa-driver_0.9.6-hh4c.bb
index deb4ee4505..d8f7dcfa0b 100644
--- a/packages/alsa/alsa-driver_0.9.6-hh4c.bb
+++ b/packages/alsa/alsa-driver_0.9.6-hh4c.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Alsa Drivers"
MAINTAINER = "Pigi"
SECTION = "base"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.handhelds.org/packages/alsa-driver/alsa-driver-${PV}.tar.gz \
file://sound.p.patch;patch=1 \
@@ -12,14 +12,33 @@ SRC_URI = "ftp://ftp.handhelds.org/packages/alsa-driver/alsa-driver-${PV}.tar.gz
inherit autotools module
-EXTRA_OECONF=" --with-sequencer=no \
+EXTRA_OECONF = "--with-sequencer=yes \
--with-isapnp=no \
--with-oss=yes \
--with-kernel=${STAGING_KERNEL_DIR} \
--with-kernel-version=${KERNEL_VERSION}"
+PACKAGES =+ "${PN}-midi ${PN}-misc"
FILES_${PN} = "/lib/modules/*/misc/snd* \
${sysconfdir}/modutils/*"
+midi_modules = "snd-seq-midi-emul.o \
+ snd-seq-midi-event.o \
+ snd-seq-midi.o \
+ snd-seq-virmidi.o \
+ snd-seq-oss.o"
+FILES_${PN}-midi = "${@' '.join(map ((lambda x: '/lib/modules/*/misc/%s' % x), bb.data.getVar('midi_modules', d).split()))}"
+misc_modules = "snd-gus-synth.o \
+ snd-emu8000-synth.o \
+ snd-emux-synth.o \
+ snd-ainstr-fm.o \
+ snd-ainstr-gf1.o \
+ snd-ainstr-iw.o \
+ snd-ainstr-simple.o"
+FILES_${PN}-misc = "${@' '.join(map ((lambda x: '/lib/modules/*/misc/%s' % x), bb.data.getVar('misc_modules', d).split()))}"
+
+# put in-kernel headers first in the include search path.
+# without this all configure checks fail
+CFLAGS =+ "-I${STAGING_KERNEL_DIR}/include"
do_configure() {
@@ -46,16 +65,9 @@ fi
if grep "CONFIG_ARCH_H3900=y" "${STAGING_KERNEL_DIR}/.config" ; then
familiar_arch=ipaqpxa
fi
-extra_modules="snd-gus-synth.o snd-emu8000-synth.o snd-emux-synth.o \
- snd-ainstr-fm.o snd-ainstr-gf1.o snd-ainstr-iw.o snd-ainstr-simple.o \
- snd-seq-midi-emul.o snd-seq-midi-event.o snd-seq-midi.o snd-seq-virmidi.o snd-seq-oss.o"
fakeroot make -k NODEPMOD=yes DESTDIR=${D} install;
- for i in ${extra_modules};
- do rm -f ${D}/lib/modules/*/misc/$i;
- done
-
if [ -d ${D}${sysconfdir}/modutils/ ] ; then
rm -r ${D}${sysconfdir}/modutils/ ;
fi