aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alsa
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/alsa
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/.mtn2git_empty0
-rw-r--r--packages/alsa/alsa-driver/.mtn2git_empty0
-rw-r--r--packages/alsa/alsa-driver/adriver.h.patch23
-rw-r--r--packages/alsa/alsa-driver/h5400.patch12
-rw-r--r--packages/alsa/alsa-driver/sound.p.patch59
-rw-r--r--packages/alsa/alsa-driver_0.9.6-hh4c.bb75
-rw-r--r--packages/alsa/alsa-lib_1.0.8.bb27
-rw-r--r--packages/alsa/alsa-tools_1.0.8.bb10
8 files changed, 206 insertions, 0 deletions
diff --git a/packages/alsa/.mtn2git_empty b/packages/alsa/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/alsa/.mtn2git_empty
diff --git a/packages/alsa/alsa-driver/.mtn2git_empty b/packages/alsa/alsa-driver/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/alsa/alsa-driver/.mtn2git_empty
diff --git a/packages/alsa/alsa-driver/adriver.h.patch b/packages/alsa/alsa-driver/adriver.h.patch
index e69de29bb2..cd648838c0 100644
--- a/packages/alsa/alsa-driver/adriver.h.patch
+++ b/packages/alsa/alsa-driver/adriver.h.patch
@@ -0,0 +1,23 @@
+--- ./include/adriver.h.orig 2003-09-22 22:04:21.000000000 +0200
++++ ./include/adriver.h 2005-06-26 10:33:15.000000000 +0200
+@@ -328,8 +328,18 @@
+ #endif /* SND_NEED_USB_WRAPPER && CONFIG_USB */
+
+ /* workqueue-alike; 2.5.45 */
+-#include <linux/workqueue.h>
++#include <linux/workqueue.h>
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 5, 45) && !defined(__WORK_INITIALIZER)
++#ifdef work_struct
++#undef work_struct
++#endif
++#ifdef INIT_WORK
++#undef INIT_WORK
++#endif
++#ifdef schedule_work
++#undef schedule_work
++#endif
++
+ struct work_struct {
+ void (*func)(void *);
+ void *data;
+
diff --git a/packages/alsa/alsa-driver/h5400.patch b/packages/alsa/alsa-driver/h5400.patch
index e69de29bb2..e156708783 100644
--- a/packages/alsa/alsa-driver/h5400.patch
+++ b/packages/alsa/alsa-driver/h5400.patch
@@ -0,0 +1,12 @@
+--- ./alsa-kernel/arm/h5400-ak4535.c.orig 2005-06-26 22:12:57.000000000 +0200
++++ ./alsa-kernel/arm/h5400-ak4535.c 2005-06-26 22:13:08.000000000 +0200
+@@ -36,7 +36,7 @@
+ #include <asm/arch-sa1100/h3600_hal.h>
+ #include <asm/arch-sa1100/h3600_asic.h>
+ #include <asm/arch-pxa/h5400-asic.h>
+-#include <asm/arch-pxa/pxa-i2s.h>
++#include <drivers/sound/pxa-i2s.h>
+
+ #include <sound/core.h>
+ #include <sound/pcm.h>
+
diff --git a/packages/alsa/alsa-driver/sound.p.patch b/packages/alsa/alsa-driver/sound.p.patch
index e69de29bb2..38b073c8bd 100644
--- a/packages/alsa/alsa-driver/sound.p.patch
+++ b/packages/alsa/alsa-driver/sound.p.patch
@@ -0,0 +1,59 @@
+--- ./acore/sound.patch.orig 2003-07-03 16:05:15.000000000 +0200
++++ ./acore/sound.patch 2005-06-26 09:45:05.000000000 +0200
+@@ -1,6 +1,26 @@
+---- sound.c 2003-05-30 15:29:14.000000000 +0200
+-+++ sound.c.old 2003-05-30 15:30:11.000000000 +0200
+-@@ -154,7 +154,9 @@
++--- sound.c.orig 2005-06-25 23:33:07.000000000 +0200
+++++ sound.c 2005-06-25 23:33:07.000000000 +0200
++@@ -77,6 +77,7 @@
++ void snd_request_card(int card)
++ {
++ int locked;
+++ char *str;
++
++ read_lock(&snd_card_rwlock);
++ locked = snd_cards_lock & (1 << card);
++@@ -85,7 +86,10 @@
++ return;
++ if (card < 0 || card >= cards_limit)
++ return;
++- request_module("snd-card-%i", card);
+++ str = kmalloc(15,GFP_KERNEL);
+++ snprintf(str,15,"snd-card-%i",card);
+++ request_module(str);
+++ kfree(str);
++ }
++
++ static void snd_request_other(int minor)
++@@ -154,7 +158,9 @@
+
+ struct file_operations snd_fops =
+ {
+@@ -10,7 +30,7 @@
+ .open = snd_open
+ };
+
+-@@ -364,6 +366,9 @@
++@@ -364,6 +370,9 @@
+ #ifndef MODULE
+ printk(KERN_INFO "Advanced Linux Sound Architecture Driver Version " CONFIG_SND_VERSION CONFIG_SND_DATE ".\n");
+ #endif
+@@ -20,7 +40,7 @@
+ return 0;
+ }
+
+-@@ -378,6 +383,9 @@
++@@ -378,6 +387,9 @@
+ snd_info_minor_unregister();
+ #endif
+ snd_info_done();
+@@ -30,7 +50,7 @@
+ #ifdef CONFIG_SND_DEBUG_MEMORY
+ snd_memory_done();
+ #endif
+-@@ -490,3 +498,5 @@
++@@ -508,3 +520,5 @@
+ EXPORT_SYMBOL(snd_wrapper_vmalloc);
+ EXPORT_SYMBOL(snd_wrapper_vfree);
+ #endif
diff --git a/packages/alsa/alsa-driver_0.9.6-hh4c.bb b/packages/alsa/alsa-driver_0.9.6-hh4c.bb
index e69de29bb2..bf307d13e2 100644
--- a/packages/alsa/alsa-driver_0.9.6-hh4c.bb
+++ b/packages/alsa/alsa-driver_0.9.6-hh4c.bb
@@ -0,0 +1,75 @@
+DESCRIPTION = "Alsa Drivers"
+MAINTAINER = "Pigi"
+SECTION = "console/utils"
+LICENSE = "GPL"
+#DEPENDS = "alsa-lib"
+
+
+SRC_URI = "ftp://ftp.handhelds.org/packages/alsa-driver/alsa-driver-${PV}.tar.gz \
+ file://sound.p.patch;patch=1 \
+ file://h5400.patch;patch=1 \
+ file://adriver.h.patch;patch=1 "
+
+#inherit autotools
+#inherit module
+
+#EXTRA_OECONF = " --with-isapnp=no "
+EXTRA_OECONF=" --with-sequencer=no --with-isapnp=no --with-oss=yes --with-cards=${cards} --with-kernel=${STAGING_KERNEL_DIR} --with-kernel-version=${KERNEL_VERSION} --host=arm-linux"
+#EXTRA_OECONF = " /ext/ambient/tmp/work/handhelds-sa-2.4.19-rmk6-pxa1-hh37.4-r5/kernel/ "
+
+
+do_configure() {
+
+VERS=`grep "^VERSION =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
+PATLEV=`grep "^PATCHLEVEL =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
+SBLEV=`grep "^SUBLEVEL =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
+EXVER=`grep "^EXTRAVERSION =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
+
+KERNEL_VERSION=$VERS.$PATLEV.$SBLEV$EXVER
+
+cards=
+if egrep "CONFIG_SA1100_H3[168]00=y" "${STAGING_KERNEL_DIR}/.config" ; then
+ cards="$cards,sa11xx-uda1341"
+ familiar_arch=ipaqsa
+fi
+if grep "CONFIG_ARCH_H3900=y" "${STAGING_KERNEL_DIR}/.config" ; then
+ cards="$cards,pxa-uda1380,h5400-ak4535"
+ familiar_arch=ipaqpxa
+fi
+cards="$cards,bluez-sco,pdaudiocf"
+
+ configure ${EXTRA_OECONF}
+ #./config.ipaq ${STAGING_KERNEL_DIR}
+
+}
+
+
+
+do_install() {
+
+if egrep "CONFIG_SA1100_H3[168]00=y" "${STAGING_KERNEL_DIR}/.config" ; then
+ familiar_arch=ipaqsa
+fi
+if grep "CONFIG_ARCH_H3900=y" "${STAGING_KERNEL_DIR}/.config" ; then
+ familiar_arch=ipaqpxa
+fi
+extra_modules="snd-gus-synth.o snd-emu8000-synth.o snd-emux-synth.o \
+ snd-ainstr-fm.o snd-ainstr-gf1.o snd-ainstr-iw.o snd-ainstr-simple.o \
+ snd-seq-midi-emul.o snd-seq-midi-event.o snd-seq-midi.o snd-seq-virmidi.o snd-seq-oss.o"
+
+ fakeroot make -k NODEPMOD=yes DESTDIR=${D} install;
+
+ for i in ${extra_modules};
+ do rm -f ${D}/lib/modules/*/misc/$i;
+ done
+
+ if [ -d ${D}/${sysconfdir}/modutils/ ] ; then
+ rm -r ${D}/${sysconfdir}/modutils/ ;
+ fi
+ mkdir ${D}/${sysconfdir}/modutils/
+ cp familiar/alsa-modules-${familiar_arch} ${D}/${sysconfdir}/modutils/
+}
+
+#FILES_alsa-driver = "/lib/modules/${KERNEL_VERSION}/misc/snd* /${sysconfdir}/init.d/ /${sysconfdir}"
+FILES_${PN} = "/lib/modules/*/misc/snd* ${sysconfdir}/modutils/* "
+
diff --git a/packages/alsa/alsa-lib_1.0.8.bb b/packages/alsa/alsa-lib_1.0.8.bb
index e69de29bb2..a58b21f532 100644
--- a/packages/alsa/alsa-lib_1.0.8.bb
+++ b/packages/alsa/alsa-lib_1.0.8.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Alsa sound library"
+MAINTAINER = "Lorn Potter <lpotter@trolltech.com>"
+SECTION = "libs/multimedia"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
+
+do_stage () {
+ oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/alsa/sound
+ install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
+ install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "libasound alsa-server alsa-conf alsa-doc alsa-dev"
+FILES_libasound = "${libdir}/libasound.so*"
+FILES_alsa-server = "${bindir}"
+FILES_alsa-conf = "${datadir}"
+FILES_alsa-dev = "${libdir}/pkgconfig/ ${incdir}"
+
diff --git a/packages/alsa/alsa-tools_1.0.8.bb b/packages/alsa/alsa-tools_1.0.8.bb
index e69de29bb2..eed86e5dba 100644
--- a/packages/alsa/alsa-tools_1.0.8.bb
+++ b/packages/alsa/alsa-tools_1.0.8.bb
@@ -0,0 +1,10 @@
+BROKEN = "1"
+
+DESCRIPTION = "Alsa Tools"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2"
+
+inherit autotools