aboutsummaryrefslogtreecommitdiffstats
path: root/packages/anki
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-12 19:22:33 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-12 19:22:33 +0000
commitb71755f5063c33c58a77a088fed19cf7e6f6bfeb (patch)
treee1947b86120a38a88eabfd899ea01b866ab31d7c /packages/anki
parentf6d75d235751beea6ccdf865fc302ff97259de65 (diff)
downloadopenembedded-b71755f5063c33c58a77a088fed19cf7e6f6bfeb.tar.gz
anki 0.4.3 make it build
Diffstat (limited to 'packages/anki')
-rw-r--r--packages/anki/anki.inc4
-rw-r--r--packages/anki/anki_0.4.3.bb4
-rw-r--r--packages/anki/files/.mtn2git_empty0
-rw-r--r--packages/anki/files/no-need-for-pyqt-at-buildtime.patch28
4 files changed, 33 insertions, 3 deletions
diff --git a/packages/anki/anki.inc b/packages/anki/anki.inc
index 4b996b0f2a..e9a71c286b 100644
--- a/packages/anki/anki.inc
+++ b/packages/anki/anki.inc
@@ -5,11 +5,11 @@ HOMEPAGE = "http://ichi2.net/anki/"
AUTHOR = "Damien Elmes"
PRIORITY = "optional"
LICENSE = "GPLv2"
-DEPENDS = "qt4-x11-free python python-pyqt python-native"
+RDEPENDS = "python-pyqt"
RRECOMMENDS = "kakasi virtual/japanese-font"
SRC_URI = "http://ichi2.net/anki/download/anki-${PV}.tgz"
-inherit autotools setuptools
+inherit setuptools
PACKAGE_ARCH = "all"
diff --git a/packages/anki/anki_0.4.3.bb b/packages/anki/anki_0.4.3.bb
index 90d3ecd6b8..5d0c8fabe7 100644
--- a/packages/anki/anki_0.4.3.bb
+++ b/packages/anki/anki_0.4.3.bb
@@ -3,5 +3,7 @@ require anki.inc
RDEPENDS += "libanki"
PR = "r0"
-S = "${WORKDIR}/anki-${PV}"
+export PV
+SRC_URI += "file://no-need-for-pyqt-at-buildtime.patch;patch=1"
+S = "${WORKDIR}/anki-${PV}"
diff --git a/packages/anki/files/.mtn2git_empty b/packages/anki/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/anki/files/.mtn2git_empty
diff --git a/packages/anki/files/no-need-for-pyqt-at-buildtime.patch b/packages/anki/files/no-need-for-pyqt-at-buildtime.patch
new file mode 100644
index 0000000000..56cfec4999
--- /dev/null
+++ b/packages/anki/files/no-need-for-pyqt-at-buildtime.patch
@@ -0,0 +1,28 @@
+#
+# (C) Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+Index: anki-0.4.3/setup.py
+===================================================================
+--- anki-0.4.3.orig/setup.py 2008-02-12 19:17:56.000000000 +0000
++++ anki-0.4.3/setup.py 2008-02-12 19:19:29.000000000 +0000
+@@ -3,10 +3,8 @@
+ from setuptools import setup, find_packages
+ import sys, os
+
+-import ankiqt
+-
+ setup(name='ankiqt',
+- version=ankiqt.appVersion,
++ version=os.environ["PV"],
+ description='An intelligent spaced-repetition memory training program',
+ long_description="",
+ # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+@@ -24,7 +22,7 @@
+ license='GPLv2',
+ packages=find_packages(),
+ include_package_data=True,
+- install_requires = 'anki >= ' + ankiqt.appVersion,
++ install_requires = 'anki >= ' + os.environ["PV"],
+ zip_safe=False,
+ package_data={'ankiqt':
+ ['locale/*/*/*']},