aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apache
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-08-21 21:27:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-21 21:27:15 +0000
commit781ae9369c6a7a5555be6ed86e351958c7d252c6 (patch)
tree1cf74bff51c69e87f9e468bd84d6a607029523c5 /packages/apache
parent20e87349126957330957f58e05f24890fd01123a (diff)
downloadopenembedded-781ae9369c6a7a5555be6ed86e351958c7d252c6.tar.gz
Fix apache to use openssl from staging. Fix depends on pcre and expat. NOTE: still just for native building.
Diffstat (limited to 'packages/apache')
-rw-r--r--packages/apache/apache_2.0.54.bb24
-rwxr-xr-x[-rw-r--r--]packages/apache/files/init0
2 files changed, 18 insertions, 6 deletions
diff --git a/packages/apache/apache_2.0.54.bb b/packages/apache/apache_2.0.54.bb
index 53b27e9f7b..882b7f2c71 100644
--- a/packages/apache/apache_2.0.54.bb
+++ b/packages/apache/apache_2.0.54.bb
@@ -1,15 +1,16 @@
MAINTAINER="David Karlstrom <daka@nslu2-linux.org>"
SECTION = "net"
-DEPENDS = "openssl"
+DEPENDS = "openssl expat pcre"
-PR = "r1"
+PR = "r2"
# ------------------------------------------
# NOTE: This package is currently only meant
# to be built nativly on the target device
# ------------------------------------------
-SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz"
+SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz \
+ "
S = "${WORKDIR}/httpd-${PV}"
@@ -39,9 +40,20 @@ FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
CFLAGS_append = " -DPATH_MAX=4096"
CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
-EXTRA_OECONF = "--enable-ssl --with-ssl=${STAGING_LIBDIR}/.. --enable-dav \
- --enable-dav-fs --with-dbm=sdbm --with-berkeley-db=no --localstatedir=${localstatedir}/log/apache \
- --with-gdbm=no --with-ndbm=no --datadir=${datadir}/apache --sysconfdir=${sysconfdir}/apache"
+EXTRA_OECONF = "--enable-ssl \
+ --with-ssl=${STAGING_LIBDIR}/.. \
+ --enable-dav \
+ --enable-dav-fs \
+ --with-dbm=sdbm \
+ --with-berkeley-db=no \
+ --localstatedir=${localstatedir}/log/apache \
+ --with-gdbm=no \
+ --with-ndbm=no \
+ --datadir=${datadir}/apache \
+ --sysconfdir=${sysconfdir}/apache \
+ "
+
+export LD_LIBRARY_PATH=${STAGING_LIBDIR}
do_configure () {
# Looks like rebuilding configure doesn't work, so we are skipping
diff --git a/packages/apache/files/init b/packages/apache/files/init
index 46dae0395f..46dae0395f 100644..100755
--- a/packages/apache/files/init
+++ b/packages/apache/files/init