aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apmd
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-16 12:44:27 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-16 12:44:27 +0000
commit3f6b63a8f4260bc411e29db3ad20d158269e117f (patch)
treef7483f7ff63f0b237221614c375d60e98e5c6df4 /packages/apmd
parent100dd10ab554d037081f5649c3bfa8e4d6c70c74 (diff)
downloadopenembedded-3f6b63a8f4260bc411e29db3ad20d158269e117f.tar.gz
apm: turn off wifi cards before suspend so they are fully reloaded upon resume. closes 3664.
Diffstat (limited to 'packages/apmd')
-rw-r--r--packages/apmd/apmd-3.2.2/90-wifi-off12
-rw-r--r--packages/apmd/apmd_3.2.2.bb4
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/apmd/apmd-3.2.2/90-wifi-off b/packages/apmd/apmd-3.2.2/90-wifi-off
new file mode 100644
index 0000000000..c54936c4be
--- /dev/null
+++ b/packages/apmd/apmd-3.2.2/90-wifi-off
@@ -0,0 +1,12 @@
+#!/bin/sh
+#Author: Rolf Leggewie
+#
+# turn off wifi cards before suspend so they are fully reloaded upon resume
+
+wifislot = `pccardctl ls|egrep '(hostap|orinoco)'|cut -f 2 -d " "`
+if test $wifislot
+then
+ for slot in $wifislot; do
+ pccardctl eject $wifislot
+ done
+fi
diff --git a/packages/apmd/apmd_3.2.2.bb b/packages/apmd/apmd_3.2.2.bb
index c3fce375d3..e9f5c0cbef 100644
--- a/packages/apmd/apmd_3.2.2.bb
+++ b/packages/apmd/apmd_3.2.2.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
DEPENDS = "libtool-cross"
LICENSE = "GPL"
-PR = "r8"
+PR = "r9"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz \
file://debian.patch;patch=1 \
@@ -12,6 +12,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz \
file://unlinux.patch;patch=1 \
file://init \
file://default \
+ file://90-wifi-off \
file://apmd_proxy \
file://apmd_proxy.conf"
@@ -49,6 +50,7 @@ do_install() {
install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm
install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd
+ install -m 0755 ${WORKDIR}/90-wifi-off ${D}${sysconfdir}/apm/suspend.d
install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/
install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/
install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd