aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apmd
diff options
context:
space:
mode:
authorJulian_chu <julian_chu@openmoko.com>2008-07-30 16:07:53 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-28 22:48:41 +0100
commitcc8f1710d3078a49c44183f13b7118d3b73b9785 (patch)
treed73cd8d8177cd0672fc3641d47b4d98f5dd31db4 /packages/apmd
parent078b0e63359b8dc61ab95e028b37d8668cdc1671 (diff)
downloadopenembedded-cc8f1710d3078a49c44183f13b7118d3b73b9785.tar.gz
apmd: Correct the .la file
Apmd install the .la file but the content was wrong. It should remove the STAGING path.
Diffstat (limited to 'packages/apmd')
-rw-r--r--packages/apmd/apmd_3.2.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/apmd/apmd_3.2.2.bb b/packages/apmd/apmd_3.2.2.bb
index 503f830bd9..471ee9ca10 100644
--- a/packages/apmd/apmd_3.2.2.bb
+++ b/packages/apmd/apmd_3.2.2.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
DEPENDS = "libtool-cross"
LICENSE = "GPL"
-PR = "r11"
+PR = "r11.01"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz \
file://debian.patch;patch=1 \
@@ -55,6 +55,10 @@ do_install() {
install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd
oe_libinstall -so libapm ${D}${libdir}
install -m 0644 apm.h ${D}${includedir}
+ for i in `find ${D} -name "*.la"` ; do \
+ sed -i -e s:${STAGING_LIBDIR}:${libdir}:g $i
+ sed -i -e s:${STAGING_DIR_HOST}::g $i
+ done
cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd
chmod 755 ${D}${sysconfdir}/init.d/apmd