aboutsummaryrefslogtreecommitdiffstats
path: root/packages/appweb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-10-12 09:18:56 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-10-12 09:18:56 +0000
commit67a391820a7b50eac89da4faa76ff60cc9c5aec9 (patch)
tree51d97942a059ff033bc2faee3be592c0214c1df8 /packages/appweb
parentba2edadd18221dc8a79713c4bcf8805a29ae6bd8 (diff)
downloadopenembedded-67a391820a7b50eac89da4faa76ff60cc9c5aec9.tar.gz
appweb: refactor get_appweb_host function out into common .inc
Diffstat (limited to 'packages/appweb')
-rw-r--r--packages/appweb/appweb.inc4
-rw-r--r--packages/appweb/appweb_1.2.0.bb7
-rw-r--r--packages/appweb/appweb_2.0.4.bb5
3 files changed, 7 insertions, 9 deletions
diff --git a/packages/appweb/appweb.inc b/packages/appweb/appweb.inc
new file mode 100644
index 0000000000..0f602f70d3
--- /dev/null
+++ b/packages/appweb/appweb.inc
@@ -0,0 +1,4 @@
+def get_appweb_host(d, bb):
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ return host.replace('-linux-uclibc', '-linux')
+
diff --git a/packages/appweb/appweb_1.2.0.bb b/packages/appweb/appweb_1.2.0.bb
index 8cf506af2c..8bd6d778f0 100644
--- a/packages/appweb/appweb_1.2.0.bb
+++ b/packages/appweb/appweb_1.2.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
SECTION = "console/network"
-LICENSE="GPL"
+LICENSE = "GPL"
SRC_URI = "http://www.mbedthis.com/software/appWeb-src-1.2.0-1.tar.gz \
file://makerules.patch;patch=1 \
file://nonrootinstall.patch;patch=1"
@@ -9,10 +9,7 @@ S = "${WORKDIR}/appWeb-1.2.0"
APPWEB_HOST = "${@get_appweb_host(d, bb)}"
APPWEB_BUILD = "${BUILD_SYS}"
-def get_appweb_host(d, bb):
- host = bb.data.getVar('HOST_SYS', d, 1)
- return host.replace('-linux-uclibc', '-linux')
-
+require appweb.inc
# --buildNumber=NUMBER Set the build number part of the version (1.0.0.X).
# --name=NAME Set the full product name (BLD_NAME define).
diff --git a/packages/appweb/appweb_2.0.4.bb b/packages/appweb/appweb_2.0.4.bb
index f740876acd..7f7941012a 100644
--- a/packages/appweb/appweb_2.0.4.bb
+++ b/packages/appweb/appweb_2.0.4.bb
@@ -10,10 +10,7 @@ S = "${WORKDIR}/appWeb-${PV}"
APPWEB_HOST = "${@get_appweb_host(d, bb)}"
APPWEB_BUILD = "${BUILD_SYS}"
-def get_appweb_host(d, bb):
- host = bb.data.getVar('HOST_SYS', d, 1)
- return host.replace('-linux-uclibc', '-linux')
-
+require appweb.inc
# --buildNumber=NUMBER Set the build number part of the version (1.0.0.X).
# --name=NAME Set the full product name (BLD_NAME define).