aboutsummaryrefslogtreecommitdiffstats
path: root/packages/appweb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/appweb
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/appweb')
-rw-r--r--packages/appweb/appweb_1.0.0.bb86
-rw-r--r--packages/appweb/appweb_1.0.1.bb86
-rw-r--r--packages/appweb/appweb_1.0.2.bb87
-rw-r--r--packages/appweb/appweb_1.2.0.bb12
4 files changed, 265 insertions, 6 deletions
diff --git a/packages/appweb/appweb_1.0.0.bb b/packages/appweb/appweb_1.0.0.bb
index e69de29bb2..e962675509 100644
--- a/packages/appweb/appweb_1.0.0.bb
+++ b/packages/appweb/appweb_1.0.0.bb
@@ -0,0 +1,86 @@
+DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
+SECTION = "console/network"
+LICENSE="GPL"
+SRC_URI = "http://www.mbedthis.com/software/appWeb-${PV}.LINUX-i386.self.tar.gz"
+SRC_URI_EXTRA = 'file://${WORKDIR}/appWeb-src-${PV}-5.tar.gz \
+ file://charsignedness.patch;patch=1 \
+ file://makerules.patch;patch=1'
+S = "${WORKDIR}/appWeb-${PV}"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${SRC_URI_EXTRA}', d)
+ bb.build.exec_func('base_do_unpack', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+ bb.build.exec_func('do_unpack_cleanup', d)
+}
+
+do_unpack_cleanup () {
+ (
+ set -e
+ cd ${WORKDIR}
+ rm -f README.HTML install remove
+ )
+}
+
+python do_patch () {
+ bb.build.exec_func('base_do_patch', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${SRC_URI_EXTRA}', d)
+ bb.build.exec_func('base_do_patch', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+}
+# --enable-access-log
+# --enable-admin
+# --enable-all-static
+# --enable-assert
+# --enable-c-api
+# --enable-dll
+# --enable-fast-malloc
+# --enable-goahead-compat
+# --enable-if-modified
+# --enable-log
+# --enable-rom-fs
+# --enable-run-as-service
+# --enable-safe-strings
+# --enable-squeeze
+# --enable-ssl
+# --enable-session
+
+APPWEB_TARGET = "${TARGET_ARCH}"
+APPWEB_OS = "${TARGET_OS}"
+APPWEB_OS_linux = "LINUX"
+EXTRA_OECONF = "--os ${APPWEB_OS} --target ${APPWEB_TARGET} \
+ --enable-keep-alive \
+ --enable-multi-thread \
+ --enable-cgi \
+ --enable-cookie \
+ --enable-config \
+ --enable-digest-auth \
+ --disable-ssl"
+EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'CPP=${CXX}' 'LD=${CC}'"
+
+LD_LIBRARY_PATH_prepend = "${S}/lib:"
+LD_LIBRARY_PATH[export] = "1"
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake build
+ oe_runmake compile
+}
+
+do_stage () {
+ :
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
+ ${D}${libexecdir}/appWeb ${D}${libdir}
+ install -m 0755 appWeb/appWeb ${D}${sbindir}/
+ install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
+ install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
+ install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
+}
diff --git a/packages/appweb/appweb_1.0.1.bb b/packages/appweb/appweb_1.0.1.bb
index e69de29bb2..8595e0e691 100644
--- a/packages/appweb/appweb_1.0.1.bb
+++ b/packages/appweb/appweb_1.0.1.bb
@@ -0,0 +1,86 @@
+DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
+SECTION = "console/network"
+LICENSE="GPL"
+SRC_URI = "http://www.mbedthis.com/software/appWeb-${PV}.LINUX-i386.self.tar.gz"
+SRC_URI_EXTRA = 'file://${WORKDIR}/appWeb-src-${PV}-5.tar.gz \
+ file://charsignedness.patch;patch=1 \
+ file://makerules.patch;patch=1'
+S = "${WORKDIR}/appWeb-${PV}"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${SRC_URI_EXTRA}', d)
+ bb.build.exec_func('base_do_unpack', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+ bb.build.exec_func('do_unpack_cleanup', d)
+}
+
+do_unpack_cleanup () {
+ (
+ set -e
+ cd ${WORKDIR}
+ rm -f README.HTML install remove
+ )
+}
+
+python do_patch () {
+ bb.build.exec_func('base_do_patch', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${SRC_URI_EXTRA}', d)
+ bb.build.exec_func('base_do_patch', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+}
+# --enable-access-log
+# --enable-admin
+# --enable-all-static
+# --enable-assert
+# --enable-c-api
+# --enable-dll
+# --enable-fast-malloc
+# --enable-goahead-compat
+# --enable-if-modified
+# --enable-log
+# --enable-rom-fs
+# --enable-run-as-service
+# --enable-safe-strings
+# --enable-squeeze
+# --enable-ssl
+# --enable-session
+
+APPWEB_TARGET = "${TARGET_ARCH}"
+APPWEB_OS = "${TARGET_OS}"
+APPWEB_OS_linux = "LINUX"
+EXTRA_OECONF = "--os ${APPWEB_OS} --target ${APPWEB_TARGET} \
+ --enable-keep-alive \
+ --enable-multi-thread \
+ --enable-cgi \
+ --enable-cookie \
+ --enable-config \
+ --enable-digest-auth \
+ --disable-ssl"
+EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'CPP=${CXX}' 'LD=${CC}'"
+
+LD_LIBRARY_PATH_prepend = "${S}/lib:"
+LD_LIBRARY_PATH[export] = "1"
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake build
+ oe_runmake compile
+}
+
+do_stage () {
+ :
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
+ ${D}${libexecdir}/appWeb ${D}${libdir}
+ install -m 0755 appWeb/appWeb ${D}${sbindir}/
+ install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
+ install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
+ install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
+}
diff --git a/packages/appweb/appweb_1.0.2.bb b/packages/appweb/appweb_1.0.2.bb
index e69de29bb2..7702078135 100644
--- a/packages/appweb/appweb_1.0.2.bb
+++ b/packages/appweb/appweb_1.0.2.bb
@@ -0,0 +1,87 @@
+DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
+SECTION = "console/network"
+LICENSE="GPL"
+
+SRC_URI = "http://www.mbedthis.com/software/appWeb-${PV}.LINUX-i386.self.tar.gz"
+SRC_URI_EXTRA = 'file://${WORKDIR}/appWeb-src-${PV}-12.tar.gz \
+ file://charsignedness.patch;patch=1 \
+ file://makerules.patch;patch=1'
+S = "${WORKDIR}/appWeb-${PV}"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${SRC_URI_EXTRA}', d)
+ bb.build.exec_func('base_do_unpack', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+ bb.build.exec_func('do_unpack_cleanup', d)
+}
+
+do_unpack_cleanup () {
+ (
+ set -e
+ cd ${WORKDIR}
+ rm -f README.HTML install remove
+ )
+}
+
+python do_patch () {
+ bb.build.exec_func('base_do_patch', d)
+ src_uri = bb.data.getVar('SRC_URI', d)
+ bb.data.setVar('SRC_URI', '${SRC_URI_EXTRA}', d)
+ bb.build.exec_func('base_do_patch', d)
+ bb.data.setVar('SRC_URI', src_uri, d)
+}
+# --enable-access-log
+# --enable-admin
+# --enable-all-static
+# --enable-assert
+# --enable-c-api
+# --enable-dll
+# --enable-fast-malloc
+# --enable-goahead-compat
+# --enable-if-modified
+# --enable-log
+# --enable-rom-fs
+# --enable-run-as-service
+# --enable-safe-strings
+# --enable-squeeze
+# --enable-ssl
+# --enable-session
+
+APPWEB_TARGET = "${TARGET_ARCH}"
+APPWEB_OS = "${TARGET_OS}"
+APPWEB_OS_linux = "LINUX"
+EXTRA_OECONF = "--os ${APPWEB_OS} --target ${APPWEB_TARGET} \
+ --enable-keep-alive \
+ --enable-multi-thread \
+ --enable-cgi \
+ --enable-cookie \
+ --enable-config \
+ --enable-digest-auth \
+ --disable-ssl"
+EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'CPP=${CXX}' 'LD=${CC}'"
+
+LD_LIBRARY_PATH_prepend = "${S}/lib:"
+LD_LIBRARY_PATH[export] = "1"
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake build
+ oe_runmake compile
+}
+
+do_stage () {
+ :
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
+ ${D}${libexecdir}/appWeb ${D}${libdir}
+ install -m 0755 appWeb/appWeb ${D}${sbindir}/
+ install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
+ install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
+ install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
+}
diff --git a/packages/appweb/appweb_1.2.0.bb b/packages/appweb/appweb_1.2.0.bb
index f303232f26..dc0ac7d0dd 100644
--- a/packages/appweb/appweb_1.2.0.bb
+++ b/packages/appweb/appweb_1.2.0.bb
@@ -101,10 +101,10 @@ do_install () {
}
#do_install () {
-# install -d ${D}/${sbindir} ${D}/${sysconfdir}/appWeb/lib \
-# ${D}/${libexecdir}/appWeb ${D}/${libdir}
-# install -m 0755 appWeb/appWeb ${D}/${sbindir}/
-# install -m 0644 appWeb/appWeb.conf ${D}/${sysconfdir}/appWeb/
-# install -m 0755 bin/${APPWEB_OS}/* ${D}/${libexecdir}/appWeb/
-# install -m 0755 lib/lib*.so* ${D}/${sysconfdir}/appWeb/lib/
+# install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
+# ${D}${libexecdir}/appWeb ${D}${libdir}
+# install -m 0755 appWeb/appWeb ${D}${sbindir}/
+# install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
+# install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
+# install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
#}