aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apr
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-09 01:54:34 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-09 01:54:34 +0000
commitce4a0ea8a254fa2678fafbbe5875742686726c65 (patch)
tree332a143f83b5f7eb492f9c149c705e4a739fc1ef /packages/apr
parent6238462f51f71dade7022e0a87dba01edf7ff0b0 (diff)
downloadopenembedded-ce4a0ea8a254fa2678fafbbe5875742686726c65.tar.gz
apr-util: Add 1.2.12 version, run full autoreconf and match apr changes
Diffstat (limited to 'packages/apr')
-rw-r--r--packages/apr/apr-util/.mtn2git_empty0
-rw-r--r--packages/apr/apr-util/configure_fixes.patch25
-rw-r--r--packages/apr/apr-util_1.2.12.bb29
-rw-r--r--packages/apr/apr-util_1.2.7.bb15
4 files changed, 60 insertions, 9 deletions
diff --git a/packages/apr/apr-util/.mtn2git_empty b/packages/apr/apr-util/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/apr/apr-util/.mtn2git_empty
diff --git a/packages/apr/apr-util/configure_fixes.patch b/packages/apr/apr-util/configure_fixes.patch
new file mode 100644
index 0000000000..16f88b3bba
--- /dev/null
+++ b/packages/apr/apr-util/configure_fixes.patch
@@ -0,0 +1,25 @@
+Index: apr-util-1.2.12/configure.in
+===================================================================
+--- apr-util-1.2.12.orig/configure.in 2008-03-08 19:15:00.000000000 +0000
++++ apr-util-1.2.12/configure.in 2008-03-08 19:15:13.000000000 +0000
+@@ -8,13 +8,13 @@
+ AC_CONFIG_HEADER(include/private/apu_config.h)
+ AC_CONFIG_AUX_DIR(build)
+
+-sinclude(build/apu-conf.m4)
+-sinclude(build/apu-iconv.m4)
+-sinclude(build/apu-hints.m4)
+-sinclude(build/apr_common.m4)
+-sinclude(build/find_apr.m4)
+-sinclude(build/dbm.m4)
+-sinclude(build/dbd.m4)
++#sinclude(build/apu-conf.m4)
++#sinclude(build/apu-iconv.m4)
++#sinclude(build/apu-hints.m4)
++#sinclude(build/apr_common.m4)
++#sinclude(build/find_apr.m4)
++#sinclude(build/dbm.m4)
++#sinclude(build/dbd.m4)
+
+ dnl Generate ./config.nice for reproducing runs of configure
+ dnl
diff --git a/packages/apr/apr-util_1.2.12.bb b/packages/apr/apr-util_1.2.12.bb
new file mode 100644
index 0000000000..64f6bcbcf8
--- /dev/null
+++ b/packages/apr/apr-util_1.2.12.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r2"
+
+# apache mirrors?
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+ file://configure_fixes.patch;patch=1"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
+ --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
+ --without-sqlite2 \
+ --without-sqlite3 \
+ --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
+
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/packages/apr/apr-util_1.2.7.bb b/packages/apr/apr-util_1.2.7.bb
index 904e41f8a3..5f019d624e 100644
--- a/packages/apr/apr-util_1.2.7.bb
+++ b/packages/apr/apr-util_1.2.7.bb
@@ -3,10 +3,11 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r2"
+PR = "r3"
# apache mirrors?
-SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz"
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+ file://configure_fixes.patch;patch=1"
EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
--with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
@@ -19,14 +20,10 @@ inherit autotools lib_package binconfig
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
-do_configure() {
- cp ${STAGING_DATADIR}/apr_rules.mk ${S}/build/rules.mk
- oe_runconf
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
}
do_stage() {
- autotools_stage_all
- sed -i s,/usr/lib/libgdbm.la,-lgdbm,g ${STAGING_LIBDIR}/libaprutil-1.la
- sed -i s,/usr/lib/libexpat.la,-lexpat,g ${STAGING_LIBDIR}/libaprutil-1.la
- sed -i s,/usr/lib/libapr-1.la,-lapr-1,g ${STAGING_LIBDIR}/libaprutil-1.la
+ autotools_stage_all
}