aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apt
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-30 17:48:26 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-30 17:48:26 +0000
commit992164d2547b4b91b2b87dcf6bd68490b1b8a865 (patch)
tree1c55846e0ef5e5f99fa1aaec099188e7dc1f6107 /packages/apt
parenta16664a66242758c8b2473b9b2d8900333e0c923 (diff)
downloadopenembedded-992164d2547b4b91b2b87dcf6bd68490b1b8a865.tar.gz
apt: sync with poky
Diffstat (limited to 'packages/apt')
-rw-r--r--packages/apt/apt-0.7.2/.mtn2git_empty0
-rw-r--r--packages/apt/apt-0.7.2/noconfigure.patch35
-rw-r--r--packages/apt/apt-0.7.2/nodoc.patch15
-rw-r--r--packages/apt/apt-0.7.3/noconfigure.patch35
-rw-r--r--packages/apt/apt-0.7.3/nodoc.patch15
-rw-r--r--packages/apt/apt-native.inc8
-rw-r--r--packages/apt/apt-native_0.7.2.bb1
-rw-r--r--packages/apt/apt-native_0.7.3.bb5
-rw-r--r--packages/apt/apt-package.inc15
-rw-r--r--packages/apt/apt.inc14
-rw-r--r--packages/apt/apt_0.7.2.bb9
-rw-r--r--packages/apt/apt_0.7.3.bb4
-rw-r--r--packages/apt/files/apt.conf1
-rw-r--r--packages/apt/files/db_linking_hack.patch27
14 files changed, 163 insertions, 21 deletions
diff --git a/packages/apt/apt-0.7.2/.mtn2git_empty b/packages/apt/apt-0.7.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/apt/apt-0.7.2/.mtn2git_empty
diff --git a/packages/apt/apt-0.7.2/noconfigure.patch b/packages/apt/apt-0.7.2/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/packages/apt/apt-0.7.2/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/packages/apt/apt-0.7.2/nodoc.patch b/packages/apt/apt-0.7.2/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/packages/apt/apt-0.7.2/nodoc.patch
@@ -0,0 +1,15 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.6.45exp2.orig/Makefile
++++ apt-0.6.45exp2/Makefile
+@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases
diff --git a/packages/apt/apt-0.7.3/noconfigure.patch b/packages/apt/apt-0.7.3/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/packages/apt/apt-0.7.3/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/packages/apt/apt-0.7.3/nodoc.patch b/packages/apt/apt-0.7.3/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/packages/apt/apt-0.7.3/nodoc.patch
@@ -0,0 +1,15 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.6.45exp2.orig/Makefile
++++ apt-0.6.45exp2/Makefile
+@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases
diff --git a/packages/apt/apt-native.inc b/packages/apt/apt-native.inc
index b615693e64..75cd8f47cd 100644
--- a/packages/apt/apt-native.inc
+++ b/packages/apt/apt-native.inc
@@ -1,11 +1,13 @@
require apt.inc
inherit native
-DEPENDS += "dpkg-native curl-native"
+DEPENDS += "dpkg-native curl-native db-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
PACKAGES = ""
USE_NLS = "no"
+SRC_URI += "file://db_linking_hack.patch;patch=1"
+
python do_stage () {
bb.build.exec_func('do_stage_base', d)
bb.build.exec_func('do_stage_config', d)
@@ -22,7 +24,7 @@ python do_stage_config () {
outdir = os.path.join(bb.data.getVar('sysconfdir', d, 1), 'apt')
if not os.path.exists(outdir):
os.makedirs(outdir)
- outpath = os.path.join(outdir, 'apt.conf')
+ outpath = os.path.join(outdir, 'apt.conf.sample')
outfile = file(outpath, 'w')
outfile.write(data)
@@ -35,7 +37,7 @@ do_stage_base () {
install -m 0755 bin/apt-get ${bindir}/
install -m 0755 bin/apt-config ${bindir}/
install -m 0755 bin/apt-cache ${bindir}/
-
+ install -m 0755 bin/apt-ftparchive ${bindir}/
install -m 0755 bin/apt-sortpkgs ${bindir}/
install -m 0755 bin/apt-extracttemplates ${bindir}/
diff --git a/packages/apt/apt-native_0.7.2.bb b/packages/apt/apt-native_0.7.2.bb
index 43f73889f7..3342618aa9 100644
--- a/packages/apt/apt-native_0.7.2.bb
+++ b/packages/apt/apt-native_0.7.2.bb
@@ -1,4 +1,5 @@
require apt-native.inc
+PR = "r1"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1"
diff --git a/packages/apt/apt-native_0.7.3.bb b/packages/apt/apt-native_0.7.3.bb
new file mode 100644
index 0000000000..6db567f987
--- /dev/null
+++ b/packages/apt/apt-native_0.7.3.bb
@@ -0,0 +1,5 @@
+require apt-native.inc
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1 \
+ file://noconfigure.patch;patch=1"
diff --git a/packages/apt/apt-package.inc b/packages/apt/apt-package.inc
index 5a5d56930e..43f54cadab 100644
--- a/packages/apt/apt-package.inc
+++ b/packages/apt/apt-package.inc
@@ -77,18 +77,11 @@ do_install () {
install -m 0755 bin/apt-sortpkgs ${D}${bindir}/
install -m 0755 bin/apt-extracttemplates ${D}${bindir}/
- install -d ${D}${libdir}
eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
- eval `cat apt-pkg/makefile | grep ^MAJOR | sed -e's, = ,=,'`
- eval `cat apt-pkg/makefile | grep ^MINOR | sed -e's, = ,=,'`
- install bin/libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/
- ln -sf libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-pkg$GLIBC_VER-6.so.$MAJOR
- ln -sf libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-pkg.so
- eval `cat apt-inst/makefile | grep ^MAJOR | sed -e's, = ,=,'`
- eval `cat apt-inst/makefile | grep ^MINOR | sed -e's, = ,=,'`
- install bin/libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/
- ln -sf libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-inst$GLIBC_VER-6.so.$MAJOR
- ln -sf libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-inst.so
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${D}${libdir}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${D}${libdir}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${D}${libdir}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${D}${libdir}/libapt-inst.so
install -d ${D}${libdir}/apt/methods
install -m 0755 bin/methods/* ${D}${libdir}/apt/methods/
diff --git a/packages/apt/apt.inc b/packages/apt/apt.inc
index 2644866c5b..92507be188 100644
--- a/packages/apt/apt.inc
+++ b/packages/apt/apt.inc
@@ -1,6 +1,8 @@
DESCRIPTION = "Advanced front-end for dpkg."
LICENSE = "GPL"
SECTION = "base"
+DEPENDS = "curl db"
+RDEPENDS = "dpkg"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
file://environment.patch;patch=1"
@@ -10,10 +12,14 @@ inherit autotools gettext
EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
-# Apt wants to know the glibc version by running a binary file, which will fail, so we have to tell configure which version to use
-# Since I don't know the impliations of setting a wrong value I only provide one for angstrom, which uses glibc 2.5 (which claims to be 2.4)
+# Apt wants to know the glibc version by running a binary file, which will
+# fail, so we have to tell configure which version to use Since I don't know
+# the impliations of setting a wrong value I only provide one for angstrom,
+# which uses glibc 2.5 (which claims to be 2.4)
# Koen - 20070327
EXTRA_OECONF_append_angstrom = " ac_cv_glibc_ver=libc6.4"
-FILES_${PN}-dbg += "${libdir}/apt/methods/.debug"
-
+# under Debian it is set to libc6.3 as they use glibc 2.3
+# They also provide glibc 2.5 in 'experimental' and it works with APT built
+# for 2.3 so we set it in same way
+EXTRA_OECONF_append = " ac_cv_glibc_ver=libc6.3"
diff --git a/packages/apt/apt_0.7.2.bb b/packages/apt/apt_0.7.2.bb
new file mode 100644
index 0000000000..2a7f963d2f
--- /dev/null
+++ b/packages/apt/apt_0.7.2.bb
@@ -0,0 +1,9 @@
+require apt.inc
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1"
+
+require apt-package.inc
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
diff --git a/packages/apt/apt_0.7.3.bb b/packages/apt/apt_0.7.3.bb
index 24023f2a58..c4cf06544b 100644
--- a/packages/apt/apt_0.7.3.bb
+++ b/packages/apt/apt_0.7.3.bb
@@ -1,4 +1,5 @@
require apt.inc
+PR = "r1"
SRC_URI += "file://nodoc.patch;patch=1"
@@ -6,6 +7,3 @@ require apt-package.inc
FILES_${PN} += "${bindir}/apt-key"
apt-manpages += "doc/apt-key.8"
-
-PR = "r1"
-
diff --git a/packages/apt/files/apt.conf b/packages/apt/files/apt.conf
index 6fd653dfcd..9e90616465 100644
--- a/packages/apt/files/apt.conf
+++ b/packages/apt/files/apt.conf
@@ -29,6 +29,7 @@ Dir "${STAGING_DIR}/"
APT
{
+ Install-Recommends "true";
Immediate-Configure "false";
Architecture "i586";
Get
diff --git a/packages/apt/files/db_linking_hack.patch b/packages/apt/files/db_linking_hack.patch
new file mode 100644
index 0000000000..3c8368b1ed
--- /dev/null
+++ b/packages/apt/files/db_linking_hack.patch
@@ -0,0 +1,27 @@
+Index: apt-0.7.3/configure.in
+===================================================================
+--- apt-0.7.3.orig/configure.in 2007-07-01 10:38:45.000000000 +0000
++++ apt-0.7.3/configure.in 2007-08-21 13:39:26.000000000 +0000
+@@ -67,8 +67,20 @@
+ [AC_DEFINE(HAVE_BDB)
+ BDBLIB="-ldb"
+ AC_MSG_RESULT(yes)],
+- [BDBLIB=""
+- AC_MSG_RESULT(no)]
++
++ LIBS="$LIBS -lpthread"
++ [AC_MSG_CHECKING(if we can link against BerkeleyDB with pthread)
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM(
++ [#include <db.h>],
++ [int r, s, t; db_version(&r, &s, &t);]
++ )],
++ [AC_DEFINE(HAVE_BDB)
++ BDBLIB="-ldb -lpthread"
++ AC_MSG_RESULT(yes)],
++ [BDBLIB=""
++ AC_MSG_RESULT(no)]
++ )]
+ )]
+ )
+