aboutsummaryrefslogtreecommitdiffstats
path: root/packages/asleap
diff options
context:
space:
mode:
authorRick Farina <sidhayn@hotmail.com>2007-10-24 16:05:33 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-10-24 16:05:33 +0000
commitae2253eba8e6461b8ffc90b36f80d9edcbf05220 (patch)
treea98504f9d4483026ffd1c8b1b0e036e27e52c552 /packages/asleap
parent4d778ea009d2309bb480492e7519d2f7f4e0b525 (diff)
downloadopenembedded-ae2253eba8e6461b8ffc90b36f80d9edcbf05220.tar.gz
packages/asleap/asleap_2.1.bb : new recipe from Zero_Chaos
Diffstat (limited to 'packages/asleap')
-rw-r--r--packages/asleap/.mtn2git_empty0
-rw-r--r--packages/asleap/asleap_2.1.bb27
-rw-r--r--packages/asleap/files/.mtn2git_empty0
-rw-r--r--packages/asleap/files/if.h.patch11
4 files changed, 38 insertions, 0 deletions
diff --git a/packages/asleap/.mtn2git_empty b/packages/asleap/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/asleap/.mtn2git_empty
diff --git a/packages/asleap/asleap_2.1.bb b/packages/asleap/asleap_2.1.bb
new file mode 100644
index 0000000000..f7848d1449
--- /dev/null
+++ b/packages/asleap/asleap_2.1.bb
@@ -0,0 +1,27 @@
+SECTION = "console/network"
+DESCRIPTION = "Proof of concept Cisco Leap Cracker"
+HOMEPAGE = "http://asleap.sourceforge.net - outdated"
+LICENSE = "GPLv2"
+DEPENDS = "libpcap openssl"
+
+SRC_URI = "http://802.11ninja.net/~jwright/code/${PN}-${PV}.tgz \
+ file://if.h.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+CFLAGS_append = " -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -D_OPENSSL_MD4 -L${STAGING_LIBDIR}"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 asleap ${D}/${sbindir}
+ install -d ${D}/${bindir}
+ install -m 0755 genkeys ${D}/${bindir}
+}
+
+#
+# Maintainer's note: I am currently not including the test dump file or the
+# scripts directory due to size constraints and the fact that it seems
+# pointless. If someone requests it, I might add it as a seperate package.
+#
diff --git a/packages/asleap/files/.mtn2git_empty b/packages/asleap/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/asleap/files/.mtn2git_empty
diff --git a/packages/asleap/files/if.h.patch b/packages/asleap/files/if.h.patch
new file mode 100644
index 0000000000..99de855956
--- /dev/null
+++ b/packages/asleap/files/if.h.patch
@@ -0,0 +1,11 @@
+diff -ur asleap/asleap.c asleap-10/asleap.c
+--- asleap/asleap.c 2007-05-10 15:29:06.000000000 -0400
++++ asleap-10/asleap.c 2007-06-22 22:05:20.000000000 -0400
+@@ -43,6 +43,7 @@
+ #include <sys/types.h>
+ #include <pcap.h>
+ #include <netpacket/packet.h>
++#include <linux/if.h>
+ #include <linux/wireless.h>
+
+ #include "asleap.h"