aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aufs
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-09-25 19:42:17 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-09-25 19:42:17 +0000
commit45065330689a968bbbf3cfea332f9982f17f9037 (patch)
treea2b3bf94ef3d2f9c2d51b488b94363b7f7e168b7 /packages/aufs
parentceaf5dc7a03b36eeebd7ce989c4b414b5f706732 (diff)
downloadopenembedded-45065330689a968bbbf3cfea332f9982f17f9037.tar.gz
aufs: cleaning up real
* inherit kernelmodule does a lot of stuff like depends and postinst so we do not need to define it manually * the kernel module made only sense, when the tools are there so let them suggest * change from cp and mkdir to install * bump PR
Diffstat (limited to 'packages/aufs')
-rw-r--r--packages/aufs/aufs_cvs.bb35
1 files changed, 15 insertions, 20 deletions
diff --git a/packages/aufs/aufs_cvs.bb b/packages/aufs/aufs_cvs.bb
index fb579f476f..dc21c1bfd4 100644
--- a/packages/aufs/aufs_cvs.bb
+++ b/packages/aufs/aufs_cvs.bb
@@ -1,13 +1,15 @@
DESCRIPTION = "Aufs is a stackable unification filesystem such as Unionfs, which unifies several directories and provides a merged single directory."
HOMEPAGE = "http://aufs.sourceforge.net/"
LICENSE = "GPL"
-RDEPENDS = "kernel (${KERNEL_VERSION})"
-DEPENDS = "virtual/kernel sed-native"
PV = "cvs${SRCDATE}"
-PR = "r0"
-S = "${WORKDIR}/aufs"
+PR = "r1"
+
+RSUGGESTS_${PN} = "${PN}-tools"
+
inherit module
+S = "${WORKDIR}/aufs"
+
# We do not create the manpage for aufs because we do not install it anyway.
# If you want to have the manpage created you will need to add host cc to
# the makefile else it will fail to crosscompile.
@@ -38,23 +40,16 @@ do_configure() {
fi
}
-do_compile(){
- LDFLAGS=""
- oe_runmake
-}
-
do_install() {
- install -m 500 -p mount.aufs umount.aufs auplink aulchown ${D}/${sbindir}
- mkdir -p ${D}/etc/default
+ install -d ${D}/${sbindir}
+ install -m 0500 mount.aufs umount.aufs auplink aulchown ${D}/${sbindir}
+ install -d ${D}/etc/default
echo FLUSH=ALL > ${D}/etc/default/auplink
- mkdir -p ${D}/${base_libdir}/modules/${KERNEL_VERSION}/drivers/extra/
- cp aufs.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/drivers/extra/
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/drivers/extra/
+ install -m 0644 aufs.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/drivers/extra/
}
-pkg_postinst() {
-if test "x$D" != "x"; then
- exit 1
-else
- depmod -ae
-fi
-}
+
+FILES_${PN} = "/lib/modules"
+PACKAGES += "${PN}-tools"
+FILES_${PN}-tools = "${sbindir} /etc/default/auplink"