aboutsummaryrefslogtreecommitdiffstats
path: root/packages/autoconf
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-03-23 22:20:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-23 22:20:50 +0000
commit032650fd051a2f7494c201f28497a01ac49a8383 (patch)
treee9e0c8132763203032daf25c472cdac6d99c85e9 /packages/autoconf
parent31df77eaae327db13c5e02dccdccfe00c73b86d3 (diff)
downloadopenembedded-032650fd051a2f7494c201f28497a01ac49a8383.tar.gz
autoconf: Correct the xlibs detection to correctly detect xlibs (from poky)
Diffstat (limited to 'packages/autoconf')
-rw-r--r--packages/autoconf/autoconf-2.59/autoconf-x.patch36
-rw-r--r--packages/autoconf/autoconf_2.59.bb3
2 files changed, 38 insertions, 1 deletions
diff --git a/packages/autoconf/autoconf-2.59/autoconf-x.patch b/packages/autoconf/autoconf-2.59/autoconf-x.patch
new file mode 100644
index 0000000000..596535b7d6
--- /dev/null
+++ b/packages/autoconf/autoconf-2.59/autoconf-x.patch
@@ -0,0 +1,36 @@
+Index: lib/autoconf/libs.m4
+===================================================================
+RCS file: /cvsroot/autoconf/autoconf/lib/autoconf/libs.m4,v
+retrieving revision 1.13
+diff -p -u -r1.13 libs.m4
+--- autoconf-2.59/lib/autoconf/libs.m4 6 Sep 2005 15:34:06 -0000 1.13
++++ autoconf-2.59/lib/autoconf/libs.m4 18 Sep 2005 17:09:58 -0000
+@@ -265,13 +265,13 @@ ac_x_header_dirs='
+ /usr/openwin/share/include'
+
+ if test "$ac_x_includes" = no; then
+- # Guess where to find include files, by looking for Intrinsic.h.
++ # Guess where to find include files, by looking for Xlib.h.
+ # First, try using that file with no special directory specified.
+- AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Intrinsic.h>])],
++ AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Xlib.h>])],
+ [# We can compile using X headers with no special include directory.
+ ac_x_includes=],
+ [for ac_dir in $ac_x_header_dirs; do
+- if test -r "$ac_dir/X11/Intrinsic.h"; then
++ if test -r "$ac_dir/X11/Xlib.h"; then
+ ac_x_includes=$ac_dir
+ break
+ fi
+@@ -284,9 +284,9 @@ if test "$ac_x_libraries" = no; then
+ # Don't add to $LIBS permanently.
+ ac_save_LIBS=$LIBS
+- LIBS="-lXt $LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Intrinsic.h>],
+- [XtMalloc (0)])],
++ LIBS="-lX11 $LIBS"
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Xlib.h>],
++ [XrmInitialize ()])],
+ [LIBS=$ac_save_LIBS
+ # We can link X programs with no special library path.
+ ac_x_libraries=],
diff --git a/packages/autoconf/autoconf_2.59.bb b/packages/autoconf/autoconf_2.59.bb
index 8636a77787..3cc962da01 100644
--- a/packages/autoconf/autoconf_2.59.bb
+++ b/packages/autoconf/autoconf_2.59.bb
@@ -6,7 +6,7 @@ SECTION = "devel"
DEPENDS += "m4-native"
RDEPENDS_${PN} = "m4 gnu-config"
RRECOMMENDS_${PN} = "automake"
-PR = "r3"
+PR = "r4"
SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
file://program_prefix.patch;patch=1 \
@@ -17,5 +17,6 @@ SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
file://autoconf259-update-configscripts.patch;patch=1 \
file://autoheader-nonfatal-warnings.patch;patch=1 \
file://sizeof_types.patch;patch=1 \
+ file://autoconf-x.patch;patch=1 \
${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
inherit autotools