aboutsummaryrefslogtreecommitdiffstats
path: root/packages/autoconf
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2008-04-17 11:53:26 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2008-04-17 11:53:26 +0000
commitc7bc9f82972c310a409a885be04eb6a82acb8a9c (patch)
tree00fb66ad4b88e61f8ee9aedd18105775afe6771b /packages/autoconf
parent81f9b311a4d1bf6545e15a512ec89e4ea863f350 (diff)
downloadopenembedded-c7bc9f82972c310a409a885be04eb6a82acb8a9c.tar.gz
autoconf: add 2.61
Diffstat (limited to 'packages/autoconf')
-rw-r--r--packages/autoconf/autoconf-2.61/.mtn2git_empty0
-rw-r--r--packages/autoconf/autoconf-2.61/autoheader-nonfatal-warnings.patch13
-rw-r--r--packages/autoconf/autoconf-2.61/autoreconf-exclude.patch127
-rw-r--r--packages/autoconf/autoconf-2.61/autoreconf-foreign.patch11
-rw-r--r--packages/autoconf/autoconf-2.61/autoreconf-gnuconfigize.patch49
-rw-r--r--packages/autoconf/autoconf-2.61/autoreconf-include.patch10
-rw-r--r--packages/autoconf/autoconf-2.61/config-site.patch13
-rw-r--r--packages/autoconf/autoconf-2.61/fix_path_xtra.patch114
-rw-r--r--packages/autoconf/autoconf-2.61/path_prog_fixes.patch126
-rw-r--r--packages/autoconf/autoconf-2.61/program_prefix.patch19
-rw-r--r--packages/autoconf/autoconf-native_2.61.bb11
-rw-r--r--packages/autoconf/autoconf_2.61.bb16
12 files changed, 509 insertions, 0 deletions
diff --git a/packages/autoconf/autoconf-2.61/.mtn2git_empty b/packages/autoconf/autoconf-2.61/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/.mtn2git_empty
diff --git a/packages/autoconf/autoconf-2.61/autoheader-nonfatal-warnings.patch b/packages/autoconf/autoconf-2.61/autoheader-nonfatal-warnings.patch
new file mode 100644
index 0000000000..1f18e04bba
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/autoheader-nonfatal-warnings.patch
@@ -0,0 +1,13 @@
+--- autoconf-2.59/bin/autoheader.in~ 2003-10-10 14:52:56.000000000 +0100
++++ autoconf-2.59/bin/autoheader.in 2004-05-03 01:36:45.000000000 +0100
+@@ -272,8 +272,8 @@
+ }
+
+ }
+- exit 1
+- if keys %symbol;
++# exit 1
++# if keys %symbol;
+ }
+
+ update_file ("$tmp/config.hin", "$config_h_in");
diff --git a/packages/autoconf/autoconf-2.61/autoreconf-exclude.patch b/packages/autoconf/autoconf-2.61/autoreconf-exclude.patch
new file mode 100644
index 0000000000..ab85fae337
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/autoreconf-exclude.patch
@@ -0,0 +1,127 @@
+Index: autoconf-2.61/bin/autoreconf.in
+===================================================================
+--- autoconf-2.61.orig/bin/autoreconf.in 2006-12-14 20:25:59.000000000 +0100
++++ autoconf-2.61/bin/autoreconf.in 2006-12-14 20:33:11.000000000 +0100
+@@ -76,6 +76,7 @@
+ -i, --install copy missing auxiliary files
+ --no-recursive don't rebuild sub-packages
+ -s, --symlink with -i, install symbolic links instead of copies
++ -x, --exclude=STEPS steps we should not run
+ -m, --make when applicable, re-run ./configure && make
+ -W, --warnings=CATEGORY report the warnings falling in CATEGORY [syntax]
+
+@@ -134,6 +135,13 @@
+ # Recurse into subpackages
+ my $recursive = 1;
+
++# Steps to exclude
++my @exclude;
++my @ex;
++
++my $uses_gettext;
++my $configure_ac;
++
+ ## ---------- ##
+ ## Routines. ##
+ ## ---------- ##
+@@ -151,6 +159,7 @@
+ 'B|prepend-include=s' => \@prepend_include,
+ 'i|install' => \$install,
+ 's|symlink' => \$symlink,
++ 'x|exclude=s' => \@exclude,
+ 'm|make' => \$make,
+ 'recursive!' => \$recursive);
+
+@@ -160,6 +169,8 @@
+ parse_WARNINGS;
+ parse_warnings '--warnings', @warning;
+
++ @exclude = map { split /,/ } @exclude;
++
+ # Even if the user specified a configure.ac, trim to get the
+ # directory, and look for configure.ac again. Because (i) the code
+ # is simpler, and (ii) we are still able to diagnose simultaneous
+@@ -253,6 +264,11 @@
+ {
+ my ($aclocal, $flags) = @_;
+
++ @ex = grep (/^aclocal$/, @exclude);
++ if ($#ex != -1) {
++ return;
++ }
++
+ # aclocal 1.8+ does all this for free. It can be recognized by its
+ # --force support.
+ if ($aclocal_supports_force)
+@@ -366,7 +382,10 @@
+ }
+ else
+ {
+- xsystem "$autopoint";
++ @ex = grep (/^autopoint$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("$autopoint");
++ }
+ }
+
+
+@@ -530,7 +549,10 @@
+ {
+ $libtoolize .= " --ltdl";
+ }
+- xsystem ($libtoolize);
++ @ex = grep (/^libtoolize$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("$libtoolize");
++ }
+ $rerun_aclocal = 1;
+ }
+ else
+@@ -570,7 +592,10 @@
+ # latter runs the former, and (ii) autoconf is stricter than
+ # autoheader. So all in all, autoconf should give better error
+ # messages.
+- xsystem ($autoconf);
++ @ex = grep (/^autoconf$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("$autoconf");
++ }
+
+
+ # -------------------- #
+@@ -591,7 +616,10 @@
+ }
+ else
+ {
+- xsystem ($autoheader);
++ @ex = grep (/^autoheader$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("$autoheader");
++ }
+ }
+
+
+@@ -608,7 +636,10 @@
+ # We should always run automake, and let it decide whether it shall
+ # update the file or not. In fact, the effect of `$force' is already
+ # included in `$automake' via `--no-force'.
+- xsystem ($automake);
++ @ex = grep (/^automake$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("$automake");
++ }
+ }
+
+
+@@ -632,7 +663,10 @@
+ }
+ else
+ {
+- xsystem ("make");
++ @ex = grep (/^make$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("make");
++ }
+ }
+ }
+ }
diff --git a/packages/autoconf/autoconf-2.61/autoreconf-foreign.patch b/packages/autoconf/autoconf-2.61/autoreconf-foreign.patch
new file mode 100644
index 0000000000..587a823826
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/autoreconf-foreign.patch
@@ -0,0 +1,11 @@
+--- autoconf-2.59/bin/autoreconf.in~autoreconf-foreign 2004-05-09 20:55:06.000000000 -0400
++++ autoconf-2.59/bin/autoreconf.in 2004-05-09 20:55:55.000000000 -0400
+@@ -184,6 +184,8 @@
+
+ $aclocal_supports_force = `$aclocal --help` =~ /--force/;
+
++ $automake .= ' --foreign';
++
+ # Dispatch autoreconf's option to the tools.
+ # --include;
+ $autoconf .= join (' --include=', '', @include);
diff --git a/packages/autoconf/autoconf-2.61/autoreconf-gnuconfigize.patch b/packages/autoconf/autoconf-2.61/autoreconf-gnuconfigize.patch
new file mode 100644
index 0000000000..c243ce0216
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/autoreconf-gnuconfigize.patch
@@ -0,0 +1,49 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: autoconf-2.61/bin/autoreconf.in
+===================================================================
+--- autoconf-2.61.orig/bin/autoreconf.in 2006-12-14 20:33:52.000000000 +0100
++++ autoconf-2.61/bin/autoreconf.in 2006-12-14 20:34:28.000000000 +0100
+@@ -58,7 +58,7 @@
+ $help = "Usage: $0 [OPTION] ... [DIRECTORY] ...
+
+ Run `autoconf' (and `autoheader', `aclocal', `automake', `autopoint'
+-(formerly `gettextize'), and `libtoolize' where appropriate)
++(formerly `gettextize'), `libtoolize', and `gnu-configize' where appropriate)
+ repeatedly to remake the GNU Build System files in specified
+ DIRECTORIES and their subdirectories (defaulting to `.').
+
+@@ -107,12 +107,13 @@
+ ";
+
+ # Lib files.
+-my $autoconf = $ENV{'AUTOCONF'} || '@bindir@/@autoconf-name@';
+-my $autoheader = $ENV{'AUTOHEADER'} || '@bindir@/@autoheader-name@';
+-my $automake = $ENV{'AUTOMAKE'} || 'automake';
+-my $aclocal = $ENV{'ACLOCAL'} || 'aclocal';
+-my $libtoolize = $ENV{'LIBTOOLIZE'} || 'libtoolize';
+-my $autopoint = $ENV{'AUTOPOINT'} || 'autopoint';
++my $autoconf = $ENV{'AUTOCONF'} || '@bindir@/@autoconf-name@';
++my $autoheader = $ENV{'AUTOHEADER'} || '@bindir@/@autoheader-name@';
++my $automake = $ENV{'AUTOMAKE'} || 'automake';
++my $aclocal = $ENV{'ACLOCAL'} || 'aclocal';
++my $libtoolize = $ENV{'LIBTOOLIZE'} || 'libtoolize';
++my $autopoint = $ENV{'AUTOPOINT'} || 'autopoint';
++my $gnuconfigize = $ENV{'GNUCONFIGIZE'} || 'gnu-configize';
+
+ # --install -- as --add-missing in other tools.
+ my $install = 0;
+@@ -644,6 +645,10 @@
+ }
+ }
+
++ @ex = grep (/^gnu-configize$/, @exclude);
++ if ($#ex == -1) {
++ xsystem ("$gnuconfigize");
++ }
+
+ # -------------- #
+ # Running make. #
diff --git a/packages/autoconf/autoconf-2.61/autoreconf-include.patch b/packages/autoconf/autoconf-2.61/autoreconf-include.patch
new file mode 100644
index 0000000000..5a7604b0fd
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/autoreconf-include.patch
@@ -0,0 +1,10 @@
+--- autoconf/bin/autoreconf.in~ 2004-04-06 23:36:10.000000000 +0100
++++ autoconf/bin/autoreconf.in 2004-04-08 20:51:57.000000000 +0100
+@@ -179,6 +179,7 @@
+ $autoconf .= join (' --prepend-include=', '', @prepend_include);
+ $autoheader .= join (' --include=', '', @include);
+ $autoheader .= join (' --prepend-include=', '', @prepend_include);
++ $aclocal .= join (' -I ', '', @include);
+
+ # --install and --symlink;
+ if ($install)
diff --git a/packages/autoconf/autoconf-2.61/config-site.patch b/packages/autoconf/autoconf-2.61/config-site.patch
new file mode 100644
index 0000000000..0fa49720c1
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/config-site.patch
@@ -0,0 +1,13 @@
+Index: autoconf-2.61/lib/autoconf/general.m4
+===================================================================
+--- autoconf-2.61.orig/lib/autoconf/general.m4 2007-07-10 15:09:01.000000000 +0100
++++ autoconf-2.61/lib/autoconf/general.m4 2007-07-10 15:09:17.000000000 +0100
+@@ -1767,7 +1767,7 @@
+ m4_define([AC_SITE_LOAD],
+ [# Prefer explicitly selected file to automatically selected ones.
+ if test -n "$CONFIG_SITE"; then
+- set x "$CONFIG_SITE"
++ set x $CONFIG_SITE
+ elif test "x$prefix" != xNONE; then
+ set x "$prefix/share/config.site" "$prefix/etc/config.site"
+ else
diff --git a/packages/autoconf/autoconf-2.61/fix_path_xtra.patch b/packages/autoconf/autoconf-2.61/fix_path_xtra.patch
new file mode 100644
index 0000000000..c3a2c4578a
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/fix_path_xtra.patch
@@ -0,0 +1,114 @@
+We don't build xmkmf so any values returned from it are going to be wrong.
+Using any paths in /usr/ for x headers/libs is a bad idea when cross compiling.
+This patch removes them to stop any confusion.
+
+RP - 20071115
+
+Index: autoconf-2.61/lib/autoconf/libs.m4
+===================================================================
+--- autoconf-2.61.orig/lib/autoconf/libs.m4 2006-10-15 01:12:02.000000000 +0000
++++ autoconf-2.61/lib/autoconf/libs.m4 2007-11-15 12:09:59.000000000 +0000
+@@ -180,53 +180,6 @@
+ # --------------------- #
+
+
+-# _AC_PATH_X_XMKMF
+-# ----------------
+-# Internal subroutine of _AC_PATH_X.
+-# Set ac_x_includes and/or ac_x_libraries.
+-m4_define([_AC_PATH_X_XMKMF],
+-[AC_ARG_VAR(XMKMF, [Path to xmkmf, Makefile generator for X Window System])dnl
+-rm -f -r conftest.dir
+-if mkdir conftest.dir; then
+- cd conftest.dir
+- cat >Imakefile <<'_ACEOF'
+-incroot:
+- @echo incroot='${INCROOT}'
+-usrlibdir:
+- @echo usrlibdir='${USRLIBDIR}'
+-libdir:
+- @echo libdir='${LIBDIR}'
+-_ACEOF
+- if (export CC; ${XMKMF-xmkmf}) >/dev/null 2>/dev/null && test -f Makefile; then
+- # GNU make sometimes prints "make[1]: Entering...", which would confuse us.
+- for ac_var in incroot usrlibdir libdir; do
+- eval "ac_im_$ac_var=\`\${MAKE-make} $ac_var 2>/dev/null | sed -n 's/^$ac_var=//p'\`"
+- done
+- # Open Windows xmkmf reportedly sets LIBDIR instead of USRLIBDIR.
+- for ac_extension in a so sl; do
+- if test ! -f "$ac_im_usrlibdir/libX11.$ac_extension" &&
+- test -f "$ac_im_libdir/libX11.$ac_extension"; then
+- ac_im_usrlibdir=$ac_im_libdir; break
+- fi
+- done
+- # Screen out bogus values from the imake configuration. They are
+- # bogus both because they are the default anyway, and because
+- # using them would break gcc on systems where it needs fixed includes.
+- case $ac_im_incroot in
+- /usr/include) ac_x_includes= ;;
+- *) test -f "$ac_im_incroot/X11/Xos.h" && ac_x_includes=$ac_im_incroot;;
+- esac
+- case $ac_im_usrlibdir in
+- /usr/lib | /lib) ;;
+- *) test -d "$ac_im_usrlibdir" && ac_x_libraries=$ac_im_usrlibdir ;;
+- esac
+- fi
+- cd ..
+- rm -f -r conftest.dir
+-fi
+-])# _AC_PATH_X_XMKMF
+-
+-
+ # _AC_PATH_X_DIRECT
+ # -----------------
+ # Internal subroutine of _AC_PATH_X.
+@@ -234,40 +187,7 @@
+ m4_define([_AC_PATH_X_DIRECT],
+ [# Standard set of common directories for X headers.
+ # Check X11 before X11Rn because it is often a symlink to the current release.
+-ac_x_header_dirs='
+-/usr/X11/include
+-/usr/X11R6/include
+-/usr/X11R5/include
+-/usr/X11R4/include
+-
+-/usr/include/X11
+-/usr/include/X11R6
+-/usr/include/X11R5
+-/usr/include/X11R4
+-
+-/usr/local/X11/include
+-/usr/local/X11R6/include
+-/usr/local/X11R5/include
+-/usr/local/X11R4/include
+-
+-/usr/local/include/X11
+-/usr/local/include/X11R6
+-/usr/local/include/X11R5
+-/usr/local/include/X11R4
+-
+-/usr/X386/include
+-/usr/x386/include
+-/usr/XFree86/include/X11
+-
+-/usr/include
+-/usr/local/include
+-/usr/unsupported/include
+-/usr/athena/include
+-/usr/local/x11r5/include
+-/usr/lpp/Xamples/include
+-
+-/usr/openwin/include
+-/usr/openwin/share/include'
++ac_x_header_dirs=''
+
+ if test "$ac_x_includes" = no; then
+ # Guess where to find include files, by looking for Xlib.h.
+@@ -316,7 +236,6 @@
+ [AC_CACHE_VAL(ac_cv_have_x,
+ [# One or both of the vars are not set, and there is no cached value.
+ ac_x_includes=no ac_x_libraries=no
+-_AC_PATH_X_XMKMF
+ _AC_PATH_X_DIRECT
+ case $ac_x_includes,$ac_x_libraries in #(
+ no,* | *,no | *\'*)
diff --git a/packages/autoconf/autoconf-2.61/path_prog_fixes.patch b/packages/autoconf/autoconf-2.61/path_prog_fixes.patch
new file mode 100644
index 0000000000..5f0d055a48
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/path_prog_fixes.patch
@@ -0,0 +1,126 @@
+Index: autoconf-2.59/bin/autoheader.in
+===================================================================
+--- autoconf-2.59.orig/bin/autoheader.in 2005-03-09 16:27:17.933878952 -0500
++++ autoconf-2.59/bin/autoheader.in 2005-03-09 16:29:57.360642400 -0500
+@@ -1,8 +1,8 @@
+-#! @PERL@
++#! @bindir@/env perl
+ # -*- Perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
+ if 0;
+
+ # autoheader -- create `config.h.in' from `configure.ac'
+Index: autoconf-2.59/bin/autom4te.in
+===================================================================
+--- autoconf-2.59.orig/bin/autom4te.in 2003-10-28 03:48:36.000000000 -0500
++++ autoconf-2.59/bin/autom4te.in 2005-03-09 16:30:14.957967200 -0500
+@@ -1,8 +1,10 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ # autom4te - Wrapper around M4 libraries.
+@@ -87,7 +89,7 @@
+ my $freeze = 0;
+
+ # $M4.
+-my $m4 = $ENV{"M4"} || '@M4@';
++my $m4 = $ENV{"M4"} || '@bindir@/env m4';
+ # Some non-GNU m4's don't reject the --help option, so give them /dev/null.
+ fatal "need GNU m4 1.4 or later: $m4"
+ if system "$m4 --help </dev/null 2>&1 | grep reload-state >/dev/null";
+Index: autoconf-2.59/bin/autoreconf.in
+===================================================================
+--- autoconf-2.59.orig/bin/autoreconf.in 2005-03-09 16:27:17.354966960 -0500
++++ autoconf-2.59/bin/autoreconf.in 2005-03-09 16:31:19.572144352 -0500
+@@ -1,8 +1,10 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ # autoreconf - install the GNU Build System in a directory tree
+Index: autoconf-2.59/bin/autoscan.in
+===================================================================
+--- autoconf-2.59.orig/bin/autoscan.in 2003-09-26 08:57:49.000000000 -0400
++++ autoconf-2.59/bin/autoscan.in 2005-03-09 16:30:18.136483992 -0500
+@@ -1,4 +1,4 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # autoscan - Create configure.scan (a preliminary configure.ac) for a package.
+ # Copyright (C) 1994, 1999, 2000, 2001, 2002, 2003
+@@ -21,7 +21,9 @@
+
+ # Written by David MacKenzie <djm@gnu.ai.mit.edu>.
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ BEGIN
+Index: autoconf-2.59/bin/autoupdate.in
+===================================================================
+--- autoconf-2.59.orig/bin/autoupdate.in 2003-08-27 07:26:32.000000000 -0400
++++ autoconf-2.59/bin/autoupdate.in 2005-03-09 16:30:19.912214040 -0500
+@@ -1,4 +1,4 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # autoupdate - modernize an Autoconf file.
+ # Copyright (C) 1994, 1999, 2000, 2001, 2002, 2003
+@@ -22,7 +22,9 @@
+ # Originally written by David MacKenzie <djm@gnu.ai.mit.edu>.
+ # Rewritten by Akim Demaille <akim@freefriends.org>.
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ BEGIN
+@@ -54,7 +56,7 @@
+ my @include = ('@datadir@');
+ my $force = 0;
+ # m4.
+-my $m4 = $ENV{"M4"} || '@M4@';
++my $m4 = $ENV{"M4"} || '@bindir@/env m4';
+
+
+ # $HELP
+Index: autoconf-2.59/bin/ifnames.in
+===================================================================
+--- autoconf-2.59.orig/bin/ifnames.in 2003-10-10 09:52:56.000000000 -0400
++++ autoconf-2.59/bin/ifnames.in 2005-03-09 16:30:22.656796800 -0500
+@@ -1,8 +1,10 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ # ifnames - print the identifiers used in C preprocessor conditionals
diff --git a/packages/autoconf/autoconf-2.61/program_prefix.patch b/packages/autoconf/autoconf-2.61/program_prefix.patch
new file mode 100644
index 0000000000..e6f4096a97
--- /dev/null
+++ b/packages/autoconf/autoconf-2.61/program_prefix.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- autoconf-2.57/lib/autoconf/general.m4~program_prefix
++++ autoconf-2.57/lib/autoconf/general.m4
+@@ -1676,8 +1676,9 @@
+ # The aliases save the names the user supplied, while $host etc.
+ # will get canonicalized.
+ test -n "$target_alias" &&
+- test "$program_prefix$program_suffix$program_transform_name" = \
+- NONENONEs,x,x, &&
++ test "$target_alias" != "$host_alias" &&
++ test "$program_prefix$program_suffix$program_transform_name" = \
++ NONENONEs,x,x, &&
+ program_prefix=${target_alias}-[]dnl
+ ])# AC_CANONICAL_TARGET
+
diff --git a/packages/autoconf/autoconf-native_2.61.bb b/packages/autoconf/autoconf-native_2.61.bb
new file mode 100644
index 0000000000..ad6cb79445
--- /dev/null
+++ b/packages/autoconf/autoconf-native_2.61.bb
@@ -0,0 +1,11 @@
+require autoconf_${PV}.bb
+
+DEPENDS = "m4-native gnu-config-native"
+RDEPENDS_${PN} = "m4-native gnu-config-native"
+
+SRC_URI += "file://fix_path_xtra.patch;patch=1"
+
+S = "${WORKDIR}/autoconf-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/autoconf-${PV}"
+
+inherit native
diff --git a/packages/autoconf/autoconf_2.61.bb b/packages/autoconf/autoconf_2.61.bb
new file mode 100644
index 0000000000..68327e9559
--- /dev/null
+++ b/packages/autoconf/autoconf_2.61.bb
@@ -0,0 +1,16 @@
+require autoconf.inc
+
+PR = "r0"
+
+PARALLEL_MAKE = ""
+
+DEPENDS += "m4-native"
+RDEPENDS_${PN} = "m4 gnu-config"
+
+SRC_URI += "file://autoreconf-include.patch;patch=1 \
+ file://autoreconf-exclude.patch;patch=1 \
+ file://autoreconf-foreign.patch;patch=1 \
+ file://autoreconf-gnuconfigize.patch;patch=1 \
+ file://autoheader-nonfatal-warnings.patch;patch=1 \
+ file://config-site.patch;patch=1 \
+ ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"