aboutsummaryrefslogtreecommitdiffstats
path: root/packages/autofs
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2007-11-21 18:05:36 +0000
committerMike Westerhof <mwester@dls.net>2007-11-21 18:05:36 +0000
commit56781c36744c71f18a9aa48b1acf4246bf116e71 (patch)
tree69aaf7ecb9c69fb8410ea069e14b5bceffd855a3 /packages/autofs
parent5ef059e8d595d4dfe11fe712aa20e7b3b54c7a46 (diff)
downloadopenembedded-56781c36744c71f18a9aa48b1acf4246bf116e71.tar.gz
autofs: remove dependency on bash, and add rc.update.d stuff to bb file.
Diffstat (limited to 'packages/autofs')
-rw-r--r--packages/autofs/autofs-4.1.4/no-bash.patch18
-rw-r--r--packages/autofs/autofs_4.1.4.bb10
2 files changed, 25 insertions, 3 deletions
diff --git a/packages/autofs/autofs-4.1.4/no-bash.patch b/packages/autofs/autofs-4.1.4/no-bash.patch
new file mode 100644
index 0000000000..16e83a0371
--- /dev/null
+++ b/packages/autofs/autofs-4.1.4/no-bash.patch
@@ -0,0 +1,18 @@
+diff -Naur autofs-4.1.4/samples.orig/auto.net autofs-4.1.4/samples/auto.net
+--- autofs-4.1.4/samples.orig/auto.net 2007-11-21 11:29:57.000000000 -0600
++++ autofs-4.1.4/samples/auto.net 2007-11-21 11:30:27.000000000 -0600
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # $Id: auto.net,v 1.8 2005/04/05 13:02:09 raven Exp $
+
+diff -Naur autofs-4.1.4/samples.orig/auto.smb autofs-4.1.4/samples/auto.smb
+--- autofs-4.1.4/samples.orig/auto.smb 2007-11-21 11:29:57.000000000 -0600
++++ autofs-4.1.4/samples/auto.smb 2007-11-21 11:30:34.000000000 -0600
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # $Id: auto.smb,v 1.3 2005/04/05 13:02:09 raven Exp $
+
diff --git a/packages/autofs/autofs_4.1.4.bb b/packages/autofs/autofs_4.1.4.bb
index ab2bacedb7..d9863ad9dd 100644
--- a/packages/autofs/autofs_4.1.4.bb
+++ b/packages/autofs/autofs_4.1.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Kernel based automounter for linux."
SECTION = "base"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
@@ -12,9 +12,13 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2
file://Makefile.rules-cross.patch;patch=1 \
file://install.patch;patch=1 \
file://auto.net-sort-option-fix.patch;patch=1 \
- file://autofs-additional-distros.patch;patch=1"
+ file://autofs-additional-distros.patch;patch=1 \
+ file://no-bash.patch;patch=1"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "autofs"
+INITSCRIPT_PARAMS = "defaults"
EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
PARALLEL_MAKE = ""