aboutsummaryrefslogtreecommitdiffstats
path: root/packages/autofs
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-04-18 00:59:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-18 00:59:04 +0000
commitb89bf2a856bba13210a8c9ef4d6d8f5fa67405bb (patch)
tree7d2e020d586647fb41297ff32b858a52a5efc76d /packages/autofs
parentb9bcfe56927ea14b91cc767a82d00ed6a819b281 (diff)
downloadopenembedded-b89bf2a856bba13210a8c9ef4d6d8f5fa67405bb.tar.gz
autofs - Makefile was not in fact using the cross compiler.
Diffstat (limited to 'packages/autofs')
-rw-r--r--packages/autofs/autofs-4.1.4/Makefile.rules-cross.patch30
-rw-r--r--packages/autofs/autofs_4.1.4.bb5
2 files changed, 34 insertions, 1 deletions
diff --git a/packages/autofs/autofs-4.1.4/Makefile.rules-cross.patch b/packages/autofs/autofs-4.1.4/Makefile.rules-cross.patch
new file mode 100644
index 0000000000..d8b3692efa
--- /dev/null
+++ b/packages/autofs/autofs-4.1.4/Makefile.rules-cross.patch
@@ -0,0 +1,30 @@
+--- autofs-4.1.4/Makefile.rules.orig 2006-04-06 16:47:33.000000000 -0500
++++ autofs-4.1.4/Makefile.rules 2006-04-06 16:49:16.000000000 -0500
+@@ -18,19 +18,19 @@
+ # The STRIP defined here *must not* remove any dynamic-loading symbols
+
+ ifdef DEBUG
+-CFLAGS = -O2 -g -DDEBUG
+-LDFLAGS = -g
++CFLAGS += -O2 -g -DDEBUG
++LDFLAGS += -g
+ STRIP = :
+ else
+-CFLAGS = -O3 -fomit-frame-pointer -Wall
+-LDFLAGS = -s
+-STRIP = strip --strip-debug
++CFLAGS += -O3 -fomit-frame-pointer -Wall
++LDFLAGS += -s
++STRIP = ${TARGET_PREFIX}strip --strip-debug
+ endif
+
+-CC = gcc
+-CXX = g++
++CC ?= ${TARGET_PREFIX}gcc
++CXX ?= ${TARGET_PREFIX}g++
+ CXXFLAGS = $(CFLAGS)
+-LD = ld
++LD ?= ${TARGET_PREFIX}ld
+ SOLDFLAGS = -shared -Xlinker -rpath -Xlinker $(autofslibdir)
+
+ # Standard rules
diff --git a/packages/autofs/autofs_4.1.4.bb b/packages/autofs/autofs_4.1.4.bb
index 8cb633c391..8acf618654 100644
--- a/packages/autofs/autofs_4.1.4.bb
+++ b/packages/autofs/autofs_4.1.4.bb
@@ -6,7 +6,10 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2
ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
- file://cross.patch;patch=1"
+ file://cross.patch;patch=1 \
+ file://Makefile.rules-cross.patch;patch=1"
+
+EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
inherit autotools