aboutsummaryrefslogtreecommitdiffstats
path: root/packages/automake
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-04-29 23:11:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-29 23:11:24 +0000
commit9303bc5d9623ce927aa7cbd0a08d676fdf7f4b73 (patch)
treee92023d719855e6d16ae0d15c072d62f9cf5a718 /packages/automake
parent3ac118be07b744242133b806053c4ec159592459 (diff)
downloadopenembedded-9303bc5d9623ce927aa7cbd0a08d676fdf7f4b73.tar.gz
automake: Fix automake RDEPENDS and add the perl modules needed (bug 852)
Diffstat (limited to 'packages/automake')
-rw-r--r--packages/automake/automake-native.inc2
-rw-r--r--packages/automake/automake.inc23
-rw-r--r--packages/automake/automake_1.7.7.bb3
-rw-r--r--packages/automake/automake_1.8.2.bb3
-rw-r--r--packages/automake/automake_1.8.4.bb3
-rw-r--r--packages/automake/automake_1.9.2.bb3
-rw-r--r--packages/automake/automake_1.9.3.bb3
7 files changed, 34 insertions, 6 deletions
diff --git a/packages/automake/automake-native.inc b/packages/automake/automake-native.inc
index 9e89ac8621..7b69252ff0 100644
--- a/packages/automake/automake-native.inc
+++ b/packages/automake/automake-native.inc
@@ -1,7 +1,7 @@
SECTION = "devel"
include automake_${PV}.bb
DEPENDS = "autoconf-native"
-RDEPENDS_${PN} = "autoconf-native perl-native-runtime"
+RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
inherit native
diff --git a/packages/automake/automake.inc b/packages/automake/automake.inc
new file mode 100644
index 0000000000..fa59c1f5cc
--- /dev/null
+++ b/packages/automake/automake.inc
@@ -0,0 +1,23 @@
+RDEPENDS_automake += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-dynaloader \
+ perl-module-errno \
+ perl-module-exporter-heavy \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-glob \
+ perl-module-file-spec-unix \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-vars "
diff --git a/packages/automake/automake_1.7.7.bb b/packages/automake/automake_1.7.7.bb
index 619361bcfd..7483868ee4 100644
--- a/packages/automake/automake_1.7.7.bb
+++ b/packages/automake/automake_1.7.7.bb
@@ -7,7 +7,8 @@ PR = "r7"
inherit autotools
FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf-native perl-native"
+
+include automake.inc
do_install () {
oe_runmake 'DESTDIR=${D}' install
diff --git a/packages/automake/automake_1.8.2.bb b/packages/automake/automake_1.8.2.bb
index cdcd1690e1..9921a8d6a4 100644
--- a/packages/automake/automake_1.8.2.bb
+++ b/packages/automake/automake_1.8.2.bb
@@ -11,7 +11,8 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
inherit autotools
FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf perl"
+
+include automake.inc
do_install () {
oe_runmake 'DESTDIR=${D}' install
diff --git a/packages/automake/automake_1.8.4.bb b/packages/automake/automake_1.8.4.bb
index 56cf80a327..493d2cc907 100644
--- a/packages/automake/automake_1.8.4.bb
+++ b/packages/automake/automake_1.8.4.bb
@@ -11,7 +11,8 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
inherit autotools
FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf perl"
+
+include automake.inc
do_install () {
oe_runmake 'DESTDIR=${D}' install
diff --git a/packages/automake/automake_1.9.2.bb b/packages/automake/automake_1.9.2.bb
index 0bf4288650..4027862768 100644
--- a/packages/automake/automake_1.9.2.bb
+++ b/packages/automake/automake_1.9.2.bb
@@ -12,7 +12,8 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
inherit autotools
FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf perl"
+
+include automake.inc
do_install () {
oe_runmake 'DESTDIR=${D}' install
diff --git a/packages/automake/automake_1.9.3.bb b/packages/automake/automake_1.9.3.bb
index 71bf0bd58b..fb75b83b68 100644
--- a/packages/automake/automake_1.9.3.bb
+++ b/packages/automake/automake_1.9.3.bb
@@ -13,7 +13,8 @@ inherit autotools
export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
-RDEPENDS_${PN} += "autoconf perl"
+
+include automake.inc
do_install () {
oe_runmake 'DESTDIR=${D}' install