aboutsummaryrefslogtreecommitdiffstats
path: root/packages/automake
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/automake
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/automake')
-rw-r--r--packages/automake/automake_1.7.7.bb20
-rw-r--r--packages/automake/automake_1.8.2.bb24
-rw-r--r--packages/automake/automake_1.8.4.bb24
-rw-r--r--packages/automake/automake_1.9.2.bb27
-rw-r--r--packages/automake/automake_1.9.3.bb27
5 files changed, 122 insertions, 0 deletions
diff --git a/packages/automake/automake_1.7.7.bb b/packages/automake/automake_1.7.7.bb
index e69de29bb2..e28e79009e 100644
--- a/packages/automake/automake_1.7.7.bb
+++ b/packages/automake/automake_1.7.7.bb
@@ -0,0 +1,20 @@
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+DESCRIPTION = "A tool for automatically generating Makefiles."
+SECTION = "devel"
+LICENSE = "GPL"
+PR = "r2"
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.7 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.7 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.8.2.bb b/packages/automake/automake_1.8.2.bb
index e69de29bb2..a61ab5cc98 100644
--- a/packages/automake/automake_1.8.2.bb
+++ b/packages/automake/automake_1.8.2.bb
@@ -0,0 +1,24 @@
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
+ file://automake182-update-configscripts.patch;patch=1;pnum=1"
+DESCRIPTION = "A tool for automatically generating Makefiles."
+SECTION = "devel"
+LICENSE = "GPL"
+PR = "r2"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.8 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.8 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.8.4.bb b/packages/automake/automake_1.8.4.bb
index e69de29bb2..b0f2ab169b 100644
--- a/packages/automake/automake_1.8.4.bb
+++ b/packages/automake/automake_1.8.4.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.8 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.8 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.9.2.bb b/packages/automake/automake_1.9.2.bb
index e69de29bb2..e720475f8b 100644
--- a/packages/automake/automake_1.9.2.bb
+++ b/packages/automake/automake_1.9.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+S = "${WORKDIR}/automake-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}
diff --git a/packages/automake/automake_1.9.3.bb b/packages/automake/automake_1.9.3.bb
index e69de29bb2..448974e65c 100644
--- a/packages/automake/automake_1.9.3.bb
+++ b/packages/automake/automake_1.9.3.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2"
+S = "${WORKDIR}/automake-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_${PN} += "perl"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}