aboutsummaryrefslogtreecommitdiffstats
path: root/packages/automake
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-07-10 15:16:24 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-07-10 15:16:24 +0000
commit51ea046316b377551dfbbc7b95864f9dc21620e9 (patch)
tree5d27477302ee91615c5f1273ab15f65bf7cdc31d /packages/automake
parent54e1ebf1061d87fb139645426d008f97a97a6c21 (diff)
downloadopenembedded-51ea046316b377551dfbbc7b95864f9dc21620e9.tar.gz
automake: added 1.10 - not tested too much, needed by parted 1.8.7, not default
Diffstat (limited to 'packages/automake')
-rw-r--r--packages/automake/automake-native_1.10.bb3
-rw-r--r--packages/automake/automake_1.10.bb31
2 files changed, 34 insertions, 0 deletions
diff --git a/packages/automake/automake-native_1.10.bb b/packages/automake/automake-native_1.10.bb
new file mode 100644
index 0000000000..92c861f49c
--- /dev/null
+++ b/packages/automake/automake-native_1.10.bb
@@ -0,0 +1,3 @@
+PV := "${PV}"
+
+require automake-native.inc
diff --git a/packages/automake/automake_1.10.bb b/packages/automake/automake_1.10.bb
new file mode 100644
index 0000000000..eef69f4e4a
--- /dev/null
+++ b/packages/automake/automake_1.10.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
+ ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
+
+S = "${WORKDIR}/automake-${PV}"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+
+require automake.inc
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}
+
+DEFAULT_PREFERENCE = "-1"