aboutsummaryrefslogtreecommitdiffstats
path: root/packages/avahi
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2005-12-11 11:05:14 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-11 11:05:14 +0000
commit6f1e9bcbd09b4f1851cbfc70a53e78bac5e4928e (patch)
tree93591e57ac195d23a427793d54b953409a73e908 /packages/avahi
parent7ef13d28a46f9525664ac6afbf9c6cbb3f53aac4 (diff)
downloadopenembedded-6f1e9bcbd09b4f1851cbfc70a53e78bac5e4928e.tar.gz
avahi: bugfix release 0.6.1 with avahi-utils
Diffstat (limited to 'packages/avahi')
-rw-r--r--packages/avahi/avahi_0.6.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/avahi/avahi_0.6.1.bb b/packages/avahi/avahi_0.6.1.bb
new file mode 100644
index 0000000000..874afdac03
--- /dev/null
+++ b/packages/avahi/avahi_0.6.1.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
+LICENSE= "GPL"
+DEPENDS = "expat libdaemon dbus-0.60"
+RRECOMMENDS = "libnss-mdns"
+SECTION = "net"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "http://www.freedesktop.org/~lennart/avahi-${PV}.tar.gz"
+
+PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+ ${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/services \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/init.d/avahi-daemon \
+ ${datadir}/avahi/introspection/*.introspect \
+ ${datadir}/avahi/avahi-service.dtd \
+ ${datadir}/avahi/service-types"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+ ${sysconfdir}/avahi/avahi-dnsconfd.action \
+ ${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-utils = "${bindir}/avahi-*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+inherit autotools
+inherit update-rc.d
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+
+pkg_postinst_avahi-daemon () {
+ grep avahi /etc/group || addgroup avahi
+ grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
+ /etc/init.d/dbus-1 force-reload
+}
+
+pkg_postrm_avahi-daemon () {
+ deluser avahi || true
+ delgroup avahi || true
+}