aboutsummaryrefslogtreecommitdiffstats
path: root/packages/avahi
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2006-12-16 13:47:20 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2006-12-16 13:47:20 +0000
commit9e38546bebf75735da5dd957b7e4a3b54aa594ae (patch)
tree6844219abb5667dcef0f5569b7d0183375b675e2 /packages/avahi
parentce63bda57c45f8900dc35cbfc8e5ec56aa2f4535 (diff)
downloadopenembedded-9e38546bebf75735da5dd957b7e4a3b54aa594ae.tar.gz
avahi: unify recipes
Diffstat (limited to 'packages/avahi')
-rw-r--r--packages/avahi/avahi.inc66
-rw-r--r--packages/avahi/avahi_0.6.10.bb66
-rw-r--r--packages/avahi/avahi_0.6.11.bb66
-rw-r--r--packages/avahi/avahi_0.6.12.bb63
-rw-r--r--packages/avahi/avahi_0.6.13.bb67
-rw-r--r--packages/avahi/avahi_0.6.14.bb65
-rw-r--r--packages/avahi/avahi_0.6.15.bb66
-rw-r--r--packages/avahi/avahi_0.6.5.bb50
-rw-r--r--packages/avahi/avahi_0.6.8.bb54
9 files changed, 79 insertions, 484 deletions
diff --git a/packages/avahi/avahi.inc b/packages/avahi/avahi.inc
new file mode 100644
index 0000000000..19ef64f0e1
--- /dev/null
+++ b/packages/avahi/avahi.inc
@@ -0,0 +1,66 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+AUTHOR = "Lennart Poettering <lennart@poettering.net>"
+HOMEPAGE = "http://avahi.org"
+SECTION = "network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "expat libdaemon dbus"
+RRECOMMENDS = "libnss-mdns"
+RRECOMMENDS_avahi-daemon = "libnss-mdns"
+
+SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
+
+inherit autotools pkgconfig update-rc.d
+
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+
+PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+ ${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/hosts \
+ ${sysconfdir}/avahi/services \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/init.d/avahi-daemon \
+ ${datadir}/avahi/introspection/*.introspect \
+ ${datadir}/avahi/avahi-service.dtd \
+ ${datadir}/avahi/service-types"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+ ${sysconfdir}/avahi/avahi-dnsconfd.action \
+ ${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-utils = "${bindir}/avahi-*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
+pkg_postinst_avahi-daemon () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep avahi /etc/group || addgroup avahi
+ grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_avahi-daemon () {
+ deluser avahi || true
+ delgroup avahi || true
+}
diff --git a/packages/avahi/avahi_0.6.10.bb b/packages/avahi/avahi_0.6.10.bb
index 39ef299351..27dcdcffcb 100644
--- a/packages/avahi/avahi_0.6.10.bb
+++ b/packages/avahi/avahi_0.6.10.bb
@@ -1,65 +1,3 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-SECTION = "network"
-PRIORITY = "optional"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-PR = "r1"
-
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS = "libnss-mdns"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools pkgconfig update-rc.d
+require avahi.inc
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-
-pkg_postinst_avahi-daemon () {
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
+PR = "r1"
diff --git a/packages/avahi/avahi_0.6.11.bb b/packages/avahi/avahi_0.6.11.bb
index 6132fda504..27dcdcffcb 100644
--- a/packages/avahi/avahi_0.6.11.bb
+++ b/packages/avahi/avahi_0.6.11.bb
@@ -1,65 +1,3 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-SECTION = "network"
-PRIORITY = "optional"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-PR="r1"
+require avahi.inc
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS = "libnss-mdns"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools pkgconfig update-rc.d
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-
-pkg_postinst_avahi-daemon () {
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
+PR = "r1"
diff --git a/packages/avahi/avahi_0.6.12.bb b/packages/avahi/avahi_0.6.12.bb
index 97fe491577..aad7d2661c 100644
--- a/packages/avahi/avahi_0.6.12.bb
+++ b/packages/avahi/avahi_0.6.12.bb
@@ -1,66 +1,7 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-SECTION = "network"
-PRIORITY = "optional"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-PR = "r2"
-
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS = "libnss-mdns"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools pkgconfig update-rc.d
+require avahi.inc
+PR = "r2"
do_stage() {
autotools_stage_all
}
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-
-pkg_postinst_avahi-daemon () {
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
diff --git a/packages/avahi/avahi_0.6.13.bb b/packages/avahi/avahi_0.6.13.bb
index a758997b4c..076dc0d148 100644
--- a/packages/avahi/avahi_0.6.13.bb
+++ b/packages/avahi/avahi_0.6.13.bb
@@ -1,70 +1,7 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-SECTION = "network"
-PRIORITY = "optional"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-PR = "r1"
-
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS = "libnss-mdns"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools pkgconfig update-rc.d
+require avahi.inc
+PR = "r1"
do_stage() {
autotools_stage_all
}
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-
-pkg_postinst_avahi-daemon () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
diff --git a/packages/avahi/avahi_0.6.14.bb b/packages/avahi/avahi_0.6.14.bb
index 2b5d56fffd..e42f4bbc13 100644
--- a/packages/avahi/avahi_0.6.14.bb
+++ b/packages/avahi/avahi_0.6.14.bb
@@ -1,71 +1,8 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-SECTION = "network"
-PRIORITY = "optional"
-LICENSE = "GPL"
+require avahi.inc
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS_avahi-daemon = "libnss-mdns"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-inherit autotools pkgconfig update-rc.d
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-
-PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
${sysconfdir}/avahi/avahi-autoipd.action"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
do_stage() {
autotools_stage_all
}
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-
-pkg_postinst_avahi-daemon () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
diff --git a/packages/avahi/avahi_0.6.15.bb b/packages/avahi/avahi_0.6.15.bb
index 331018d23a..07a429e133 100644
--- a/packages/avahi/avahi_0.6.15.bb
+++ b/packages/avahi/avahi_0.6.15.bb
@@ -1,72 +1,10 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-SECTION = "network"
-PRIORITY = "optional"
-LICENSE = "GPL"
+require avahi.inc
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS_avahi-daemon = "libnss-mdns"
+SRC_URI += "file://patch-avahi-daemon_dbus-protocol.c.patch;patch=1;pnum=0"
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
- file://patch-avahi-daemon_dbus-protocol.c.patch;patch=1;pnum=0"
-
-inherit autotools pkgconfig update-rc.d
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-
-PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
${sysconfdir}/avahi/avahi-autoipd.action"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
do_stage() {
autotools_stage_all
}
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-
-pkg_postinst_avahi-daemon () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
diff --git a/packages/avahi/avahi_0.6.5.bb b/packages/avahi/avahi_0.6.5.bb
index 4e27d655b0..9189734dfa 100644
--- a/packages/avahi/avahi_0.6.5.bb
+++ b/packages/avahi/avahi_0.6.5.bb
@@ -1,49 +1 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-SECTION = "network"
-PRIORITY = "optional"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools pkgconfig update-rc.d
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-pkg_postinst_avahi-daemon () {
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
- /etc/init.d/dbus-1 force-reload
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
+require avahi.inc
diff --git a/packages/avahi/avahi_0.6.8.bb b/packages/avahi/avahi_0.6.8.bb
index 828ea4a39a..9189734dfa 100644
--- a/packages/avahi/avahi_0.6.8.bb
+++ b/packages/avahi/avahi_0.6.8.bb
@@ -1,53 +1 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-SECTION = "network"
-PRIORITY = "optional"
-AUTHOR = "Lennart Poettering <lennart@poettering.net>"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS = "libnss-mdns"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/hosts \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools pkgconfig update-rc.d
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-pkg_postinst_avahi-daemon () {
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
- /etc/init.d/dbus-1 force-reload
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
+require avahi.inc