aboutsummaryrefslogtreecommitdiffstats
path: root/packages/avahi
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-11-21 10:06:19 +0000
committerKoen Kooi <koen@openembedded.org>2006-11-21 10:06:19 +0000
commitcf1d33d740aec5916e1bac4f892de51610f987d1 (patch)
tree634224316baad9fe19b2c884bfff7011e0d6359c /packages/avahi
parenta9ffadeccc2babc56563d3b33db5d896a4d6637a (diff)
downloadopenembedded-cf1d33d740aec5916e1bac4f892de51610f987d1.tar.gz
avahi: update to 0.6.15 (security update) and add a patch to build against dbus 1.0 (from freebsd)
Diffstat (limited to 'packages/avahi')
-rw-r--r--packages/avahi/avahi-0.6.15/.mtn2git_empty0
-rw-r--r--packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch28
-rw-r--r--packages/avahi/avahi_0.6.15.bb72
3 files changed, 100 insertions, 0 deletions
diff --git a/packages/avahi/avahi-0.6.15/.mtn2git_empty b/packages/avahi/avahi-0.6.15/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/avahi/avahi-0.6.15/.mtn2git_empty
diff --git a/packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch b/packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch
new file mode 100644
index 0000000000..0971a9eea8
--- /dev/null
+++ b/packages/avahi/avahi-0.6.15/patch-avahi-daemon_dbus-protocol.c.patch
@@ -0,0 +1,28 @@
+marcus 2006-11-11 02:56:18 UTC
+
+ FreeBSD ports repository
+
+ Modified files:
+ net/avahi Makefile distinfo
+ Added files:
+ net/avahi/files patch-avahi-daemon_dbus-protocol.c
+ Log:
+ Update to 0.6.15, and fix the build with D-BUS 1.0.
+
+ Revision Changes Path
+ 1.43 +3 -3 ports/net/avahi/Makefile
+ 1.12 +3 -3 ports/net/avahi/distinfo
+ 1.3 +11 -0 ports/net/avahi/files/patch-avahi-daemon_dbus-protocol.c (new)
+
+--- avahi-daemon/dbus-protocol.c.orig Fri Nov 10 21:50:07 2006
++++ avahi-daemon/dbus-protocol.c Fri Nov 10 21:50:55 2006
+@@ -1067,7 +1067,7 @@ static int dbus_connect(void) {
+ if (dbus_bus_request_name(
+ server->bus,
+ AVAHI_DBUS_NAME,
+-#if (DBUS_VERSION_MAJOR == 0) && (DBUS_VERSION_MINOR >= 60)
++#if ((DBUS_VERSION_MAJOR == 0) && (DBUS_VERSION_MINOR >= 60)) || DBUS_VERSION_MAJOR > 0
+ DBUS_NAME_FLAG_DO_NOT_QUEUE,
+ #else
+ DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT,
+
diff --git a/packages/avahi/avahi_0.6.15.bb b/packages/avahi/avahi_0.6.15.bb
new file mode 100644
index 0000000000..331018d23a
--- /dev/null
+++ b/packages/avahi/avahi_0.6.15.bb
@@ -0,0 +1,72 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+AUTHOR = "Lennart Poettering <lennart@poettering.net>"
+HOMEPAGE = "http://avahi.org"
+SECTION = "network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "expat libdaemon dbus"
+RRECOMMENDS_avahi-daemon = "libnss-mdns"
+
+SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
+ file://patch-avahi-daemon_dbus-protocol.c.patch;patch=1;pnum=0"
+
+inherit autotools pkgconfig update-rc.d
+
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+
+PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+ ${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/hosts \
+ ${sysconfdir}/avahi/services \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/init.d/avahi-daemon \
+ ${datadir}/avahi/introspection/*.introspect \
+ ${datadir}/avahi/avahi-service.dtd \
+ ${datadir}/avahi/service-types"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+ ${sysconfdir}/avahi/avahi-dnsconfd.action \
+ ${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
+ ${sysconfdir}/avahi/avahi-autoipd.action"
+FILES_avahi-utils = "${bindir}/avahi-*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+do_stage() {
+ autotools_stage_all
+}
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
+pkg_postinst_avahi-daemon () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep avahi /etc/group || addgroup avahi
+ grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_avahi-daemon () {
+ deluser avahi || true
+ delgroup avahi || true
+}