aboutsummaryrefslogtreecommitdiffstats
path: root/packages/balsa
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/balsa
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/balsa')
-rw-r--r--packages/balsa/.mtn2git_empty0
-rw-r--r--packages/balsa/balsa-2.0.17/.mtn2git_empty0
-rw-r--r--packages/balsa/balsa-2.0.17/desktop-file-fix.patch8
-rw-r--r--packages/balsa/balsa-2.0.17/libmutt-cross.patch20
-rw-r--r--packages/balsa/balsa_2.0.17.bb27
5 files changed, 55 insertions, 0 deletions
diff --git a/packages/balsa/.mtn2git_empty b/packages/balsa/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/balsa/.mtn2git_empty
diff --git a/packages/balsa/balsa-2.0.17/.mtn2git_empty b/packages/balsa/balsa-2.0.17/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/balsa/balsa-2.0.17/.mtn2git_empty
diff --git a/packages/balsa/balsa-2.0.17/desktop-file-fix.patch b/packages/balsa/balsa-2.0.17/desktop-file-fix.patch
index e69de29bb2..1f169eea8b 100644
--- a/packages/balsa/balsa-2.0.17/desktop-file-fix.patch
+++ b/packages/balsa/balsa-2.0.17/desktop-file-fix.patch
@@ -0,0 +1,8 @@
+--- balsa-2.0.17/balsa.desktop~ 2003-07-08 15:37:35.000000000 +0100
++++ balsa-2.0.17/balsa.desktop 2004-08-03 23:23:50.000000000 +0100
+@@ -80,4 +80,4 @@
+ Terminal=0
+ Type=Application
+ StartupNotify=true
+-Categories=GNOME;Application;Network
++Categories=GNOME;Application;Network;
diff --git a/packages/balsa/balsa-2.0.17/libmutt-cross.patch b/packages/balsa/balsa-2.0.17/libmutt-cross.patch
index e69de29bb2..983368528f 100644
--- a/packages/balsa/balsa-2.0.17/libmutt-cross.patch
+++ b/packages/balsa/balsa-2.0.17/libmutt-cross.patch
@@ -0,0 +1,20 @@
+--- balsa-2.0.17/libmutt/configure.in~ 2003-03-24 22:36:15.000000000 +0000
++++ balsa-2.0.17/libmutt/configure.in 2004-06-27 16:45:40.000000000 +0100
+@@ -131,7 +131,7 @@
+ if (s.st_mode & S_IWOTH) exit (0);
+ exit (1);
+ }], [mutt_cv_worldwrite=yes], [mutt_cv_worldwrite=no],
+- [ AC_MSG_ERROR("Cannot cross compile libmutt. Yet")] ))
++ [mutt_cv_worldwrite=no] ))
+
+ mutt_cv_setgid=no
+ if test $mutt_cv_worldwrite = yes; then
+@@ -149,7 +149,7 @@
+ if (s.st_mode & S_IWGRP) exit (0);
+ exit (1);
+ }], [mutt_cv_groupwrite=yes], [mutt_cv_groupwrite=no],
+- [ AC_MSG_ERROR("Cannot cross compile libmutt. Yet")] ))
++ [mutt_cv_worldwrite=no] ))
+
+ dnl if test $mutt_cv_groupwrite = yes; then
+ dnl AC_DEFINE(USE_DOTLOCK)
diff --git a/packages/balsa/balsa_2.0.17.bb b/packages/balsa/balsa_2.0.17.bb
index e69de29bb2..6893ef90c3 100644
--- a/packages/balsa/balsa_2.0.17.bb
+++ b/packages/balsa/balsa_2.0.17.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Balsa is an e-mail client for GNOME, highly configurable and \
+incorporating all the features you would expect in a robust mail client."
+HOMEPAGE = "http://balsa.gnome.org"
+SECTION = "x11/network"
+LICENSE="GPL"
+
+DEPENDS = "libesmtp glib-2.0 libgnome libgnomeui gtk+ gnome-vfs libbonobo aspell pcre libtool openssl gtkhtml-3.0"
+RDEPENDS = "gdk-pixbuf-loader-xpm"
+PR = "r3"
+
+
+SRC_URI = "http://balsa.gnome.org/balsa-2.0.17.tar.bz2 \
+ file://libmutt-cross.patch;patch=1 \
+ file://desktop-file-fix.patch;patch=1"
+
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ssl"
+
+do_configure_prepend() {
+ # aclocal seems to insist on looking in here. Make sure it exists.
+ mkdir -p ${S}/m4
+ # work around automake lossage with AC_CONFIG_AUX_DIR
+ ( cd libmutt; libtoolize --force ; cp ../ltmain.sh . )
+}
+