aboutsummaryrefslogtreecommitdiffstats
path: root/packages/base-files
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/base-files
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/base-files')
-rw-r--r--packages/base-files/base-files_3.0.14.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/packages/base-files/base-files_3.0.14.bb b/packages/base-files/base-files_3.0.14.bb
index a17ee67bb7..38c3bf7d32 100644
--- a/packages/base-files/base-files_3.0.14.bb
+++ b/packages/base-files/base-files_3.0.14.bb
@@ -98,36 +98,36 @@ do_install () {
install -m 0644 ${WORKDIR}/licenses/$license ${D}/${datadir}/common-licenses/
done
- if (grep -q "^\(tmpfs\|ramfs\)\W\+/var" ${D}/etc/fstab); then
+ if (grep -q "^\(tmpfs\|ramfs\)\W\+/var" ${D}/${sysconfdir}/fstab); then
# /var is in a ramdisk
- install -d ${D}/etc/init.d ${D}/etc/rcS.d
+ install -d ${D}/${sysconfdir}/init.d ${D}/${sysconfdir}/rcS.d
for d in ${dirs755}; do
if (echo $d|grep -q "^${localstatedir}"); then
- echo "mkdir -p $d" >> ${D}/etc/init.d/populate-var.sh
- echo "chmod 0775 $d" >> ${D}/etc/init.d/populate-var.sh
+ echo "mkdir -p $d" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo "chmod 0775 $d" >> ${D}/${sysconfdir}/init.d/populate-var.sh
fi
done
for d in ${dirs1777}; do
if (echo $d|grep -q "^${localstatedir}"); then
- echo "mkdir -p $d" >> ${D}/etc/init.d/populate-var.sh
- echo "chmod 1777 $d" >> ${D}/etc/init.d/populate-var.sh
+ echo "mkdir -p $d" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo "chmod 1777 $d" >> ${D}/${sysconfdir}/init.d/populate-var.sh
fi
done
for d in ${dirs2775}; do
if (echo $d|grep -q "^${localstatedir}"); then
- echo "mkdir -p $d" >> ${D}/etc/init.d/populate-var.sh
- echo "chmod 2775 $d" >> ${D}/etc/init.d/populate-var.sh
+ echo "mkdir -p $d" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo "chmod 2775 $d" >> ${D}/${sysconfdir}/init.d/populate-var.sh
fi
done
- echo ">/var/run/utmp" >> ${D}/etc/init.d/populate-var.sh
- echo ">/var/log/wtmp" >> ${D}/etc/init.d/populate-var.sh
- echo ">/var/log/lastlog" >> ${D}/etc/init.d/populate-var.sh
- echo "chmod 0664 /var/run/utmp /var/log/wtmp /var/log/lastlog" >> ${D}/etc/init.d/populate-var.sh
- echo "touch /var/run/resolv.conf" >> ${D}/etc/init.d/populate-var.sh
+ echo ">/var/run/utmp" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo ">/var/log/wtmp" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo ">/var/log/lastlog" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo "chmod 0664 /var/run/utmp /var/log/wtmp /var/log/lastlog" >> ${D}/${sysconfdir}/init.d/populate-var.sh
+ echo "touch /var/run/resolv.conf" >> ${D}/${sysconfdir}/init.d/populate-var.sh
-# rmdir ${D}/var/*
+# rmdir ${D}/${localstatedir}/*
chmod 0755 ${D}/${sysconfdir}/init.d/populate-var.sh
ln -sf ../init.d/populate-var.sh ${D}/${sysconfdir}/rcS.d/S37populate-var.sh
ln -sf ${localstatedir}/run/resolv.conf ${D}/${sysconfdir}/resolv.conf
@@ -139,7 +139,7 @@ do_install () {
do_install_append_ramses () {
rmdir ${D}/tmp
- mkdir -p ${D}/var/tmp
+ mkdir -p ${D}/${localstatedir}/tmp
ln -s var/tmp ${D}/tmp
}