aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bash/bash_2.05b.bb
diff options
context:
space:
mode:
authorBruno Randolf <br1@subnet.at>2004-12-20 16:19:11 +0000
committerBruno Randolf <br1@subnet.at>2004-12-20 16:19:11 +0000
commit45114bdfb079754baa67fd13c7bc538f5a0d31d2 (patch)
tree2c46aa5bb62337a3adc4401b7eb4a4df0a59711f /packages/bash/bash_2.05b.bb
parent3921cd53c238da7a4f1d157f20108f449eb79f80 (diff)
downloadopenembedded-45114bdfb079754baa67fd13c7bc538f5a0d31d2.tar.gz
bash 3.0 added
bash: apply signames patch for correct signal names on mipsel BKrev: 41c6fb7foLjY95rA5l1Pu2zK3WskYg
Diffstat (limited to 'packages/bash/bash_2.05b.bb')
-rw-r--r--packages/bash/bash_2.05b.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/packages/bash/bash_2.05b.bb b/packages/bash/bash_2.05b.bb
index e69de29bb2..775bdf860c 100644
--- a/packages/bash/bash_2.05b.bb
+++ b/packages/bash/bash_2.05b.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+DEPENDS = "ncurses"
+SECTION = "base/shell"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
+ file://bashbug-editor.patch;patch=1;pnum=0 \
+ file://deb-bash-config.patch;patch=1 \
+ file://deb-examples.patch;patch=1;pnum=0 \
+ file://man-arithmetic.patch;patch=1;pnum=0 \
+ file://man-fignore.patch;patch=1;pnum=0 \
+ file://man-bashrc.patch;patch=1 \
+ file://privmode.patch;patch=1 \
+ file://various.patch;patch=1 \
+ file://report-155436.patch;patch=1;pnum=0 \
+ file://bash205b-001.patch;patch=1;pnum=0 \
+ file://bash205b-002.patch;patch=1;pnum=0 \
+ file://bash205b-003.patch;patch=1;pnum=0 \
+ file://bash205b-004.patch;patch=1;pnum=0 \
+ file://bash205b-005.patch;patch=1;pnum=0 \
+ file://bash205b-006.patch;patch=1;pnum=0 \
+ file://bash205b-007.patch;patch=1;pnum=0 \
+ file://rl-examples.patch;patch=1;pnum=0 \
+ file://rl-inputrc.patch;patch=1 \
+ file://rl-del-backspace-policy.patch;patch=1;pnum=0 \
+ file://rl-8bit-init.patch;patch=1 \
+ file://rl-slow-multibyte.patch;patch=1 \
+ file://s390-build.patch;patch=1;pnum=0 \
+ file://rbash-manpage.patch;patch=1;pnum=0 \
+ file://rbash-login-shell.patch;patch=1 \
+ file://execute-cmd.patch;patch=1 \
+ file://builtins-shift.patch;patch=1;pnum=0 \
+ file://suspend-segfault.patch;patch=1 \
+ file://mailcheck.patch;patch=1 \
+ file://autofoo.patch;patch=1 \
+ file://gcc34.patch;patch=1 \
+ file://signames-mipsel.diff;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/sh"
+ALTERNATIVE_NAME = "sh"
+ALTERNATIVE_PATH = "${bindir}/bash"
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-curses"
+BUILD_CPPFLAGS_append = " -I${S} -I${S}/include"
+BUILD_CFLAGS_append = " -I${S} -I${S}/include"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
+export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS}"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+ if [ ! -e acinclude.m4 ]; then
+ mv aclocal.m4 acinclude.m4
+ fi
+ autotools_do_configure
+}