aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-08-11 20:03:56 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-11 20:03:56 +0000
commit122c43cb0589c423749b9f046ceed1ab53bee9f6 (patch)
treef4381920fc7e84bf5eabd3cd37bf6adeee33fbec /packages/binutils
parent5f016dabf20ee6196f7e141e7f499a09b7342f91 (diff)
downloadopenembedded-122c43cb0589c423749b9f046ceed1ab53bee9f6.tar.gz
This set of changes ensures that TARGET_CC_ARCH is passed reliably to all
packages in a build. The change fixes problems in the following packages: binutils{,-cross}_2.15.94.0.1 HOST_CC_ARCH was not being passed to HOST_CC. The problem does not seem to be present in binutils* 2.16, however this version is still used for uClibc builds. gcc{,-cross,-cross-initial}_3.4.4 HOST/TARGET_CC_ARCH was not used in the appropriate places, plus this was not sufficient - FLAGS_FOR_TARGET (a gcc make variable) is now preloaded with the target CC_ARCH values, which causes all the builds (gcc, g++, gcj, fortran) to get the correct values. gcc OTHER *NOT* fixed - other versions of gcc will still need the _CC_ARCH fix in the same lines (CC_FOR_TARGET, GCC_FOR_TARGET, CXX_FOR_TARGET), however so long as these builds use gcc3-*.inc the FLAGS_FOR_TARGET fixx will be there. uclibc{,-initial}_0.9.27 TARGET_CC_ARCH added to the do_compile. For the do_stage step the build actually compiles target code (make utils), but this will not accept a CC with whitespace. The TARGET_CC_ARCH flags have therefore been added to CFLAGS (a bit ugly, but it works). These changes have been tested for both cross and target builds, the changes should be fine on self-hosted (i.e. target-hosted) builds, if anyone actually does these, but note that the gcc build specifically tests for build==host and does *not* do certain _FOR_TARGET settings in this case (this was the case before this change too) - if you are seeing strange settings on self-hosted gcc builds (before and after this change) check the do_compile environment variable settings.
Diffstat (limited to 'packages/binutils')
-rw-r--r--packages/binutils/binutils_2.15.94.0.1.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/binutils/binutils_2.15.94.0.1.bb b/packages/binutils/binutils_2.15.94.0.1.bb
index f8d39b1720..5edf4548a3 100644
--- a/packages/binutils/binutils_2.15.94.0.1.bb
+++ b/packages/binutils/binutils_2.15.94.0.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/binutils/"
SECTION = "devel"
LICENSE = "GPL"
MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
-PR = "r0"
+PR = "r1"
inherit autotools gettext
@@ -69,14 +69,14 @@ export LD_FOR_TARGET = "${TARGET_PREFIX}ld"
export NM_FOR_TARGET = "${TARGET_PREFIX}nm"
export RANLIB_FOR_TARGET = "${TARGET_PREFIX}ranlib"
-export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc"
-export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc"
+export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
+export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
export CC_FOR_BUILD = "${BUILD_CC}"
export CPP_FOR_BUILD = "${BUILD_CPP}"
export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CC = "${CCACHE} ${HOST_PREFIX}gcc"
+export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
do_configure () {
(cd ${S}; gnu-configize) || die "Failed to run gnu-configize"