aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-08-11 08:20:11 +0000
committerHolger Freyther <zecke@selfish.org>2006-08-11 08:20:11 +0000
commit3ad072fab792d2824057a75d8e7cf44c5464cb12 (patch)
treed214022a9abbc87f237f00eaf0df524fe1b00a48 /packages/binutils
parent8099caf59b566208b0516b82e0be2d0abc960656 (diff)
downloadopenembedded-3ad072fab792d2824057a75d8e7cf44c5464cb12.tar.gz
packages/binutils: Binutils 2.17 make compile on OSX
OSX claims that stopc might end up uninitialized. Initialize it to '0' to and hope it works out. This fixes the compile and I have an ARM EABI toolchain on OSX that could work...
Diffstat (limited to 'packages/binutils')
-rw-r--r--packages/binutils/binutils-2.17/warning-free.patch94
-rw-r--r--packages/binutils/binutils_2.17.bb3
2 files changed, 97 insertions, 0 deletions
diff --git a/packages/binutils/binutils-2.17/warning-free.patch b/packages/binutils/binutils-2.17/warning-free.patch
new file mode 100644
index 0000000000..e6424ff59f
--- /dev/null
+++ b/packages/binutils/binutils-2.17/warning-free.patch
@@ -0,0 +1,94 @@
+Index: binutils-2.17/gas/read.c
+===================================================================
+--- binutils-2.17.orig/gas/read.c 2006-08-08 11:25:56.000000000 +0200
++++ binutils-2.17/gas/read.c 2006-08-10 11:19:24.000000000 +0200
+@@ -1283,7 +1283,7 @@
+ unsigned int align_limit = ALIGN_LIMIT;
+ unsigned int align;
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+ offsetT fill = 0;
+ int max;
+ int fill_p;
+@@ -1427,7 +1427,7 @@
+ offsetT temp, size;
+ symbolS *symbolP = NULL;
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+ expressionS exp;
+
+ if (flag_mri)
+@@ -1542,7 +1542,7 @@
+ symbolS *sym;
+ offsetT align;
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ if (!flag_mri)
+ {
+@@ -1811,7 +1811,7 @@
+ {
+ offsetT temp;
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ if (flag_mri)
+ stop = mri_comment_field (&stopc);
+@@ -1933,7 +1933,7 @@
+ int c;
+ symbolS *symbolP;
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ if (flag_mri)
+ stop = mri_comment_field (&stopc);
+@@ -2885,7 +2885,7 @@
+ expressionS val;
+ char *p = 0;
+ char *stop = NULL;
+- char stopc;
++ char stopc=0;
+ int bytes;
+
+ #ifdef md_flush_pending_output
+@@ -3061,7 +3061,7 @@
+ int flen;
+ char temp[MAXIMUM_NUMBER_OF_CHARS_FOR_FLOAT];
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ if (flag_mri)
+ stop = mri_comment_field (&stopc);
+@@ -3138,7 +3138,7 @@
+ s_struct (int ignore ATTRIBUTE_UNUSED)
+ {
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ if (flag_mri)
+ stop = mri_comment_field (&stopc);
+@@ -3518,7 +3518,7 @@
+ int c;
+ expressionS exp;
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ #ifdef md_flush_pending_output
+ md_flush_pending_output ();
+@@ -5014,7 +5014,7 @@
+ equals (char *sym_name, int reassign)
+ {
+ char *stop = NULL;
+- char stopc;
++ char stopc = 0;
+
+ input_line_pointer++;
+ if (*input_line_pointer == '=')
diff --git a/packages/binutils/binutils_2.17.bb b/packages/binutils/binutils_2.17.bb
index 3edbe204e8..d9e167f051 100644
--- a/packages/binutils/binutils_2.17.bb
+++ b/packages/binutils/binutils_2.17.bb
@@ -22,6 +22,9 @@ SRC_URI += "\
file://400-mips-ELF_MAXPAGESIZE-4K.patch;patch=1 \
"
+# Zecke's OSX fixes
+SRC_URI += " file://warning-free.patch;patch=1 "
+
S = "${WORKDIR}/binutils-${PV}"
B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"