aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-27 16:29:51 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-27 16:29:51 +0000
commitdc65500908f11b42bece3477e8d933e331009301 (patch)
treef745e683edad9c5d22997b151700bd5d596783c9 /packages/binutils
parent154ce545bf6b5b9d3c6422a4167d4ce45a09b8af (diff)
downloadopenembedded-dc65500908f11b42bece3477e8d933e331009301.tar.gz
binutils: Add 2.16.1
Diffstat (limited to 'packages/binutils')
-rw-r--r--packages/binutils/binutils-2.16.1/.mtn2git_empty0
-rw-r--r--packages/binutils/binutils-2.16.1/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch31
-rw-r--r--packages/binutils/binutils-cross_2.16.1.bb3
-rw-r--r--packages/binutils/binutils_2.16.1.bb14
4 files changed, 48 insertions, 0 deletions
diff --git a/packages/binutils/binutils-2.16.1/.mtn2git_empty b/packages/binutils/binutils-2.16.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/binutils/binutils-2.16.1/.mtn2git_empty
diff --git a/packages/binutils/binutils-2.16.1/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch b/packages/binutils/binutils-2.16.1/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
new file mode 100644
index 0000000000..4461bedd4e
--- /dev/null
+++ b/packages/binutils/binutils-2.16.1/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
@@ -0,0 +1,31 @@
+# strip (and objcopy) fail to set the error code if there is no
+# output file name and the rename of the stripped (or copied) file
+# fails, yet the command fails to do anything. This fixes both
+# objcopy and strip.
+#
+# modification by bero: Ported to 2.16.91.0.6
+#
+#Signed-off-by: John Bowler <jbowler@acm.org>
+#Signed-off-by: Bernhard Rosenkraenzer <bero@arklinux.org>
+--- binutils-2.16.91.0.6/binutils/objcopy.c.ark 2006-03-11 15:59:07.000000000 +0100
++++ binutils-2.16.91.0.6/binutils/objcopy.c 2006-03-11 15:59:45.000000000 +0100
+@@ -2593,7 +2593,8 @@
+ if (preserve_dates)
+ set_times (tmpname, &statbuf);
+ if (output_file == NULL)
+- smart_rename (tmpname, argv[i], preserve_dates);
++ if(smart_rename (tmpname, argv[i], preserve_dates))
++ hold_status = 1;
+ status = hold_status;
+ }
+ else
+@@ -3184,7 +3185,8 @@
+ {
+ if (preserve_dates)
+ set_times (tmpname, &statbuf);
+- smart_rename (tmpname, input_filename, preserve_dates);
++ if (smart_rename (tmpname, input_filename, preserve_dates))
++ status = 1;
+ }
+ else
+ unlink (tmpname);
diff --git a/packages/binutils/binutils-cross_2.16.1.bb b/packages/binutils/binutils-cross_2.16.1.bb
new file mode 100644
index 0000000000..d245f7d11a
--- /dev/null
+++ b/packages/binutils/binutils-cross_2.16.1.bb
@@ -0,0 +1,3 @@
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
+require binutils_${PV}.bb
+require binutils-cross.inc
diff --git a/packages/binutils/binutils_2.16.1.bb b/packages/binutils/binutils_2.16.1.bb
new file mode 100644
index 0000000000..cc92da3e35
--- /dev/null
+++ b/packages/binutils/binutils_2.16.1.bb
@@ -0,0 +1,14 @@
+
+CROSSTOOL_PATCH_URL = "http://www.kegel.com/crosstool/crosstool-0.43/patches/binutils-2.16.1/"
+SRC_URI = \
+ "${GNU_MIRROR}/binutils/binutils-${PV}.tar.bz2 \
+ ${CROSSTOOL_PATCH_URL}bfd-hash-tweak.patch;patch=1 \
+ ${CROSSTOOL_PATCH_URL}binutils-2.15-psignal.patch;patch=1 \
+ ${CROSSTOOL_PATCH_URL}binutils-skip-comments.patch;patch=1 \
+ ${CROSSTOOL_PATCH_URL}callahan.patch;patch=1 \
+ ${CROSSTOOL_PATCH_URL}cross-gprof.patch;patch=1 \
+ ${CROSSTOOL_PATCH_URL}stabs-tweak.patch;patch=1 \
+ file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1"
+
+
+require binutils.inc