aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-03 01:52:01 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-03 01:52:01 +0000
commit96456ef68efb938cdf44ab32d6fe73c1f59223d8 (patch)
tree7dab96781719bcfc7b072daf9fcc43ccb8e86af8 /packages/binutils
parent947a5ee7adcefe5c857dffd5d64db50006a843d2 (diff)
downloadopenembedded-96456ef68efb938cdf44ab32d6fe73c1f59223d8.tar.gz
binutils: change do_stage to use autotools_stage_all in binutils.inc
Diffstat (limited to 'packages/binutils')
-rw-r--r--packages/binutils/binutils-cross-sdk_2.15.91.0.2.bb2
-rw-r--r--packages/binutils/binutils.inc10
-rw-r--r--packages/binutils/binutils_2.16.bb13
3 files changed, 3 insertions, 22 deletions
diff --git a/packages/binutils/binutils-cross-sdk_2.15.91.0.2.bb b/packages/binutils/binutils-cross-sdk_2.15.91.0.2.bb
index 7b51227cde..65130e6345 100644
--- a/packages/binutils/binutils-cross-sdk_2.15.91.0.2.bb
+++ b/packages/binutils/binutils-cross-sdk_2.15.91.0.2.bb
@@ -1,5 +1,5 @@
SECTION = "devel"
-PR = "r1"
+PR = "r2"
include binutils_${PV}.bb
inherit sdk
DEPENDS += "flex-native bison-native"
diff --git a/packages/binutils/binutils.inc b/packages/binutils/binutils.inc
index 680e579a06..938fc5754e 100644
--- a/packages/binutils/binutils.inc
+++ b/packages/binutils/binutils.inc
@@ -63,15 +63,7 @@ do_configure () {
}
do_stage () {
- oe_libinstall -so -a -C opcodes libopcodes ${STAGING_LIBDIR}/
- oe_libinstall -a -C libiberty libiberty ${STAGING_LIBDIR}/
- oe_libinstall -so -a -C bfd libbfd ${STAGING_LIBDIR}/
- install -m 0644 ${S}/include/dis-asm.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/symcat.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/libiberty.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/ansidecl.h ${STAGING_INCDIR}/
- install -m 0644 ${S}/include/bfdlink.h ${STAGING_INCDIR}/
- install -m 0644 bfd/bfd.h ${STAGING_INCDIR}/
+ autotools_stage_all
}
do_install () {
diff --git a/packages/binutils/binutils_2.16.bb b/packages/binutils/binutils_2.16.bb
index bb66ca6741..d852a2b658 100644
--- a/packages/binutils/binutils_2.16.bb
+++ b/packages/binutils/binutils_2.16.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/binutils/"
SECTION = "devel"
LICENSE = "GPL"
MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
-PR = "r3"
+PR = "r4"
SRC_URI = \
"http://ftp.gnu.org/gnu/binutils/binutils-${PV}.tar.bz2 \
@@ -19,18 +19,7 @@ SRC_URI += "file://binutils-2.16-linux-uclibc.patch;patch=1"
SRC_URI += "file://binutils-2.16-thumb-trampoline.patch;patch=1"
SRC_URI += "file://binutils-2.16-thumb-glue.patch;patch=1"
-#to be removed:
-# this patch does not seem to do anything any longer
-#SRC_URI += "file://binutils-2.15.90.0.3-uclibc-200-build_modules.patch;patch=1"
-
S = "${WORKDIR}/binutils-${PV}"
B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
include binutils.inc
-
-#to be removed:
-# This was not doing anything because it used the ${B} directory and there
-# was no configure.ac or configure.in in there.
-#do_configure_prepend() {
-# for dir in bfd gas ld; do ( cd $dir; autoreconf ); done
-#}