aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-10-31 13:46:47 +0000
committerKoen Kooi <koen@openembedded.org>2007-10-31 13:46:47 +0000
commit44cbb9985f111ce87e6990061c89e2e061b6c6ea (patch)
treef26c7f7df66d468547e5b5cc8ba8dc328c44f08d /packages/binutils
parent43b6ecbcb39354a32e0b8dd7c02ec8789be0ab9a (diff)
parent821528ad116a72c2323d88d21e979614c78f1b41 (diff)
downloadopenembedded-44cbb9985f111ce87e6990061c89e2e061b6c6ea.tar.gz
propagate from branch 'org.openembedded.dev' (head a6b798a43c05aef43ed650ab880f3edd386d0aa3)
to branch 'org.openembedded.dev.avr32' (head 77e1041de2eef682f183f3f5199826818cb9c5b1)
Diffstat (limited to 'packages/binutils')
-rw-r--r--packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch19
-rw-r--r--packages/binutils/binutils-2.18/binutils-2.16.1-e300c2c3.patch19
-rw-r--r--packages/binutils/binutils_2.16.bb9
-rw-r--r--packages/binutils/binutils_2.18.bb6
4 files changed, 50 insertions, 3 deletions
diff --git a/packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch b/packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch
new file mode 100644
index 0000000000..c5e4234f22
--- /dev/null
+++ b/packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch
@@ -0,0 +1,19 @@
+Adds support for Freescale Power architecture e300c2 and e300c3 cores.
+http://www.bitshrine.org/gpp/tc-fsl-x86lnx-e300c3-nptl-4.0.2-2.src.rpm
+
+Leon Woestenberg <leonw@mailcan.com>
+
+diff -uNr binutils-2.16.1.orig/gas/config/tc-ppc.c binutils-2.16.1/gas/config/tc-ppc.c
+--- binutils-2.16.1.orig/gas/config/tc-ppc.c 2005-03-02 13:24:01.000000000 +0000
++++ binutils-2.16.1/gas/config/tc-ppc.c 2006-07-04 11:45:24.000000000 +0100
+@@ -879,6 +879,10 @@
+ else
+ ppc_cpu |= PPC_OPCODE_SPE;
+ }
++ else if (strcmp (arg, "pmr") == 0)
++ {
++ ppc_cpu |= PPC_OPCODE_PMR;
++ }
+ /* -mppc64 and -m620 mean to assemble for the 64-bit PowerPC
+ 620. */
+ else if (strcmp (arg, "ppc64") == 0 || strcmp (arg, "620") == 0)
diff --git a/packages/binutils/binutils-2.18/binutils-2.16.1-e300c2c3.patch b/packages/binutils/binutils-2.18/binutils-2.16.1-e300c2c3.patch
new file mode 100644
index 0000000000..c5e4234f22
--- /dev/null
+++ b/packages/binutils/binutils-2.18/binutils-2.16.1-e300c2c3.patch
@@ -0,0 +1,19 @@
+Adds support for Freescale Power architecture e300c2 and e300c3 cores.
+http://www.bitshrine.org/gpp/tc-fsl-x86lnx-e300c3-nptl-4.0.2-2.src.rpm
+
+Leon Woestenberg <leonw@mailcan.com>
+
+diff -uNr binutils-2.16.1.orig/gas/config/tc-ppc.c binutils-2.16.1/gas/config/tc-ppc.c
+--- binutils-2.16.1.orig/gas/config/tc-ppc.c 2005-03-02 13:24:01.000000000 +0000
++++ binutils-2.16.1/gas/config/tc-ppc.c 2006-07-04 11:45:24.000000000 +0100
+@@ -879,6 +879,10 @@
+ else
+ ppc_cpu |= PPC_OPCODE_SPE;
+ }
++ else if (strcmp (arg, "pmr") == 0)
++ {
++ ppc_cpu |= PPC_OPCODE_PMR;
++ }
+ /* -mppc64 and -m620 mean to assemble for the 64-bit PowerPC
+ 620. */
+ else if (strcmp (arg, "ppc64") == 0 || strcmp (arg, "620") == 0)
diff --git a/packages/binutils/binutils_2.16.bb b/packages/binutils/binutils_2.16.bb
index a03f355379..b9195c57ff 100644
--- a/packages/binutils/binutils_2.16.bb
+++ b/packages/binutils/binutils_2.16.bb
@@ -1,7 +1,7 @@
-PR = "r7"
+PR = "r8"
SRC_URI = \
- "http://ftp.gnu.org/gnu/binutils/binutils-${PV}.tar.bz2 \
+ "${GNU_MIRROR}/binutils/binutils-${PV}.tar.bz2 \
file://ld_makefile.patch;patch=1 \
file://better_file_error.patch;patch=1 \
file://signed_char_fix.patch;patch=1 \
@@ -11,8 +11,11 @@ SRC_URI = \
# uclibc patches
SRC_URI += "file://binutils-2.16-linux-uclibc.patch;patch=1"
-# thumb support patches
+# arm thumb support patches
SRC_URI += "file://binutils-2.16-thumb-trampoline.patch;patch=1"
SRC_URI += "file://binutils-2.16-thumb-glue.patch;patch=1"
+# powerpc patches
+SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;patch=1"
+
require binutils.inc
diff --git a/packages/binutils/binutils_2.18.bb b/packages/binutils/binutils_2.18.bb
index 78000c7af6..b6a230cb18 100644
--- a/packages/binutils/binutils_2.18.bb
+++ b/packages/binutils/binutils_2.18.bb
@@ -1,3 +1,5 @@
+PR = "r1"
+
require binutils.inc
SRC_URI = "\
@@ -10,3 +12,7 @@ SRC_URI = "\
file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
"
+
+# powerpc patches
+SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;patch=1"
+