aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-10-18 16:15:40 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-10-18 16:15:40 +0000
commit55c98bbee7f1e37196b6c5e1b3f1d53acda8698b (patch)
tree8ce705946833954b813b394336cfbd9c937fd6b4 /packages/binutils
parent2995925f6a3af176037d52e9c5b3feee19b8b89f (diff)
downloadopenembedded-55c98bbee7f1e37196b6c5e1b3f1d53acda8698b.tar.gz
binutils-2.16: Added support for powerpc e300c3 core. Bumped PV for your pleasure.
Diffstat (limited to 'packages/binutils')
-rw-r--r--packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch19
-rw-r--r--packages/binutils/binutils_2.16.bb4
2 files changed, 22 insertions, 1 deletions
diff --git a/packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch b/packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch
new file mode 100644
index 0000000000..c5e4234f22
--- /dev/null
+++ b/packages/binutils/binutils-2.16/binutils-2.16.1-e300c2c3.patch
@@ -0,0 +1,19 @@
+Adds support for Freescale Power architecture e300c2 and e300c3 cores.
+http://www.bitshrine.org/gpp/tc-fsl-x86lnx-e300c3-nptl-4.0.2-2.src.rpm
+
+Leon Woestenberg <leonw@mailcan.com>
+
+diff -uNr binutils-2.16.1.orig/gas/config/tc-ppc.c binutils-2.16.1/gas/config/tc-ppc.c
+--- binutils-2.16.1.orig/gas/config/tc-ppc.c 2005-03-02 13:24:01.000000000 +0000
++++ binutils-2.16.1/gas/config/tc-ppc.c 2006-07-04 11:45:24.000000000 +0100
+@@ -879,6 +879,10 @@
+ else
+ ppc_cpu |= PPC_OPCODE_SPE;
+ }
++ else if (strcmp (arg, "pmr") == 0)
++ {
++ ppc_cpu |= PPC_OPCODE_PMR;
++ }
+ /* -mppc64 and -m620 mean to assemble for the 64-bit PowerPC
+ 620. */
+ else if (strcmp (arg, "ppc64") == 0 || strcmp (arg, "620") == 0)
diff --git a/packages/binutils/binutils_2.16.bb b/packages/binutils/binutils_2.16.bb
index a03f355379..578d05c8d0 100644
--- a/packages/binutils/binutils_2.16.bb
+++ b/packages/binutils/binutils_2.16.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
SRC_URI = \
"http://ftp.gnu.org/gnu/binutils/binutils-${PV}.tar.bz2 \
@@ -8,6 +8,8 @@ SRC_URI = \
file://binutils-2.16-objcopy-rename-errorcode.patch;patch=1 \
file://binutils-100_cflags_for_build.patch;patch=1"
+SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;patch=1"
+
# uclibc patches
SRC_URI += "file://binutils-2.16-linux-uclibc.patch;patch=1"