aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bluez
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-07-04 23:34:18 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-07-04 23:34:18 +0000
commite45268ec831c439a5159e147a02dccce7a6b4d0e (patch)
tree777008f51321e676dc909e9403c0ddbe37ca6995 /packages/bluez
parentbe38316990d805b15eb51fb75665ee20e95d6672 (diff)
downloadopenembedded-e45268ec831c439a5159e147a02dccce7a6b4d0e.tar.gz
bluez: Stop 02dtl1_cs.sh the nasty hack from breaking everyone's BT connection.
* This sloppily written script just unconditionally breaks a BT connection on suspend. * So, instead, make only DTL1 victims suffer it thru: 1. Make a separate package for it. 2. Make kernel-module-dtl1-cs and nothing else RDEPENDS on it.
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/bluez-dtl1-workaround_1.0.bb14
-rw-r--r--packages/bluez/bluez-utils.inc2
-rw-r--r--packages/bluez/bluez-utils_3.11.bb6
-rw-r--r--packages/bluez/bluez-utils_3.12.bb6
-rw-r--r--packages/bluez/bluez-utils_3.4.bb2
-rw-r--r--packages/bluez/bluez-utils_3.7.bb2
-rw-r--r--packages/bluez/bluez-utils_3.8.bb4
7 files changed, 17 insertions, 19 deletions
diff --git a/packages/bluez/bluez-dtl1-workaround_1.0.bb b/packages/bluez/bluez-dtl1-workaround_1.0.bb
new file mode 100644
index 0000000000..7c08d347db
--- /dev/null
+++ b/packages/bluez/bluez-dtl1-workaround_1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A nasty hack for for dtl1-cs driver to workaround suspend/resume."
+SECTION = "console"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "file://02dtl1_cs.sh"
+
+do_install() {
+ install -d ${D}${sysconfdir}/apm/event.d/
+ install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
+}
+
+#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
+FILES_${PN} += "${sysconfdir}/apm/"
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index b6f9660fa7..8eb4fbfbf0 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -10,7 +10,6 @@ LICENSE = "GPL"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1 \
file://handle-eintr.patch;patch=1;status=applied"
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/
}
diff --git a/packages/bluez/bluez-utils_3.11.bb b/packages/bluez/bluez-utils_3.11.bb
index 2419f431f6..6cadfc1a53 100644
--- a/packages/bluez/bluez-utils_3.11.bb
+++ b/packages/bluez/bluez-utils_3.11.bb
@@ -6,9 +6,8 @@ DEPENDS += "glib-2.0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF = " \
--enable-bccmd \
@@ -84,9 +83,6 @@ FILES_${PN} = " \
${base_sbindir}/hciattach \
"
-#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
-FILES_${PN} += "${sysconfdir}/apm/"
-
FILES_${PN}-dbg += " \
${libdir}/bluetooth/.debug \
"
diff --git a/packages/bluez/bluez-utils_3.12.bb b/packages/bluez/bluez-utils_3.12.bb
index e543eed649..4710aa6779 100644
--- a/packages/bluez/bluez-utils_3.12.bb
+++ b/packages/bluez/bluez-utils_3.12.bb
@@ -4,9 +4,8 @@ DEPENDS += "glib-2.0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF = " \
--enable-bccmd \
@@ -82,9 +81,6 @@ FILES_${PN} = " \
${base_sbindir}/hciattach \
"
-#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
-FILES_${PN} += "${sysconfdir}/apm/"
-
FILES_${PN}-dbg += " \
${libdir}/bluetooth/.debug \
"
diff --git a/packages/bluez/bluez-utils_3.4.bb b/packages/bluez/bluez-utils_3.4.bb
index 49e6ded250..f2bbd15507 100644
--- a/packages/bluez/bluez-utils_3.4.bb
+++ b/packages/bluez/bluez-utils_3.4.bb
@@ -11,7 +11,6 @@ PR = "r1"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/bluez/bluez-utils_3.7.bb b/packages/bluez/bluez-utils_3.7.bb
index 3dbaa030c1..7a76cb3200 100644
--- a/packages/bluez/bluez-utils_3.7.bb
+++ b/packages/bluez/bluez-utils_3.7.bb
@@ -11,7 +11,6 @@ PR = "r0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/bluez/bluez-utils_3.8.bb b/packages/bluez/bluez-utils_3.8.bb
index d549d12d30..f2bbd15507 100644
--- a/packages/bluez/bluez-utils_3.8.bb
+++ b/packages/bluez/bluez-utils_3.8.bb
@@ -7,11 +7,10 @@ RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus"
RREPLACES = "bluez-utils-dbus"
RCONFLICTS_${PN} = "bluez-utils-nodbus"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \