aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bluez
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2005-09-21 13:43:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-21 13:43:38 +0000
commit246be68e76096fe0148e30ac908bea204e12a4f3 (patch)
treec8444a391715828b1a2b85feb65b4109f6653984 /packages/bluez
parentb319c41459468efd93f1ab42f26894fc132779c1 (diff)
downloadopenembedded-246be68e76096fe0148e30ac908bea204e12a4f3.tar.gz
bluez-libs,bluez-utils: new version 2.21
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/bluez-libs_2.21.bb22
-rw-r--r--packages/bluez/bluez-utils-2.21.inc48
-rw-r--r--packages/bluez/bluez-utils-dbus_2.21.bb5
-rw-r--r--packages/bluez/bluez-utils-nodbus_2.21.bb3
4 files changed, 78 insertions, 0 deletions
diff --git a/packages/bluez/bluez-libs_2.21.bb b/packages/bluez/bluez-libs_2.21.bb
new file mode 100644
index 0000000000..d740bd80a9
--- /dev/null
+++ b/packages/bluez/bluez-libs_2.21.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+ oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/bluetooth/
+ for f in ${HEADERS}
+ do
+ install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+ done
+}
diff --git a/packages/bluez/bluez-utils-2.21.inc b/packages/bluez/bluez-utils-2.21.inc
new file mode 100644
index 0000000000..d4d1bdc387
--- /dev/null
+++ b/packages/bluez/bluez-utils-2.21.inc
@@ -0,0 +1,48 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Utilities."
+SECTION = "console"
+PRIORITY = "optional"
+DEPENDS = "bluez-libs-${PV} pcmcia-cs"
+RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
+ file://base.patch;patch=1 \
+ file://blueboxes.patch;patch=1 \
+ file://hcid.conf \
+ file://bluetooth.default \
+ file://bluetooth.conf "
+
+# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
+# Let's default to that instead of 'any' and see if we break something with that
+SRC_URI_append_familiar = " file://default-manfid-0x0-to-bcps.patch;patch=1"
+SRC_URI_append_openzaurus = " file://default-manfid-0x0-to-bcps.patch;patch=1"
+
+S = "${WORKDIR}/bluez-utils-${PV}"
+
+EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR} \
+ --enable-pcmcia --enable-initscripts --enable-bcm203x"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "bluetooth"
+INITSCRIPT_PARAMS = "defaults 23 19"
+
+do_install_append() {
+ install -d ${D}${base_sbindir} ${D}${base_bindir}/
+ mv ${D}${sbindir}/* ${D}${base_sbindir}/
+ mv ${D}${bindir}/* ${D}${base_bindir}/
+ rmdir ${D}${bindir} ${D}${sbindir}
+ chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
+ chmod 755 ${D}${sysconfdir}/pcmcia/bluetooth
+ install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
+ install -m 0644 ${WORKDIR}/bluetooth.default ${D}${sysconfdir}/default/bluetooth
+ cat ${WORKDIR}/bluetooth.conf >> ${D}${sysconfdir}/pcmcia/bluetooth.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
+ ${sysconfdir}/bluetooth/pin ${sysconfdir}/default/bluetooth"
+
+PACKAGES =+ "${PN}-ciptool ${PN}-bluepin"
+FILES_${PN}-ciptool = "/bin/ciptool"
+FILES_${PN}-bluepin = "/bin/bluepin"
diff --git a/packages/bluez/bluez-utils-dbus_2.21.bb b/packages/bluez/bluez-utils-dbus_2.21.bb
new file mode 100644
index 0000000000..3e89e8408d
--- /dev/null
+++ b/packages/bluez/bluez-utils-dbus_2.21.bb
@@ -0,0 +1,5 @@
+include bluez-utils-${PV}.inc
+DEPENDS += "dbus"
+SRC_URI += "file://smash.patch;patch=1 \
+ file://hcid-alignment-fix.patch;patch=1"
+EXTRA_OECONF += "--with-dbus"
diff --git a/packages/bluez/bluez-utils-nodbus_2.21.bb b/packages/bluez/bluez-utils-nodbus_2.21.bb
new file mode 100644
index 0000000000..43230271d9
--- /dev/null
+++ b/packages/bluez/bluez-utils-nodbus_2.21.bb
@@ -0,0 +1,3 @@
+include bluez-utils-${PV}.inc
+
+EXTRA_OECONF += "--without-dbus"