aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bluez
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-02 12:42:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-02 12:42:09 +0000
commit8998ef3fe7b3bc3a45b627993d905a2965784f36 (patch)
tree5d4cce033398cf9db517c8ffabf11e1dc1f86174 /packages/bluez
parent23430ca54377133de1107c3cec6d4d063388cc03 (diff)
downloadopenembedded-8998ef3fe7b3bc3a45b627993d905a2965784f36.tar.gz
bluez: update and put related .bb files into one directory
- bluez-libs, bluez-utils, and bluez-hcidump are pretty tied, so I think it makes sense to put them into the same directory - update bluez-libs to 2.20 - update bluez-hcidump to 1.25 - enable default-manfid patch
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/.mtn2git_empty0
-rw-r--r--packages/bluez/bluez-hcidump_1.25.bb15
-rw-r--r--packages/bluez/bluez-libs_2.20.bb22
-rw-r--r--packages/bluez/bluez-utils-dbus/.mtn2git_empty0
-rw-r--r--packages/bluez/bluez-utils-dbus/dbus.patch58
-rw-r--r--packages/bluez/bluez-utils-dbus/hcid.conf72
-rw-r--r--packages/bluez/bluez-utils-dbus/smash.patch11
-rw-r--r--packages/bluez/bluez-utils-dbus_2.20.bb5
-rw-r--r--packages/bluez/bluez-utils-nodbus_2.20.bb4
-rw-r--r--packages/bluez/bluez-utils.inc48
-rw-r--r--packages/bluez/files/.mtn2git_empty0
-rw-r--r--packages/bluez/files/base.patch33
-rw-r--r--packages/bluez/files/blueboxes.patch18
-rw-r--r--packages/bluez/files/bluetooth.conf11
-rw-r--r--packages/bluez/files/bluetooth.default37
-rw-r--r--packages/bluez/files/default-manfid-0x0-to-bcps.patch22
-rw-r--r--packages/bluez/files/hcid.conf72
-rw-r--r--packages/bluez/files/openmn/.mtn2git_empty0
-rw-r--r--packages/bluez/files/openmn/bluetooth.default37
-rw-r--r--packages/bluez/files/openmn/hcid.conf70
-rw-r--r--packages/bluez/files/openslug/.mtn2git_empty0
-rw-r--r--packages/bluez/files/openslug/bluetooth.default37
-rw-r--r--packages/bluez/files/openslug/hcid.conf70
23 files changed, 642 insertions, 0 deletions
diff --git a/packages/bluez/.mtn2git_empty b/packages/bluez/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/.mtn2git_empty
diff --git a/packages/bluez/bluez-hcidump_1.25.bb b/packages/bluez/bluez-hcidump_1.25.bb
new file mode 100644
index 0000000000..0cbc0fd6ec
--- /dev/null
+++ b/packages/bluez/bluez-hcidump_1.25.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Linux Bluetooth Stack HCI Debugger Tool."
+SECTION = "console"
+PRIORITY = "optional"
+DEPENDS = "bluez-libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-hcidump-${PV}.tar.gz"
+S = "${WORKDIR}/bluez-hcidump-${PV}"
+
+EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR}"
+
+inherit autotools
+
+
diff --git a/packages/bluez/bluez-libs_2.20.bb b/packages/bluez/bluez-libs_2.20.bb
new file mode 100644
index 0000000000..d740bd80a9
--- /dev/null
+++ b/packages/bluez/bluez-libs_2.20.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+ oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/bluetooth/
+ for f in ${HEADERS}
+ do
+ install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+ done
+}
diff --git a/packages/bluez/bluez-utils-dbus/.mtn2git_empty b/packages/bluez/bluez-utils-dbus/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/bluez-utils-dbus/.mtn2git_empty
diff --git a/packages/bluez/bluez-utils-dbus/dbus.patch b/packages/bluez/bluez-utils-dbus/dbus.patch
new file mode 100644
index 0000000000..c5ab129469
--- /dev/null
+++ b/packages/bluez/bluez-utils-dbus/dbus.patch
@@ -0,0 +1,58 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.20/acinclude.m4~dbus.patch
++++ bluez-utils-2.20/acinclude.m4
+@@ -211,46 +211,15 @@
+ ])
+
+ AC_DEFUN([AC_PATH_DBUS], [
+- dbus_prefix=${prefix}
+-
+- AC_ARG_WITH(dbus, AC_HELP_STRING([--with-dbus=DIR], [D-BUS library is installed in DIR]), [
+- if (test "${withval}" != "yes"); then
+- dbus_prefix=${withval}
+- fi
+- ])
+-
+- ac_save_CPPFLAGS=$CPPFLAGS
+- ac_save_LDFLAGS=$LDFLAGS
+-
+- DBUS_CFLAGS="-DDBUS_API_SUBJECT_TO_CHANGE"
+- test -d "${dbus_prefix}/include/dbus-1.0" && DBUS_CFLAGS="$DBUS_CFLAGS -I${dbus_prefix}/include/dbus-1.0"
+- if (test "${prefix}" = "${bluez_prefix}"); then
+- test -d "${libdir}/dbus-1.0/include" && DBUS_CFLAGS="$DBUS_CFLAGS -I${libdir}/dbus-1.0/include"
+- else
+- test -d "${dbus_prefix}/lib64/dbus-1.0/include" && DBUS_CFLAGS="$DBUS_CFLAGS -I${dbus_prefix}/lib64/dbus-1.0/include"
+- test -d "${dbus_prefix}/lib/dbus-1.0/include" && DBUS_CFLAGS="$DBUS_CFLAGS -I${dbus_prefix}/lib/dbus-1.0/include"
+- fi
++ if pkg-config --exists dbus-1; then
++ dbus_found=yes ; DBUS_CFLAGS="`pkg-config --cflags dbus-1` -DDBUS_API_SUBJECT_TO_CHANGE"
++ DBUS_LIBS="`pkg-config --libs dbus-1`"
+
+ CPPFLAGS="$CPPFLAGS $DBUS_CFLAGS"
+- AC_CHECK_HEADER(dbus/dbus.h, dbus_found=yes, dbus_found=no)
+-
+- DBUS_LIBS=""
+- if (test "${prefix}" = "${dbus_prefix}"); then
+- test -d "${libdir}" && DBUS_LIBS="$DBUS_LIBS -L${libdir}"
+- else
+- test -d "${dbus_prefix}/lib64" && DBUS_LIBS="$DBUS_LIBS -L${dbus_prefix}/lib64"
+- test -d "${dbus_prefix}/lib" && DBUS_LIBS="$DBUS_LIBS -L${dbus_prefix}/lib"
+- fi
+-
+ LDFLAGS="$LDFLAGS $DBUS_LIBS"
+- AC_CHECK_LIB(dbus-1, dbus_error_init, DBUS_LIBS="$DBUS_LIBS -ldbus-1", dbus_found=no)
+- AC_CHECK_LIB(dbus-1, dbus_message_iter_get_basic, AC_DEFINE(HAVE_DBUS_MESSAGE_ITER_GET_BASIC, 1, [Define to 1 if you have the dbus_message_iter_get_basic() function.]))
+-
+- CPPFLAGS=$ac_save_CPPFLAGS
+- LDFLAGS=$ac_save_LDFLAGS
+-
+ AC_SUBST(DBUS_CFLAGS)
+ AC_SUBST(DBUS_LIBS)
++ fi
+ ])
+
+ AC_DEFUN([AC_ARG_BLUEZ], [
diff --git a/packages/bluez/bluez-utils-dbus/hcid.conf b/packages/bluez/bluez-utils-dbus/hcid.conf
new file mode 100644
index 0000000000..ab3ca2aaee
--- /dev/null
+++ b/packages/bluez/bluez-utils-dbus/hcid.conf
@@ -0,0 +1,72 @@
+#
+# HCI daemon configuration file.
+#
+# $Id: hcid.conf,v 1.4 2004/04/29 20:14:21 holtmann Exp $
+#
+
+# HCId options
+options {
+ # Automatically initialize new devices
+ autoinit yes;
+
+ # Security Manager mode
+ # none - Security manager disabled
+ # auto - Use local PIN for incoming connections
+ # user - Always ask user for a PIN
+ #
+ security auto;
+
+ # Pairing mode
+ # none - Pairing disabled
+ # multi - Allow pairing with already paired devices
+ # once - Pair once and deny successive attempts
+ pairing multi;
+
+ # PIN helper
+ # pin_helper /usr/bin/bluepin;
+
+ # D-Bus PIN helper
+ dbus_pin_helper;
+}
+
+# Default settings for HCI devices
+device {
+ # Local device name
+ # %d - device id
+ # %h - host name
+ name "%h";
+
+ # Local device class
+ class 0x120112;
+
+ # Default packet type
+ #pkt_type DH1,DM1,HV1;
+
+ # Inquiry and Page scan
+ iscan enable; pscan enable;
+
+ # Default link mode
+ # none - no specific policy
+ # accept - always accept incoming connections
+ # master - become master on incoming connections,
+ # deny role switch on outgoing connections
+ #
+ #lm accept,master;
+ #
+ lm accept;
+
+ # Default link policy
+ # none - no specific policy
+ # rswitch - allow role switch
+ # hold - allow hold mode
+ # sniff - allow sniff mode
+ # park - allow park mode
+ #
+ #lp hold,sniff;
+ #
+ lp rswitch,hold,sniff,park;
+
+ # Authentication and Encryption
+ #auth enable;
+ encrypt enable;
+}
diff --git a/packages/bluez/bluez-utils-dbus/smash.patch b/packages/bluez/bluez-utils-dbus/smash.patch
new file mode 100644
index 0000000000..55cdbb7284
--- /dev/null
+++ b/packages/bluez/bluez-utils-dbus/smash.patch
@@ -0,0 +1,11 @@
+--- bluez-utils-2.11/hcid/dbus.c.old 2004-12-31 16:35:12.000000000 +0000
++++ bluez-utils-2.11/hcid/dbus.c 2004-12-31 16:39:58.000000000 +0000
+@@ -89,6 +89,8 @@
+
+ memset(&pr, 0, sizeof(pr));
+ bacpy(&pr.bdaddr, &req->bda);
++ if (len > sizeof (pr.pin_code))
++ goto error;
+ memcpy(pr.pin_code, pin, len);
+ pr.pin_len = len;
+ hci_send_cmd(req->dev, OGF_LINK_CTL, OCF_PIN_CODE_REPLY,
diff --git a/packages/bluez/bluez-utils-dbus_2.20.bb b/packages/bluez/bluez-utils-dbus_2.20.bb
new file mode 100644
index 0000000000..e54ff67085
--- /dev/null
+++ b/packages/bluez/bluez-utils-dbus_2.20.bb
@@ -0,0 +1,5 @@
+include bluez-utils.inc
+DEPENDS += "dbus"
+SRC_URI += "file://dbus.patch;patch=1 file://smash.patch;patch=1"
+EXTRA_OECONF += "--with-dbus"
+
diff --git a/packages/bluez/bluez-utils-nodbus_2.20.bb b/packages/bluez/bluez-utils-nodbus_2.20.bb
new file mode 100644
index 0000000000..487ace6e15
--- /dev/null
+++ b/packages/bluez/bluez-utils-nodbus_2.20.bb
@@ -0,0 +1,4 @@
+include bluez-utils.inc
+
+EXTRA_OECONF += "--without-dbus"
+
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
new file mode 100644
index 0000000000..b5a5e14970
--- /dev/null
+++ b/packages/bluez/bluez-utils.inc
@@ -0,0 +1,48 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Utilities."
+SECTION = "console"
+PRIORITY = "optional"
+DEPENDS = "bluez-libs-${PV} pcmcia-cs"
+RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils"
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
+ file://base.patch;patch=1 \
+ file://blueboxes.patch;patch=1 \
+ file://hcid.conf \
+ file://bluetooth.default \
+ file://bluetooth.conf "
+
+# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
+# Let's default to that instead of 'any' and see if we break something with that
+SRC_URI_append_familiar = " file://default-manfid-0x0-to-bcps.patch;patch=1"
+SRC_URI_append_openzaurus = " file://default-manfid-0x0-to-bcps.patch;patch=1"
+
+S = "${WORKDIR}/bluez-utils-${PV}"
+
+EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR} \
+ --enable-pcmcia --enable-initscripts --enable-bcm203x"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "bluetooth"
+INITSCRIPT_PARAMS = "defaults 23 19"
+
+do_install_append() {
+ install -d ${D}${base_sbindir} ${D}${base_bindir}/
+ mv ${D}${sbindir}/* ${D}${base_sbindir}/
+ mv ${D}${bindir}/* ${D}${base_bindir}/
+ rmdir ${D}${bindir} ${D}${sbindir}
+ chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
+ chmod 755 ${D}${sysconfdir}/pcmcia/bluetooth
+ install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
+ install -m 0644 ${WORKDIR}/bluetooth.default ${D}${sysconfdir}/default/bluetooth
+ cat ${WORKDIR}/bluetooth.conf >> ${D}${sysconfdir}/pcmcia/bluetooth.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
+ ${sysconfdir}/bluetooth/pin ${sysconfdir}/default/bluetooth"
+
+PACKAGES =+ "${PN}-ciptool ${PN}-bluepin"
+FILES_${PN}-ciptool = "/bin/ciptool"
+FILES_${PN}-bluepin = "/bin/bluepin"
diff --git a/packages/bluez/files/.mtn2git_empty b/packages/bluez/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/files/.mtn2git_empty
diff --git a/packages/bluez/files/base.patch b/packages/bluez/files/base.patch
new file mode 100644
index 0000000000..337c9aa73e
--- /dev/null
+++ b/packages/bluez/files/base.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.17/pcmcia/bluetooth~base.patch
++++ bluez-utils-2.17/pcmcia/bluetooth
+@@ -15,9 +15,16 @@
+
+ if [ -r ./shared ]; then . ./shared ; else . /etc/pcmcia/shared ; fi
+
++# Give the port some time to complete initialization
++sleep 5
++
+ # Get device attributes
+ get_info $DEVICE
+
++test "$DEVICE" = "ttyS7" && DEVICE="/dev/tts/7"
++test -z "$MANFID" && MANFID="bcsp"
++test "$MANFID" = "0000,0000" && MANFID="bcsp"
++
+ #
+ # Serial devices
+ #
+@@ -25,7 +32,7 @@
+ IRQ=`setserial /dev/$DEVICE | sed -e 's/.*IRQ: //'`
+ setserial /dev/$DEVICE irq 0 ; setserial /dev/$DEVICE irq $IRQ
+
+- /usr/sbin/hciattach $DEVICE $MANFID
++ /sbin/hciattach $DEVICE $MANFID
+ }
+ stop_serial() {
+ do_fuser -k -HUP /dev/$DEVICE > /dev/null
diff --git a/packages/bluez/files/blueboxes.patch b/packages/bluez/files/blueboxes.patch
new file mode 100644
index 0000000000..c429b06c06
--- /dev/null
+++ b/packages/bluez/files/blueboxes.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.14/pcmcia/bluetooth.conf~base
++++ bluez-utils-2.14/pcmcia/bluetooth.conf
+@@ -26,6 +26,10 @@
+ version "Brain Boxes", "Bluetooth PC Card"
+ bind "serial_cs" class "bluetooth"
+
++card "F+ Bluetooth_Card, BCSP"
++ manfid 0x0160, 0xaba0
++ bind "serial_cs" class "bluetooth"
++
+ card "IBM Bluetooth PC Card II"
+ version "IBM", "Bluetooth PC Card II"
+ bind "serial_cs" class "bluetooth"
diff --git a/packages/bluez/files/bluetooth.conf b/packages/bluez/files/bluetooth.conf
new file mode 100644
index 0000000000..bae8fae08e
--- /dev/null
+++ b/packages/bluez/files/bluetooth.conf
@@ -0,0 +1,11 @@
+#
+# additional cards for /etc/pcmcia/bluetooth.conf
+# Note for OE: This file is _appended_ to the stock
+# bluetooth.conf in bluez-utils, so no need to duplicate
+# entries for individual cards.
+#
+card "CSR BT01x0M Bluetooth CF Card"
+ version "Bluetooth BT0100M", "", ""
+ bind "serial_cs" class "bluetooth"
+
+
diff --git a/packages/bluez/files/bluetooth.default b/packages/bluez/files/bluetooth.default
new file mode 100644
index 0000000000..4817d38c60
--- /dev/null
+++ b/packages/bluez/files/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=true
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=true
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=true
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=false
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=false
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"
diff --git a/packages/bluez/files/default-manfid-0x0-to-bcps.patch b/packages/bluez/files/default-manfid-0x0-to-bcps.patch
new file mode 100644
index 0000000000..3d993543b3
--- /dev/null
+++ b/packages/bluez/files/default-manfid-0x0-to-bcps.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.16/tools/hciattach.c~default-manfid-0x0-to-bcps
++++ bluez-utils-2.16/tools/hciattach.c
+@@ -796,13 +796,12 @@
+ }
+
+ struct uart_t uart[] = {
++ { "bcsp", 0x0000, 0x0000, HCI_UART_BCSP, 115200, 115200, 0, bcsp },
+ { "any", 0x0000, 0x0000, HCI_UART_H4, 115200, 115200, FLOW_CTL, NULL },
+ { "ericsson", 0x0000, 0x0000, HCI_UART_H4, 57600, 115200, FLOW_CTL, ericsson },
+ { "digi", 0x0000, 0x0000, HCI_UART_H4, 9600, 115200, FLOW_CTL, digi },
+ { "texas", 0x0000, 0x0000, HCI_UART_H4, 115200, 115200, FLOW_CTL, texas },
+
+- { "bcsp", 0x0000, 0x0000, HCI_UART_BCSP, 115200, 115200, 0, bcsp },
+-
+ /* Xircom PCMCIA cards: Credit Card Adapter and Real Port Adapter */
+ { "xircom", 0x0105, 0x080a, HCI_UART_H4, 115200, 115200, FLOW_CTL, NULL },
+
diff --git a/packages/bluez/files/hcid.conf b/packages/bluez/files/hcid.conf
new file mode 100644
index 0000000000..44e9c46fb0
--- /dev/null
+++ b/packages/bluez/files/hcid.conf
@@ -0,0 +1,72 @@
+#
+# HCI daemon configuration file.
+#
+# $Id: hcid.conf,v 1.4 2004/04/29 20:14:21 holtmann Exp $
+#
+
+# HCId options
+options {
+ # Automatically initialize new devices
+ autoinit yes;
+
+ # Security Manager mode
+ # none - Security manager disabled
+ # auto - Use local PIN for incoming connections
+ # user - Always ask user for a PIN
+ #
+ security auto;
+
+ # Pairing mode
+ # none - Pairing disabled
+ # multi - Allow pairing with already paired devices
+ # once - Pair once and deny successive attempts
+ pairing multi;
+
+ # PIN helper
+ pin_helper /bin/bluepin;
+
+ # D-Bus PIN helper
+ # dbus_pin_helper;
+}
+
+# Default settings for HCI devices
+device {
+ # Local device name
+ # %d - device id
+ # %h - host name
+ name "%h";
+
+ # Local device class
+ class 0x120112;
+
+ # Default packet type
+ #pkt_type DH1,DM1,HV1;
+
+ # Inquiry and Page scan
+ iscan enable; pscan enable;
+
+ # Default link mode
+ # none - no specific policy
+ # accept - always accept incoming connections
+ # master - become master on incoming connections,
+ # deny role switch on outgoing connections
+ #
+ #lm accept,master;
+ #
+ lm accept;
+
+ # Default link policy
+ # none - no specific policy
+ # rswitch - allow role switch
+ # hold - allow hold mode
+ # sniff - allow sniff mode
+ # park - allow park mode
+ #
+ #lp hold,sniff;
+ #
+ lp rswitch,hold,sniff,park;
+
+ # Authentication and Encryption
+ #auth enable;
+ encrypt enable;
+}
diff --git a/packages/bluez/files/openmn/.mtn2git_empty b/packages/bluez/files/openmn/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/files/openmn/.mtn2git_empty
diff --git a/packages/bluez/files/openmn/bluetooth.default b/packages/bluez/files/openmn/bluetooth.default
new file mode 100644
index 0000000000..06c52d7960
--- /dev/null
+++ b/packages/bluez/files/openmn/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=false
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=false
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=false
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=false
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=false
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=false
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"
diff --git a/packages/bluez/files/openmn/hcid.conf b/packages/bluez/files/openmn/hcid.conf
new file mode 100644
index 0000000000..46a5d5fd54
--- /dev/null
+++ b/packages/bluez/files/openmn/hcid.conf
@@ -0,0 +1,70 @@
+#
+# HCI daemon configuration file.
+#
+# $Id: hcid.conf,v 1.4 2004/04/29 20:14:21 holtmann Exp $
+#
+
+# HCId options
+options {
+ # Automatically initialize new devices
+ autoinit yes;
+
+ # Security Manager mode
+ # none - Security manager disabled
+ # auto - Use local PIN for incoming connections
+ # user - Always ask user for a PIN
+ #
+ security auto;
+
+ # Pairing mode
+ # none - Pairing disabled
+ # multi - Allow pairing with already paired devices
+ # once - Pair once and deny successive attempts
+ pairing multi;
+
+ # PIN helper
+ # pin_helper /bin/bluepin;
+
+ # D-Bus PIN helper
+ # dbus_pin_helper;
+}
+
+# Default settings for HCI devices
+device {
+ # Local device name
+ # %d - device id
+ # %h - host name
+ name "%h";
+
+ # Local device class
+ class 0x820100;
+
+ # Default packet type
+ #pkt_type DH1,DM1,HV1;
+
+ # Inquiry and Page scan
+ iscan enable; pscan enable;
+
+ # Default link mode
+ # none - no specific policy
+ # accept - always accept incoming connections
+ # master - become master on incoming connections,
+ # deny role switch on outgoing connections
+ #
+ lm accept,master;
+
+ # Default link policy
+ # none - no specific policy
+ # rswitch - allow role switch
+ # hold - allow hold mode
+ # sniff - allow sniff mode
+ # park - allow park mode
+ #
+ #lp hold,sniff;
+ #
+ lp rswitch,hold,sniff,park;
+
+ # Authentication and Encryption
+ auth enable;
+ encrypt enable;
+}
diff --git a/packages/bluez/files/openslug/.mtn2git_empty b/packages/bluez/files/openslug/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/files/openslug/.mtn2git_empty
diff --git a/packages/bluez/files/openslug/bluetooth.default b/packages/bluez/files/openslug/bluetooth.default
new file mode 100644
index 0000000000..10f628e314
--- /dev/null
+++ b/packages/bluez/files/openslug/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=true
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=false
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=false
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=true
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=true
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"
diff --git a/packages/bluez/files/openslug/hcid.conf b/packages/bluez/files/openslug/hcid.conf
new file mode 100644
index 0000000000..46a5d5fd54
--- /dev/null
+++ b/packages/bluez/files/openslug/hcid.conf
@@ -0,0 +1,70 @@
+#
+# HCI daemon configuration file.
+#
+# $Id: hcid.conf,v 1.4 2004/04/29 20:14:21 holtmann Exp $
+#
+
+# HCId options
+options {
+ # Automatically initialize new devices
+ autoinit yes;
+
+ # Security Manager mode
+ # none - Security manager disabled
+ # auto - Use local PIN for incoming connections
+ # user - Always ask user for a PIN
+ #
+ security auto;
+
+ # Pairing mode
+ # none - Pairing disabled
+ # multi - Allow pairing with already paired devices
+ # once - Pair once and deny successive attempts
+ pairing multi;
+
+ # PIN helper
+ # pin_helper /bin/bluepin;
+
+ # D-Bus PIN helper
+ # dbus_pin_helper;
+}
+
+# Default settings for HCI devices
+device {
+ # Local device name
+ # %d - device id
+ # %h - host name
+ name "%h";
+
+ # Local device class
+ class 0x820100;
+
+ # Default packet type
+ #pkt_type DH1,DM1,HV1;
+
+ # Inquiry and Page scan
+ iscan enable; pscan enable;
+
+ # Default link mode
+ # none - no specific policy
+ # accept - always accept incoming connections
+ # master - become master on incoming connections,
+ # deny role switch on outgoing connections
+ #
+ lm accept,master;
+
+ # Default link policy
+ # none - no specific policy
+ # rswitch - allow role switch
+ # hold - allow hold mode
+ # sniff - allow sniff mode
+ # park - allow park mode
+ #
+ #lp hold,sniff;
+ #
+ lp rswitch,hold,sniff,park;
+
+ # Authentication and Encryption
+ auth enable;
+ encrypt enable;
+}