aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bogofilter
diff options
context:
space:
mode:
authorccsmart <ccsmart@smartpal.de>2005-09-04 20:01:40 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-04 20:01:40 +0000
commit7074944830793879b4686948003162da637ac380 (patch)
tree58a4791fe314d4b1b1047fb2c4eaa8396f8b45cd /packages/bogofilter
parent9d72695f9235bb6873e4d7f1d4dc2187a8e6c804 (diff)
downloadopenembedded-7074944830793879b4686948003162da637ac380.tar.gz
bogofilter: Initial version checkin.
Diffstat (limited to 'packages/bogofilter')
-rw-r--r--packages/bogofilter/.mtn2git_empty0
-rw-r--r--packages/bogofilter/bogofilter-0.96.0/.mtn2git_empty0
-rw-r--r--packages/bogofilter/bogofilter-0.96.0/configure.ac.patch34
-rw-r--r--packages/bogofilter/bogofilter_0.96.0.bb17
4 files changed, 51 insertions, 0 deletions
diff --git a/packages/bogofilter/.mtn2git_empty b/packages/bogofilter/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bogofilter/.mtn2git_empty
diff --git a/packages/bogofilter/bogofilter-0.96.0/.mtn2git_empty b/packages/bogofilter/bogofilter-0.96.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bogofilter/bogofilter-0.96.0/.mtn2git_empty
diff --git a/packages/bogofilter/bogofilter-0.96.0/configure.ac.patch b/packages/bogofilter/bogofilter-0.96.0/configure.ac.patch
new file mode 100644
index 0000000000..310eaaa16d
--- /dev/null
+++ b/packages/bogofilter/bogofilter-0.96.0/configure.ac.patch
@@ -0,0 +1,34 @@
+--- bogofilter-0.96.0/configure.ac.orig 2005-09-04 20:42:35.000000000 +0200
++++ bogofilter-0.96.0/configure.ac 2005-09-04 20:45:12.000000000 +0200
+@@ -460,6 +460,7 @@
+ dnl check if run-time link works
+ saveLIBS="$LIBS"
+ LIBS="$LIBS $LIBDB"
++ if test x$cross_compiling = xNO ; then
+ AC_MSG_CHECKING(if a program can be linked against Berkeley DB and run)
+ AC_RUN_IFELSE(
+ AC_LANG_PROGRAM([[
+@@ -500,6 +501,7 @@
+ [AC_MSG_RESULT(no)
+ AC_MSG_ERROR(db.h header file and db library version do not match.)],)
+ AC_MSG_RESULT(yes)
++ fi
+ AC_CHECK_DECLS(db_create,,
+ AC_MSG_ERROR([[Can not locate a suitable Berkeley DB db.h header file.
+ Use --with-libdb-prefix=PATH to specify the path to a v3+ install directory.
+@@ -509,6 +511,7 @@
+ #endif
+ #include <db.h>]]
+ )
++ if test x$cross_compiling = xNO ; then
+ AC_MSG_CHECKING(if Berkeley DB supports shared environments)
+ if test "x$enable_dbshared_test" != xno && test "x$USE_TRANSACTIONS" != xNO ; then
+ AC_RUN_IFELSE(
+@@ -548,6 +551,7 @@
+ else
+ AC_MSG_RESULT(skipped)
+ fi
++ fi
+
+ AC_DEFINE(ENABLE_DB_DATASTORE,1, [Enable Berkeley DB datastore])
+ LIBS="$saveLIBS"
diff --git a/packages/bogofilter/bogofilter_0.96.0.bb b/packages/bogofilter/bogofilter_0.96.0.bb
new file mode 100644
index 0000000000..e552f1b8bd
--- /dev/null
+++ b/packages/bogofilter/bogofilter_0.96.0.bb
@@ -0,0 +1,17 @@
+SECTION = "console/network"
+DEPENDS = "db3"
+DESCRIPTION = "Bogofilter is a mail filter that classifies mail as spam or ham (non-spam) \
+by a statistical analysis of the message's header and content (body). \
+The program is able to learn from the user's classifications and corrections."
+LICENSE = "GPL"
+PR = "r1"
+PRIORITY = "optional"
+
+SRC_URI = "http://download.sourceforge.net/bogofilter/bogofilter-${PV}.tar.bz2 \
+ file://${FILESDIR}/configure.ac.patch;patch=1 \
+ "
+
+inherit autotools
+
+EXTRA_OECONF = "--with-libdb-prefix=${libdir}"
+