aboutsummaryrefslogtreecommitdiffstats
path: root/packages/boost
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2008-07-01 13:28:43 +0000
committerPhilip Balister <philip@balister.org>2008-07-01 13:28:43 +0000
commit262f26f0843401bf5a9ab20c370ac7f8e74e12fc (patch)
treee45abb11f2ede1fb4d40cc67ef1703a8ce8609b9 /packages/boost
parent92a3b502575e078cb62bb12153f3be30900db601 (diff)
downloadopenembedded-262f26f0843401bf5a9ab20c370ac7f8e74e12fc.tar.gz
boost-jam-native : Add support for boost-jam-native-3.1.16. Add a
boost-jam-native.inc file. New version is DEFAULT_PREFERENCE = "-1" for now.
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost-jam-native.inc30
-rw-r--r--packages/boost/boost-jam-native_3.1.11.bb28
-rw-r--r--packages/boost/boost-jam-native_3.1.16.bb6
3 files changed, 37 insertions, 27 deletions
diff --git a/packages/boost/boost-jam-native.inc b/packages/boost/boost-jam-native.inc
new file mode 100644
index 0000000000..843f912f46
--- /dev/null
+++ b/packages/boost/boost-jam-native.inc
@@ -0,0 +1,30 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
+
+inherit native
+
+do_compile() {
+ set -ex
+ rm -rf bin.*
+ ./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+ set -ex
+ install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
+}
diff --git a/packages/boost/boost-jam-native_3.1.11.bb b/packages/boost/boost-jam-native_3.1.11.bb
index 843f912f46..2e92146a83 100644
--- a/packages/boost/boost-jam-native_3.1.11.bb
+++ b/packages/boost/boost-jam-native_3.1.11.bb
@@ -1,30 +1,4 @@
-# The Boost web site provides free peer-reviewed portable
-# C++ source libraries. The emphasis is on libraries which
-# work well with the C++ Standard Library. The libraries are
-# intended to be widely useful, and are in regular use by
-# thousands of programmers across a broad spectrum of applications.
-DESCRIPTION = "Make system for boost (native)"
-HOMEPAGE = "http://www.boost.org/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "Boost Software License"
-PR = "r0"
+include boost-jam-native.inc
SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
-S = "${WORKDIR}/boost-jam-${PV}"
-inherit native
-
-do_compile() {
- set -ex
- rm -rf bin.*
- ./build.sh gcc
-}
-
-# This is too terrible - the build script doesn't give any good
-# way I can see to find out where the binaries are placed, so
-# rely on only one bin.foo directory being created.
-do_stage() {
- set -ex
- install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
-}
diff --git a/packages/boost/boost-jam-native_3.1.16.bb b/packages/boost/boost-jam-native_3.1.16.bb
new file mode 100644
index 0000000000..955f7bfac8
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.16.bb
@@ -0,0 +1,6 @@
+include boost-jam-native.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+