aboutsummaryrefslogtreecommitdiffstats
path: root/packages/boost
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-03-29 14:34:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-29 14:34:12 +0000
commit2b0add3a1a9cf83dd00b8bde2db75bc9c17d7ca9 (patch)
tree1eea5c4d9035ad90fd4824d0e8b0e321db0e10be /packages/boost
parentc157ad6287aa649414f24cbf3170c9e9ed7b41a6 (diff)
downloadopenembedded-2b0add3a1a9cf83dd00b8bde2db75bc9c17d7ca9.tar.gz
boost 1.33.0: make it compile w/ linux-gnueabi
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost_1.33.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/boost/boost_1.33.0.bb b/packages/boost/boost_1.33.0.bb
index 2c81f37899..db30f95a69 100644
--- a/packages/boost/boost_1.33.0.bb
+++ b/packages/boost/boost_1.33.0.bb
@@ -10,7 +10,7 @@ SECTION = "libs"
DEPENDS = "boost-jam-native zlib"
PRIORITY = "optional"
LICENSE = "Boost Software License"
-PR = "r0"
+PR = "r1"
# need debian package naming for the libs
inherit debian
@@ -128,6 +128,10 @@ BJAM_OPTS = '${BJAM_TOOLS} \
${BJAM_EXTRA}'
+do_configure_prepend() {
+ cp -f boost/config/platform/linux.hpp boost/config/platform/linux-gnueabi.hpp
+}
+
do_compile() {
set -ex
bjam ${BJAM_OPTS} --prefix=${prefix} \