aboutsummaryrefslogtreecommitdiffstats
path: root/packages/boost
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-16 21:49:13 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-16 21:49:13 +0000
commitb596f9f477d78eb31712117f1f8bbf1030199eac (patch)
treedbabbb317a6465a6427a061b563398f2165c5f04 /packages/boost
parentdeff9c70d95f3153404ebf5bd9d5c3d22e3bcdbd (diff)
downloadopenembedded-b596f9f477d78eb31712117f1f8bbf1030199eac.tar.gz
boost-jam-native:
- upgrade to 3.1.10 - minor description reformatting - use ${STAGING_BINDIR} in do_stage()
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost-jam-native_3.1.10.bb (renamed from packages/boost/boost-jam-native_3.1.9.bb)16
1 files changed, 8 insertions, 8 deletions
diff --git a/packages/boost/boost-jam-native_3.1.9.bb b/packages/boost/boost-jam-native_3.1.10.bb
index e13d160a37..3a844b191e 100644
--- a/packages/boost/boost-jam-native_3.1.9.bb
+++ b/packages/boost/boost-jam-native_3.1.10.bb
@@ -9,13 +9,13 @@ MAINTAINER = "John Bowler <jbowler@acm.org>"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "Boost Software License"
+PR = "r0"
-SRC_URI = "http://download.sourceforge.net/boost/boost-jam-${PV}.tgz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
inherit native
-S = "${WORKDIR}/boost-jam-${PV}"
-
do_compile() {
set -ex
rm -rf bin.*
@@ -27,9 +27,9 @@ do_compile() {
# rely on only one bin.foo directory being created.
do_stage() {
set -ex
- install -c -m 755 bin.*/jam ${bindir}
- install -c -m 755 bin.*/mkjambase ${bindir}
- install -c -m 755 bin.*/yyacc ${bindir}
- rm -f ${bindir}/bjam
- ln ${bindir}/jam ${bindir}/bjam
+ install -c -m 755 bin.*/jam ${STAGING_BINDIR}/
+ install -c -m 755 bin.*/mkjambase ${STAGING_BINDIR}/
+ install -c -m 755 bin.*/yyacc ${STAGING_BINDIR}/
+ rm -f ${STAGING_BINDIR}/bjam
+ ln -sf ./jam ${STAGING_BINDIR}/bjam
}