aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bootchart
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2006-08-04 08:37:05 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-04 08:37:05 +0000
commita6f0e34d4d90d6d40920ee7b00fa9dd734e8f011 (patch)
treeb00952c8541b467fdfeef5822ebd954ac19b2f63 /packages/bootchart
parent6de5064faea13f0cb4b8bfeaa4352740aeba4bea (diff)
downloadopenembedded-a6f0e34d4d90d6d40920ee7b00fa9dd734e8f011.tar.gz
bootchart: This is revamp of the bb, pulling official tarball, and patching it with
setting which make it more seamless and easier to use with OE-based distribution.
Diffstat (limited to 'packages/bootchart')
-rw-r--r--packages/bootchart/bootchart_0.9.bb17
1 files changed, 8 insertions, 9 deletions
diff --git a/packages/bootchart/bootchart_0.9.bb b/packages/bootchart/bootchart_0.9.bb
index b9b4029590..abbdda4488 100644
--- a/packages/bootchart/bootchart_0.9.bb
+++ b/packages/bootchart/bootchart_0.9.bb
@@ -2,28 +2,27 @@ DESCRIPTION = "Bootchart is a tool for performance analysis and visualization of
LICENSE = "GPLv2"
HOMEPAGE = "http://www.bootchart.org/"
MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
-
+PR = "r1"
#this only installs the loggers, you will need to run the renderers on your workstation
#boot with 'init=/sbin/bootchartd' and do '/sbin/bootchartd stop' to end the logging
#needed for a real /bin/sh and /bin/sleep
-DEPENDS = "bash coreutils"
-RDEPENDS = "bash coreutils"
+DEPENDS = "bash coreutils acct"
+RDEPENDS = "bash coreutils acct"
#this is a plain shell script
PACKAGE_ARCH = "all"
-SRC_URI = "file://bootchart \
- file://bootchartd \
- file://bootchartd.conf"
+SRC_URI = "${SOURCEFORGE_MIRROR}/bootchart/bootchart-${PV}.tar.bz2\
+ file://handheld.patch;patch=1"
do_install() {
install -d ${D}/sbin
install -d ${D}/etc
- install -m 755 ${WORKDIR}/bootchart ${D}/sbin
- install -m 755 ${WORKDIR}/bootchartd ${D}/sbin
- install -m 644 ${WORKDIR}/bootchart ${D}/etc
+ install -d ${D}/bootchart
+ install -m 755 ${S}/script/bootchartd ${D}/sbin
+ install -m 644 ${S}/script/bootchartd.conf ${D}/etc
}