aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bootchart
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-04-27 11:55:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-27 11:55:26 +0000
commitce04f81f47b8c0296e0bd6f92502e748741f2088 (patch)
treef61d7b2d43295d9a1e97c8935b52278f678d834e /packages/bootchart
parentaecd7412b859e591f25c4a38d850bf8122a60947 (diff)
downloadopenembedded-ce04f81f47b8c0296e0bd6f92502e748741f2088.tar.gz
bootchart 0.9: add the device part of bootchart, a neat way to view the boot process of your favourite device.
read the recipe on how to use it
Diffstat (limited to 'packages/bootchart')
-rw-r--r--packages/bootchart/.mtn2git_empty0
-rw-r--r--packages/bootchart/bootchart_0.9.bb29
2 files changed, 29 insertions, 0 deletions
diff --git a/packages/bootchart/.mtn2git_empty b/packages/bootchart/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bootchart/.mtn2git_empty
diff --git a/packages/bootchart/bootchart_0.9.bb b/packages/bootchart/bootchart_0.9.bb
new file mode 100644
index 0000000000..b9b4029590
--- /dev/null
+++ b/packages/bootchart/bootchart_0.9.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Bootchart is a tool for performance analysis and visualization of the GNU/Linux boot process."
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.bootchart.org/"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
+
+
+#this only installs the loggers, you will need to run the renderers on your workstation
+#boot with 'init=/sbin/bootchartd' and do '/sbin/bootchartd stop' to end the logging
+
+#needed for a real /bin/sh and /bin/sleep
+DEPENDS = "bash coreutils"
+RDEPENDS = "bash coreutils"
+
+#this is a plain shell script
+PACKAGE_ARCH = "all"
+
+SRC_URI = "file://bootchart \
+ file://bootchartd \
+ file://bootchartd.conf"
+
+
+do_install() {
+ install -d ${D}/sbin
+ install -d ${D}/etc
+ install -m 755 ${WORKDIR}/bootchart ${D}/sbin
+ install -m 755 ${WORKDIR}/bootchartd ${D}/sbin
+ install -m 644 ${WORKDIR}/bootchart ${D}/etc
+}
+