aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bootsplash
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-04-27 21:46:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-27 21:46:20 +0000
commitadedc268790814906bb7e93b92e50d69f304a623 (patch)
tree4be25a78b924993a5fb15ae9a9f1d389c7e3d69a /packages/bootsplash
parent20674b19d0a0c49013f042a5ee367ccfde84ee67 (diff)
downloadopenembedded-adedc268790814906bb7e93b92e50d69f304a623.tar.gz
bootsplash: make it building - close #346
Diffstat (limited to 'packages/bootsplash')
-rw-r--r--packages/bootsplash/bootsplash-native_3.0.7.bb2
-rw-r--r--packages/bootsplash/bootsplash_3.0.7.bb12
-rw-r--r--packages/bootsplash/files/.mtn2git_empty0
-rw-r--r--packages/bootsplash/files/freetype2.patch15
4 files changed, 25 insertions, 4 deletions
diff --git a/packages/bootsplash/bootsplash-native_3.0.7.bb b/packages/bootsplash/bootsplash-native_3.0.7.bb
index ccc9377961..df368ce38c 100644
--- a/packages/bootsplash/bootsplash-native_3.0.7.bb
+++ b/packages/bootsplash/bootsplash-native_3.0.7.bb
@@ -8,7 +8,7 @@ inherit native
S="${WORKDIR}/bootsplash-${PV}"
do_compile() {
- oe_runmake -C Utilities splash
+ oe_runmake splash
}
do_stage() {
diff --git a/packages/bootsplash/bootsplash_3.0.7.bb b/packages/bootsplash/bootsplash_3.0.7.bb
index da2290e202..9ffa97d4d5 100644
--- a/packages/bootsplash/bootsplash_3.0.7.bb
+++ b/packages/bootsplash/bootsplash_3.0.7.bb
@@ -6,12 +6,18 @@ DESCRIPTION="Bootsplash shows pretty pictures during boot"
HOMEPAGE="http://www.bootsplash.org"
SECTION = "media-gfx"
LICENSE = "GPL"
-SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2"
+SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2 \
+ file://freetype2.patch;patch=1"
-DEPENDS="freetype"
+DEPENDS="freetype libmng"
+PR = "r1"
+
+EXTRA_OEMAKE += "-C Utilities \
+ CFLAGS='${CFLAGS} -I${STAGING_INCDIR}/freetype2/ -I${STAGING_INCDIR}' \
+ LDFLAGS='${LDFLAGS} -L${STAGING_LIBDIR} -ljpeg'"
do_compile() {
- oe_runmake -C Utilities
+ oe_runmake
}
do_install() {
diff --git a/packages/bootsplash/files/.mtn2git_empty b/packages/bootsplash/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bootsplash/files/.mtn2git_empty
diff --git a/packages/bootsplash/files/freetype2.patch b/packages/bootsplash/files/freetype2.patch
new file mode 100644
index 0000000000..3683c628f8
--- /dev/null
+++ b/packages/bootsplash/files/freetype2.patch
@@ -0,0 +1,15 @@
+Index: bootsplash-3.0.7/Utilities/ttf.c
+===================================================================
+--- bootsplash-3.0.7.orig/Utilities/ttf.c 2003-08-09 11:58:44.000000000 +0200
++++ bootsplash-3.0.7/Utilities/ttf.c 2006-04-04 11:26:54.210699456 +0200
+@@ -9,8 +9,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+-#include <freetype/freetype.h>
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+