aboutsummaryrefslogtreecommitdiffstats
path: root/packages/busybox
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-02-11 22:40:21 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-02-11 22:40:21 +0100
commit5a0e1d473ca7aca5ffefffe9a2ec44ae7a1f35bc (patch)
treebffb9fff9c4e5da35ecef9484de291733c2d3455 /packages/busybox
parent4e1b79d2d824ae7e0204251a09e852c24045c54a (diff)
downloadopenembedded-5a0e1d473ca7aca5ffefffe9a2ec44ae7a1f35bc.tar.gz
busybox: fix tar problem with filenames that are exactly 100 bytes
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/busybox-1.13.2/get_header_tar.patch11
-rw-r--r--packages/busybox/busybox_1.13.2.bb3
2 files changed, 13 insertions, 1 deletions
diff --git a/packages/busybox/busybox-1.13.2/get_header_tar.patch b/packages/busybox/busybox-1.13.2/get_header_tar.patch
new file mode 100644
index 0000000000..0121cd1b61
--- /dev/null
+++ b/packages/busybox/busybox-1.13.2/get_header_tar.patch
@@ -0,0 +1,11 @@
+--- busybox-1.13.2/archival/libunarchive/get_header_tar.c.orig 2008-11-09 18:28:02.000000000 +0100
++++ busybox-1.13.2/archival/libunarchive/get_header_tar.c 2009-02-11 22:34:52.000000000 +0100
+@@ -252,6 +252,8 @@
+ file_header->name = concat_path_file(tar.prefix, tar.name);
+ } else
+ file_header->name = xstrdup(tar.name);
++ if (strlen(file_header->name) > 100)
++ file_header->name[100] = 0;
+ }
+
+ /* Set bits 12-15 of the files mode */
diff --git a/packages/busybox/busybox_1.13.2.bb b/packages/busybox/busybox_1.13.2.bb
index bff6d27fa6..f00830badb 100644
--- a/packages/busybox/busybox_1.13.2.bb
+++ b/packages/busybox/busybox_1.13.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r12"
+PR = "r13"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
@@ -12,6 +12,7 @@ SRC_URI = "\
file://udhcpscript.patch;patch=1 \
file://udhcpc-fix-nfsroot.patch;patch=1 \
file://B921600.patch;patch=1 \
+ file://get_header_tar.patch;patch=1 \
file://find-touchscreen.sh \
file://busybox-cron \
file://busybox-httpd \