aboutsummaryrefslogtreecommitdiffstats
path: root/packages/busybox
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@koansoftware.com>2009-01-09 17:39:34 +0100
committerMarcin Juszkiewicz <hrw@koansoftware.com>2009-01-16 15:37:49 +0100
commit5e4817d253b47a758a4b8fba1fcf46a88e390b60 (patch)
treec8a0c03c8e69c3388934ae3e70e35dbfc14e1437 /packages/busybox
parent2dc2f17523a946c8039c58e1ae27b6bc14e2cbc2 (diff)
downloadopenembedded-5e4817d253b47a758a4b8fba1fcf46a88e390b60.tar.gz
busybox: create /dev/input/touchscreen0 with mdev
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/busybox_1.13.2.bb5
-rw-r--r--packages/busybox/files/find-touchscreen.sh7
-rw-r--r--packages/busybox/files/mdev.conf60
3 files changed, 42 insertions, 30 deletions
diff --git a/packages/busybox/busybox_1.13.2.bb b/packages/busybox/busybox_1.13.2.bb
index 740eee2255..2172967bec 100644
--- a/packages/busybox/busybox_1.13.2.bb
+++ b/packages/busybox/busybox_1.13.2.bb
@@ -1,11 +1,14 @@
require busybox.inc
+PR = "r1"
+
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
\
file://udhcpscript.patch;patch=1 \
file://B921600.patch;patch=1 \
file://mdev-fix.patch;patch=1 \
+ file://find-touchscreen.sh \
file://busybox-cron \
file://busybox-httpd \
file://busybox-udhcpd \
@@ -30,6 +33,8 @@ do_configure () {
do_install_append() {
install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/mdev
+ install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
}
diff --git a/packages/busybox/files/find-touchscreen.sh b/packages/busybox/files/find-touchscreen.sh
new file mode 100644
index 0000000000..34835e7f1c
--- /dev/null
+++ b/packages/busybox/files/find-touchscreen.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+
+
+if [ `egrep "input:.*-e0.*,3,.*a0,1,.*18,.*" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
+ ln -sf /dev/input/$MDEV /dev/input/touchscreen0
+fi
diff --git a/packages/busybox/files/mdev.conf b/packages/busybox/files/mdev.conf
index 196194941f..c66e7bda95 100644
--- a/packages/busybox/files/mdev.conf
+++ b/packages/busybox/files/mdev.conf
@@ -1,32 +1,32 @@
-console 0:0 0600
-cpu_dma_latency 0:0 0660
-fb0:0 44 0660
-full 0:0 0666
-initctl 0:0 0600
-ircomm[0-9].* 0:20 0660
-kmem 0:15 0640
-kmsg 0:0 0660
-log 0:0 0666
-loop[0-9].* 0:6 0640
-mem 0:15 0640
-network_latency 0:0 0660
-network_throughput 0:0 0660
-null 0:0 0666
-port 0:15 0640
-ptmx 0:5 0666
-ram[0-9].* 0:6 0640
-random 0:0 0666
-sda 0:6 0640
-tty 0:5 0666
-tty.* 0:0 0620
-urandom 0:0 0666
-usbdev.* 0:0 0660
-vcs.* 0:5 0660
-zero 0:0 0666
+console 0:0 0600
+cpu_dma_latency 0:0 0660
+fb0:0 44 0660
+full 0:0 0666
+initctl 0:0 0600
+ircomm[0-9].* 0:20 0660
+kmem 0:15 0640
+kmsg 0:0 0660
+log 0:0 0666
+loop[0-9].* 0:6 0640
+mem 0:15 0640
+network_latency 0:0 0660
+network_throughput 0:0 0660
+null 0:0 0666
+port 0:15 0640
+ptmx 0:5 0666
+ram[0-9].* 0:6 0640
+random 0:0 0666
+sda 0:6 0640
+tty 0:5 0666
+tty.* 0:0 0620
+urandom 0:0 0666
+usbdev.* 0:0 0660
+vcs.* 0:5 0660
+zero 0:0 0666
+
+pcm.* 0:0 0660 =snd/
+control.* 0:0 0660 =snd/
-pcm.* 0:0 0660 =snd/
-control.* 0:0 0660 =snd/
-
-event.* 0:0 0660 =input/
-mice 0:0 0660 =input/
+event.* 0:0 0660 =input/ @/etc/mdev/find-touchscreen.sh
+mice 0:0 0660 =input/
mouse.* 0:0 0660 =input/