aboutsummaryrefslogtreecommitdiffstats
path: root/packages/busybox
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2007-06-07 03:09:51 +0000
committerMike Westerhof <mwester@dls.net>2007-06-07 03:09:51 +0000
commit78c7219f57fbcfdd631c486d59fa96e8de4e6cab (patch)
tree0bf9ad2ee86edc379edaaddc45ab6ff9c202d483 /packages/busybox
parent91917695c41bdbac35f2416ade9be11efedd55b9 (diff)
downloadopenembedded-78c7219f57fbcfdd631c486d59fa96e8de4e6cab.tar.gz
Unslung: slingbox - fix read_hex routine causing busybox fdisk failures
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/slingbox-1.3.1/fdisk-readhex.patch20
-rw-r--r--packages/busybox/slingbox_1.3.1.bb7
2 files changed, 23 insertions, 4 deletions
diff --git a/packages/busybox/slingbox-1.3.1/fdisk-readhex.patch b/packages/busybox/slingbox-1.3.1/fdisk-readhex.patch
new file mode 100644
index 0000000000..d8e32c40e7
--- /dev/null
+++ b/packages/busybox/slingbox-1.3.1/fdisk-readhex.patch
@@ -0,0 +1,20 @@
+--- busybox-1.3.1/util-linux/fdisk.c.orig 2007-06-06 21:18:45.000000000 -0500
++++ busybox-1.3.1/util-linux/fdisk.c 2007-06-06 21:17:20.000000000 -0500
+@@ -331,13 +331,16 @@
+ read_hex(const struct systypes *sys)
+ {
+ unsigned long v;
++ char *e;
+ while (1) {
+ read_nonempty(_("Hex code (type L to list codes): "));
+ if (*line_ptr == 'l' || *line_ptr == 'L') {
+ list_types(sys);
+ continue;
+ }
+- v = bb_strtoul(line_ptr, NULL, 16);
++ v = bb_strtoul(line_ptr, &e, 16);
++ /* Clear out EINVAL code if it's because of the trailing \n */
++ if ((errno == EINVAL) && (*e == '\n')) errno = 0;
+ if (errno || v > 0xff) continue;
+ return v;
+ }
diff --git a/packages/busybox/slingbox_1.3.1.bb b/packages/busybox/slingbox_1.3.1.bb
index 89b189e325..62d150a9fe 100644
--- a/packages/busybox/slingbox_1.3.1.bb
+++ b/packages/busybox/slingbox_1.3.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r0"
+PR = "r1"
COMPATIBLE_MACHINE = "nslu2"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
@@ -12,12 +12,11 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://shadow_h_is_required.patch;patch=1 \
file://df_rootfs.patch;patch=1 \
file://lazy_umount.patch;patch=1 \
- file://halt.patch;patch=1" \
+ file://halt.patch;patch=1 \
+ file://fdisk-readhex.patch;patch=1 \
file://slingbox_name.patch;patch=1 \
file://slingbox.patch;patch=1"
-# file://wget-long-options.patch;patch=1 \
-
S = "${WORKDIR}/busybox-${PV}"
export EXTRA_CFLAGS = "${CFLAGS}"