aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bzip2
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-07-23 13:36:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-23 13:36:38 +0000
commit5e01906b8433bc6a8c03be2e31758589641124c9 (patch)
treec400790ffa5ebb896c464da84752a4937d889400 /packages/bzip2
parent57808a977840bce11bdbab373d9eacaba7ef88c1 (diff)
downloadopenembedded-5e01906b8433bc6a8c03be2e31758589641124c9.tar.gz
Updated to use update-alternatives and fix some FHS bugs
Diffstat (limited to 'packages/bzip2')
-rw-r--r--packages/bzip2/bzip2_1.0.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/bzip2/bzip2_1.0.2.bb b/packages/bzip2/bzip2_1.0.2.bb
index 0233f0f235..1e1cb8e539 100644
--- a/packages/bzip2/bzip2_1.0.2.bb
+++ b/packages/bzip2/bzip2_1.0.2.bb
@@ -1,5 +1,6 @@
DESCRIPTION = "Very high-quality data compression program."
SECTION = "console/utils"
+PR = "r1"
LICENSE = "bzip2"
SRC_URI = "ftp://sources.redhat.com/pub/bzip2/v102/bzip2-${PV}.tar.gz \
@@ -23,4 +24,18 @@ do_stage () {
do_install () {
oe_runmake 'DESTDIR=${D}' install
oe_libinstall -a -so libbz2 ${D}${libdir}
+ mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
+ mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
+ update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
+}
+
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove bunzip2 bunzip2.${PN}
+ update-alternatives --remove bzcat bzcat.${PN}
}