aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cacao/cacaoh-cldc-native_0.98.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-08 22:57:50 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-08 22:57:50 +0000
commit614090f5ecd4f17a53dfad97f4dfa1f335ed2256 (patch)
treef33315ab93719416f4328adba65f2272654d42e3 /packages/cacao/cacaoh-cldc-native_0.98.bb
parentd9e16f02594b391b5e04f960b38e19d48f564d08 (diff)
downloadopenembedded-614090f5ecd4f17a53dfad97f4dfa1f335ed2256.tar.gz
cacao: first support of cacao in oe
* for now we only support cacao-cldc * with cacao-cldc and midapth wie have midp support in oe * opera-mini and serval other midlets should work now * installing the packages is not enough * you have to write shellscripts which looks like http://midpath.svn.sourceforge.net/viewvc/midpath/trunk/bin/midpath-test-cacao-cldc.sh?view=markup * arm is the only support platform for now, others will breakout at not finding genoffset.h, which can only generate at the target device with the binary genoffset, upstream is working on diffrent solution, feel free to submit genoffset.h for your architecture or machine
Diffstat (limited to 'packages/cacao/cacaoh-cldc-native_0.98.bb')
-rw-r--r--packages/cacao/cacaoh-cldc-native_0.98.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/cacao/cacaoh-cldc-native_0.98.bb b/packages/cacao/cacaoh-cldc-native_0.98.bb
new file mode 100644
index 0000000000..e24225a042
--- /dev/null
+++ b/packages/cacao/cacaoh-cldc-native_0.98.bb
@@ -0,0 +1,16 @@
+
+require cacao.inc
+
+DEPENDS = "ecj-native classpath-minimal-native virtual/cldc-api-1.1 libtool-native zlib-native"
+
+inherit native
+
+EXTRA_OECONF += "--with-classpath-includedir=${STAGING_INCDIR}/classpath-minimal \
+ --enable-jni \
+ --enable-java=cldc1.1 \
+ --with-classpath=cldc1.1 \
+ --with-classpath-classes=${STAGING_LIBDIR}/java/cldc1.1.jar \
+ "
+do_stage() {
+ install -m 0755 src/cacaoh/.libs/cacaoh ${STAGING_BINDIR}/
+}