aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cacao
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-06-27 13:00:39 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-06-27 13:00:39 +0000
commit5e7a95307b8c10f67b2103557f128014853eb805 (patch)
tree04bca4ed9bc67c7ceebb26c0ccdef3d030734ef5 /packages/cacao
parentcfba5ecca6f961324fbffafbb32ef7b718e859b1 (diff)
downloadopenembedded-5e7a95307b8c10f67b2103557f128014853eb805.tar.gz
cacao-native 0.99.1: New recipe.
Diffstat (limited to 'packages/cacao')
-rw-r--r--packages/cacao/cacao-native_0.99.1.bb14
-rw-r--r--packages/cacao/cacao_0.99.1.bb10
-rw-r--r--packages/cacao/files/cacao-0.98+hg20080519-build-java-runtime-library-classes.patch46
3 files changed, 35 insertions, 35 deletions
diff --git a/packages/cacao/cacao-native_0.99.1.bb b/packages/cacao/cacao-native_0.99.1.bb
new file mode 100644
index 0000000000..a503c7d3d4
--- /dev/null
+++ b/packages/cacao/cacao-native_0.99.1.bb
@@ -0,0 +1,14 @@
+require cacao.inc
+
+PR = "r0"
+
+SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2;md5sum=a5641452c7ba173060c99ed700950b3d \
+ file://cacao-${PV}-build-java-runtime-library-classes.patch;patch=1 \
+ "
+
+# Quirks for Nokia N800:
+# - with mfloat-abi=softfp the runtime fails to run anything
+# - without --enable-softfloat it cannot find files within Jars
+TARGET_CC_ARCH_nokia800 = "-march=armv6j -mtune=arm1136jf-s -mfpu=vfp -mfloat-abi=soft"
+
+EXTRA_OECONF_append_nokia800 = "--enable-softfloat"
diff --git a/packages/cacao/cacao_0.99.1.bb b/packages/cacao/cacao_0.99.1.bb
index a503c7d3d4..217e948831 100644
--- a/packages/cacao/cacao_0.99.1.bb
+++ b/packages/cacao/cacao_0.99.1.bb
@@ -1,14 +1,6 @@
-require cacao.inc
+require cacao-native.inc
PR = "r0"
SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2;md5sum=a5641452c7ba173060c99ed700950b3d \
- file://cacao-${PV}-build-java-runtime-library-classes.patch;patch=1 \
"
-
-# Quirks for Nokia N800:
-# - with mfloat-abi=softfp the runtime fails to run anything
-# - without --enable-softfloat it cannot find files within Jars
-TARGET_CC_ARCH_nokia800 = "-march=armv6j -mtune=arm1136jf-s -mfpu=vfp -mfloat-abi=soft"
-
-EXTRA_OECONF_append_nokia800 = "--enable-softfloat"
diff --git a/packages/cacao/files/cacao-0.98+hg20080519-build-java-runtime-library-classes.patch b/packages/cacao/files/cacao-0.98+hg20080519-build-java-runtime-library-classes.patch
index 7df1c480ea..7c649c495c 100644
--- a/packages/cacao/files/cacao-0.98+hg20080519-build-java-runtime-library-classes.patch
+++ b/packages/cacao/files/cacao-0.98+hg20080519-build-java-runtime-library-classes.patch
@@ -1,36 +1,26 @@
-Index: cacao/configure.ac
-===================================================================
---- cacao.orig/configure.ac 2008-06-27 01:23:44.000000000 +0200
-+++ cacao/configure.ac 2008-06-27 01:24:02.000000000 +0200
-@@ -772,6 +772,7 @@
-
- AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_PREFIX
- AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_CLASSES
-+AC_CHECK_WITH_BUILD_JAVA_RUNTIME_LIBRARY_CLASSES
-
- if test x"${ENABLE_JRE_LAYOUT}" = "xno"; then
- AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_LIBDIR
Index: cacao/m4/java-runtime-library.m4
===================================================================
---- cacao.orig/m4/java-runtime-library.m4 2008-06-27 01:23:44.000000000 +0200
-+++ cacao/m4/java-runtime-library.m4 2008-06-27 01:24:02.000000000 +0200
-@@ -93,20 +93,32 @@
+--- cacao.orig/m4/java-runtime-library.m4 2008-06-27 13:51:34.000000000 +0200
++++ cacao/m4/java-runtime-library.m4 2008-06-27 13:53:31.000000000 +0200
+@@ -92,14 +92,28 @@
+ AC_MSG_RESULT(${JAVA_RUNTIME_LIBRARY_CLASSES})
AC_DEFINE_UNQUOTED([JAVA_RUNTIME_LIBRARY_CLASSES], "${JAVA_RUNTIME_LIBRARY_CLASSES}", [Java runtime library classes])
AC_SUBST(JAVA_RUNTIME_LIBRARY_CLASSES)
-
++])
++
++
+dnl where are Java core library classes located at compilation time
+
+AC_DEFUN([AC_CHECK_WITH_BUILD_JAVA_RUNTIME_LIBRARY_CLASSES],[
+AC_MSG_CHECKING(where Java core library classes are located at compile time)
+AC_ARG_WITH([build-java-runtime-library-classes],
-+ [AS_HELP_STRING(--with-build-java-runtime-library-classes=<path>,path to Java core library classes (includes the name of the file and may be flat) [[default=${JAVA_RUNTIME_LIBRARY_PREFIX}/share/classpath/glibj.zip]])],
++ [AS_HELP_STRING(--with-build-java-runtime-library-classes=<path>,path to Java core library classes (includes the name of the file and may be flat) [[default=${JAVA_RUNTIME_LIBRARY_CLASSES}]])],
+ [BUILD_JAVA_RUNTIME_LIBRARY_CLASSES=${withval}],
-+ [BUILD_JAVA_RUNTIME_LIBRARY_CLASSES=${JAVA_RUNTIME_LIBRARY_PREFIX}/share/classpath/glibj.zip])
++ [BUILD_JAVA_RUNTIME_LIBRARY_CLASSES=${JAVA_RUNTIME_LIBRARY_CLASSES}])
+AC_MSG_RESULT(${BUILD_JAVA_RUNTIME_LIBRARY_CLASSES})
+AC_DEFINE_UNQUOTED([BUILD_JAVA_RUNTIME_LIBRARY_CLASSES], "${BUILD_JAVA_RUNTIME_LIBRARY_CLASSES}", [Java core library classes at compile time])
+AC_SUBST(BUILD_JAVA_RUNTIME_LIBRARY_CLASSES)
-+])
-+
+
dnl define BOOTCLASSPATH for Makefiles
case "${WITH_JAVA_RUNTIME_LIBRARY}" in
cldc1.1 | gnuclasspath)
@@ -43,11 +33,15 @@ Index: cacao/m4/java-runtime-library.m4
;;
esac
AC_SUBST(BOOTCLASSPATH)
- ])
+Index: cacao/configure.ac
+===================================================================
+--- cacao.orig/configure.ac 2008-06-27 13:51:34.000000000 +0200
++++ cacao/configure.ac 2008-06-27 13:53:31.000000000 +0200
+@@ -772,6 +772,7 @@
--
--dnl where are Java runtime library native libraries installed
-+dnl where are Java runtime library native libraries installed (at compilation time)
+ AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_PREFIX
+ AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_CLASSES
++AC_CHECK_WITH_BUILD_JAVA_RUNTIME_LIBRARY_CLASSES
- AC_DEFUN([AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_LIBDIR],[
- AC_MSG_CHECKING(where Java runtime library native libraries are installed)
+ if test x"${ENABLE_JRE_LAYOUT}" = "xno"; then
+ AC_CHECK_WITH_JAVA_RUNTIME_LIBRARY_LIBDIR