aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cdtool
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 15:55:25 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 15:55:25 +0000
commit72aa008f66d59df7243b9dc6a3ef71d0bb31cbd3 (patch)
tree0f00745a72139c15c80bc5c13f5c5dbaf645cba1 /packages/cdtool
parenta50d53ca381f6166c5a2e517430822071992171c (diff)
downloadopenembedded-72aa008f66d59df7243b9dc6a3ef71d0bb31cbd3.tar.gz
cdtool: Rename to packages/cdtool.
Diffstat (limited to 'packages/cdtool')
-rw-r--r--packages/cdtool/.mtn2git_empty0
-rw-r--r--packages/cdtool/cdtool_2.1.8pre4.bb14
-rw-r--r--packages/cdtool/files/.mtn2git_empty0
-rw-r--r--packages/cdtool/files/install-no-owner.patch33
4 files changed, 47 insertions, 0 deletions
diff --git a/packages/cdtool/.mtn2git_empty b/packages/cdtool/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cdtool/.mtn2git_empty
diff --git a/packages/cdtool/cdtool_2.1.8pre4.bb b/packages/cdtool/cdtool_2.1.8pre4.bb
new file mode 100644
index 0000000000..8f2b425f49
--- /dev/null
+++ b/packages/cdtool/cdtool_2.1.8pre4.bb
@@ -0,0 +1,14 @@
+# cdtool .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://hinterhof.net/cdtool/"
+DESCRIPTION="cdtool is a free software package to control the audio functions \
+of an attached CDROM drive from the command line in a quick and scriptable way."
+MAINTAINER = "Raymond Danks <info-linux@geode.amd.com>"
+LICENSE = "GPL"
+
+SRC_URI="http://hinterhof.net/${PN}/dist/${PN}-${PV}.tar.gz \
+ file://install-no-owner.patch;patch=1"
+
+inherit autotools
diff --git a/packages/cdtool/files/.mtn2git_empty b/packages/cdtool/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cdtool/files/.mtn2git_empty
diff --git a/packages/cdtool/files/install-no-owner.patch b/packages/cdtool/files/install-no-owner.patch
new file mode 100644
index 0000000000..9519767350
--- /dev/null
+++ b/packages/cdtool/files/install-no-owner.patch
@@ -0,0 +1,33 @@
+--- cdtool-2.1.8pre4/Makefile.in.orig 2006-06-05 20:38:28.567261984 -0600
++++ cdtool-2.1.8pre4/Makefile.in 2006-06-05 20:38:46.218578576 -0600
+@@ -44,13 +44,13 @@
+ install: install-files install-links
+ install-files:
+ mkdir -p $(DESTDIR)$(bindir)
+- $(INSTALL) cdctrl $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdloop $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdadd $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdown $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir) -o root
++ $(INSTALL) cdctrl $(DESTDIR)$(bindir)
++ $(INSTALL) cdloop $(DESTDIR)$(bindir)
++ $(INSTALL) cdadd $(DESTDIR)$(bindir)
++ $(INSTALL) cdown $(DESTDIR)$(bindir)
++ $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir)
+
+- mkdir -p $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdctrl.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdloop.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdadd.1 $(DESTDIR)$(mandir)/man1
+@@ -58,8 +58,8 @@
+ $(INSTALL) cdtool.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdtool2cddb.1 $(DESTDIR)$(mandir)/man1
+
+- mkdir -p $(DESTDIR)$(libdir)/cdtool
+- $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool -o root
++ $(INSTALL) -d $(DESTDIR)$(libdir)/cdtool
++ $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool
+
+ LINKTARGET = ../lib/cdtool/cdtool
+ LINKS = cdplay cdpause cdstop cdclose cdeject cdir cdinfo cdreset \