aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ckermit
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-05-30 14:46:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-30 14:46:28 +0000
commit2211bf20b22959ede40362acbbc071387ef9b256 (patch)
tree24aff20d22d32b129a8a7ceefd5fdae3631fc619 /packages/ckermit
parentcb32f8279d0c252cbadfe969cd612bcbd5966add (diff)
downloadopenembedded-2211bf20b22959ede40362acbbc071387ef9b256.tar.gz
ckermit 211: Fix for uclibc by disabling arrow key checking, which in turn
prevents it from trying to peek inside the stdio implementation which is what was breaking it.
Diffstat (limited to 'packages/ckermit')
-rw-r--r--packages/ckermit/ckermit_211.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/ckermit/ckermit_211.bb b/packages/ckermit/ckermit_211.bb
index 9bf4c2859e..9a89c9fbbf 100644
--- a/packages/ckermit/ckermit_211.bb
+++ b/packages/ckermit/ckermit_211.bb
@@ -8,6 +8,7 @@ MAINTAINER = "Holger Schurig"
HOMEPAGE = "http://www.columbia.edu/kermit/"
SECTION = "console/network"
SRC_URI = "ftp://kermit.columbia.edu/kermit/archives/cku${PV}.tar.gz"
+PR = "r1"
#
# From http://www.columbia.edu/kermit/ck80.html#license
@@ -63,6 +64,11 @@ export BINDIR = "${bindir}"
export MANDIR = "${mandir}/man1"
export INFODIR = "${infodir}"
+# Additional flags. For uclibc we add -DNOARROWKEYS which stops ckermit
+# trying to look inside the stdio headers.
+CKERMIT_ADDITIONAL = ""
+CKERMIT_ADDITIONAL_linux-uclibc = "-DNOARROWKEYS"
+
do_compile () {
# The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
# so we build wart manually. Note that you need a ckwart.o with the proper
@@ -83,7 +89,8 @@ do_compile () {
-DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
-DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
-DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
- -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI"
+ -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
+ ${CKERMIT_ADDITIONAL}"
}
do_install () {